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About this manual

This manual describes the Impression Publisher software pack-
age. It is divided into the following sections:

1. Introduction

Basic information about Impression.
2. Using Impression 

Describes the features available in Impression.
3. Keyboard short cuts

A list of short cuts available from the keyboard, grouped by
function.

Appendices

1. Updating ABI � this describes what action to take if you
need to update the copy of ABI (the user interface
controller) on your computer.

2. Details of how to use the dialogue boxes in Impression.
Valuable information if you are new to Acorn
computers.

3. Recommended equipment - our hardware suggestions.

4. Hints and tips - may be helpful when using Impression.

5. Complete lists of the standard character set and the
Greek and Dingbats fonts. Plus short samples of the
available text fonts.

6. Borders - the standard and optional borders illustrated.

7. Further information on using different types of printer
with Impression and using PDF files.

8. Details of the loaders provided by Impression for
importing text files from other applications or
computers.

9. History of Impression.

    10. Document description file (DDF).

    11. Glossary.
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Typographic conventions

This section describes the conventions used in this manual.

Menu options

Where you can choose an option from a menu, the name of the
option is shown like this: File ⇒ Save document. This means first
display the File menu then choose Save document.

Dialogue box switches

These are shown as OK.

Keyboard characters

Where you use the keyboard for control, the name of the key is
shown in italics.

Return means the key marked �Return�

Space means the Space bar

F1 to F12 means the function keys along the top of the
keyboard

Ctrl-A means hold down the Ctrl key and then press A or a
Shift-A means hold down the Shift key and then press A or a
Ctrl-Shift-A means hold down both the Ctrl and Shift keys and

then press A or a

Mouse buttons

We use the Acorn convention for the three mouse buttons:

the left-hand button is called Select,

the centre button is called Menu,

the right-hand button is called Adjust.

Where we say click on something and don�t specify a mouse
button, use Select.
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Chapter 1:

Introduction
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Where word-processing and desktop publishing

meet

The microcomputer has brought the way we record our thoughts
and ideas on paper firmly into the modern-day domain of
wordprocessors and, more recently, desktop publishing (DTP)
systems.

A desktop micro running a word-processing program, in conjunc-
tion with a suitable printer, is nothing more than a computerised
typewriter. A DTP package, on the other hand, takes the textual
output of a word processor and lets you arrange it on a page
virtually as you wish, complemented by illustrations made from
scanned images, diagrams, etc., with the facility to resize every-
thing, including pictures, in order to fit the page precisely.

Then, with the aid of the latest hardcopy technology, your work
can be reproduced, as you see it on screen, using dot-matrix
printers, laser printers, or even professional type-setting
machines.

Now, using the sheer power that Acorn RISC OS computers has
brought to personal computing, the concepts of word processor
and DTP have been completely and successfully married to
produce Impression. 

As an example, this manual was written and laid out entirely
using Impression on an Acorn computer. It was printed to a PDF
file using Level 2 and Level 3 Postscript printer drivers ready for
commercial printing.

A complete document processor

Impression is a powerful word processor and a fully featured,
extremely fast, DTP package - a comprehensive document
processor.
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With Impression you can write letters, booklets, business reports,
design advertising copy and posters. Pages can be laid out
precisely on screen whilst retaining all the advantages of a true
word processor, such as text editing with crisp cursor responses
and spell-checking as you type, word counting, search and
replace, cut and paste, and more. 

Text and illustrations can all be imported into Impression
documents, and the Acorn computer windowing system is
exploited to the full.

Impression is entirely written in hand-optimised ARM (Acorn RISC
Machine) code, which means it can update the screen extremely
fast. It is possible to zoom in or out to any scale from 1 to 975%,
either to magnify a portion of your document for detailed study,
or to zoom out for a stepped back view of one, two, or many
more pages on screen at once.

Impression uses the RISC OS outline fonts to ensure that the
representation of the page on the screen is as accurate as poss-
ible. Even large characters are shown smoothly, and smaller text
is displayed using anti-aliasing, a technique intended to make
small text more readable by �smudging� the edges.

And of course everything you see on the screen will be a true
representation of what is printed out; in other words, true What
You See Is What You Get (WYSIWYG).

Desktop publishing is a very wide-ranging discipline. Whilst
Impression gives you all the tools necessary to produce remark-
able documents, making the fullest use of the technology requires
a certain amount of experience. You will probably find it useful to
read one of the many books available on the subject.
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Chapter 2:

Using Impression
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2.1 The basics

This section covers:

• loading Impression

• starting a new document

• loading an existing document

• the Impression window

• the menus

• opening a second window

• closing the editing window

• the clipboard

• scaling your view

• saving the document

• memory management

• typical installation

• quitting Impression 

Related section of this manual:

• 2.2 The Toolbar
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Loading Impression

Double-click on the !Publisher icon to load Impression.

Impression versions

As described in Appendix 9, Impression is now available in three
forms. Impression Style, with version numbers 3.xx, offers most
of the facilities of Impression Publisher (version numbers 4.xx)
with the exception of typesetting, colour calibration via colour
tables, some facilities added since further development of Style
ceased, such as subscript and superscript positioning, word
count, guide frames and page origin control. These facilities are
described here but are highlighted (as shown below) to indicate
that they are not available in Impression Style.

Impression Publisher Plus (latest version is 5.13) adds some
specialist printing enhancements described separately in an �OPI
Supplement'. These include:

EPS – Encapsulated PostScript 
DCS – Desktop Colour Separation
OPI – Open Pre-Press Interface
Improved colour handling with named colours. Also an improved
word count, a case swop tool and a page origin setting for
printing.

Impression-X includes all the facilities of Impression Publisher
Plus and has version numbers in the 5.xx series from 5.75
onwards. It uses dynamic areas to improve memory handling
(dynamic areas lie outside the 28Mbyte WimpSlot limit for 26 bit
applications), allows longer (14 character) filenames, permits
direct import of JPEG images, and allows the DELETE key to be
configured as BBC-style (backspace) or PC-style. The enhance-
ments in Impression-X are described separately.

An example of a feature not available in Impression Style is given
by so marking this paragraph.
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Starting a new document

Click on the Impression icon on the icon bar. This creates a new
document and opens a window onto it.

The new document is a copy of the default document, which is a
normal document held inside Impression. You can edit the
default document, if required, to customise Impression for your
precise requirements. For details see 2.16 Customising
Impression.

Loading an existing document

You can:

� double-click on the document�s icon in a directory window.
(This also loads Impression if you have not already loaded
it.)

� Drop the document�s icon onto the Impression icon on the
icon bar.

The Impression window

This looks like most other RISC OS windows:
Close icon Title bar

Scroll bars

One window will have a yellow Title Bar. This is the current
document. Any typing or other operations apply to this window.

 10 Impression Manual

Impression Publisher



The Close icon

If you have more than one window open on the document (see
below), clicking on the Close icon closes that window.

If you have only one window open onto the document, the Close
icon can work in two ways:

� Clicking on it closes the window and removes the document
from memory. (This is how the Close icon works in most
applications.)

If you have changed the document but not saved those
changes, an Alert box warns you. You then have the choice
of:

   � discarding the changes, 

   � cancelling the close, 

   � hiding the document (that is, closing the window but
      retaining the document in memory) or 

   � saving then removing the document.

� Clicking on it closes the window but the document remains
in memory. To re-open the document, use the Icon Bar
Menu option New view.

The exception is when you create a new document and then
close the window without making any changes. Clicking on
the Close icon always removes a blank document from
memory.

The Remove document on close option in Preferences on the
Icon Bar Menu (described in 2.16 Customising Impression)
controls how the Close icon operates.

Removing the document from memory is described below.

Adjust-clicking on the Close icon closes the window and opens a
directory window onto the document�s parent directory.
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The Title bar

The title bar may look like this

where 

FileName is the name of the document.

2 shows that this is the second window currently open on the
document. (The original window has a space in this position
and not 1.)

at 100% is the current scaling of the window (full size).

* shows that you have made changes but not yet saved them.

The menus

The Main Menu

To display this, click Menu on the Impression window. Most
menu options are selected from the Main Menu.

The Icon Bar Menu

Click Menu on the Impression icon on the icon bar.
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Cursors and pointers

Impression uses two vertical bar-cursors:

� the text cursor which responds to normal cursor controls
such as arrow-keys or Return. 

� the mouse pointer which is controlled by the mouse.

Impression tries to keep the area of text immediately around the
text cursor constantly visible in the editing window. Even if you
scroll the cursor out of the window, typing causes the window to
display the area around the cursor. If you use the arrow keys to
move the text cursor up or down your document, the window
scrolls automatically to keep the cursor in sight.

The text cursor normally blinks to make it more noticeable. You
can make the cursor non-blinking using Flashing cursor in
Preferences in the Icon Bar Menu (see 2.16 Customising Impres-
sion for details).

The shape of the mouse pointer changes depending on the part
of the document it is displayed over. This indicates the action you
can perform.

Scrolling the document 

There are several ways to move the document around in the
window:

� Use the scroll bars and arrows as normal; these are described
in the Acorn User Guide.

� Press and hold down the Ctrl and Shift keys. The arrow keys
on the keyboard then act like the scroll arrows on the
window. Using Ctrl-Shift-arrows does not move the cursor,
only the area of the document in the window.

� When the mouse pointer is over an unused area of the
document it changes shape to a hand. Press and hold down
Select or Adjust and you can slide the document.

The PageUp and PageDown keys scroll up or down by one
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screen.

Opening a second window

You can have up to four windows open on the same document.
Each window or view is totally independent of the others. Any
window can view any part of the document and be scrolled
freely. Each window can be scaled individually using
View ⇒ Scale view while the pointer is over the required
window.

To open a new view:
� Choose View ⇒ New view on the Main Menu or press Ctrl-

Shift-F1 to open a new window onto the current document.
� Choose New view on the Icon Bar Menu. This displays a list

of documents currently in memory. Choose a document
name to open a new window onto that document.

Removing the document from memory

Either:
� use File ⇒ Discard document (keyboard short cut Ctrl-F2),
� use the Discard document submenu on the Icon Bar Menu

(this lets you discard any document currently in memory),
or, if the Remove document on closing option is set in the
Icon Bar Menu Preferences, 

� close all the windows on the document.

You are warned if the document includes unsaved changes. You
can then save the document before it is discarded.

Scaling your view

The initial view of the window is 100% (full size). It�s often useful
to enlarge your view of the document to examine details or
reduce your view to get an overall impression. Scalings over 100%
show an enlarged view; below 100% a reduced view. All you
change is your view of the document. The size of the document
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and the objects in it are unchanged.

The size of your monitor screen, the screen mode and vertical
and horizontal adjustments on your monitor can distort the
dimensions of the document on screen. This means that a
document displayed at 100% is unlikely to be at its true size.

Some screen modes (such as 12 or 20) cannot display the full
width of an A4 page. You need a scaling of about 90% to see the
full width.

You can either use the Scale view dialogue box or the Zoom tool.

Scale view dialogue box 

To display the Scale view dialogue box choose: 

� View ⇒ Scale view or 

� Ctrl-F9 or

� Select-clicking on the Scale tool.

Change the scaling by:

� clicking on one of the preset boxes. Click on Scale to make
the change.

� entering a value between 1% and 975% into the edit field.
Click on Scale to make the change.

� for small changes, clicking on the bump icons to the right of
the edit field. Click on Scale to make the change.

� clicking on Scale to screen. This selects the best scaling to fit
a complete page (or pair of pages) on the screen.

� clicking on Scale to window. This selects the best scaling to
fit a complete page (or pair of pages) in the window.
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� clicking on Previous zoom. This cancels any previously
applied zoom. (Adjust-clicking on the Scale tool on the
Toolbar has the same effect.)

� clicking on Zoom. This duplicates selecting the Zoom tool
from the keyboard.

There are also keyboard short cuts:

� Shift-Fkey lets you scale between 20% (Shift-F2) and 100%
(Shift-F10). Shift-F3 to Shift-F9 give you the intermediate
10% steps (30% to 90%).

� Shift-F11 halves the current scaling (say from 150% to 75%).

� Ctrl-Shift-F11 doubles the current scale (say from 60% to
120%).

For large changes in scaling it is usually quicker to use the
dialogue box rather than repeated use of Shift-F11 or Ctrl-Shift-
F11. This is because each step caches the fonts for the new scale.

The Zoom tool from the keyboard

Hold down the Ctrl and Shift keys. The mouse pointer changes
shape to a magnifying glass. You can now:

� Click Select. This doubles the current scale (this is the same
as pressing Ctrl-Shift-F11). The enlarged view is centred on
where you clicked.

� Click Adjust. This halves the current scale (this is the same as
pressing Shift-F11). 

� Press and hold down Select. Dragging the mouse draws a
rectangle. When you release Select, the area within the
rectangle is enlarged to fit the window.

Saving documents

Impression can store documents in either of two formats:

� as a single file, or

� as a directory. (With either option you see a single icon in a
directory window.)

Single file format has these advantages:
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� Files are smaller. This is useful for short documents such as
letters.

� Directory windows show the file size. (You must use Count

on the filer menu to find out the size of a directory.)

� File names can be ten characters long; directory names are
nine characters plus a leading !.

� You can print a single file document by dragging its icon
onto the printer icon on the icon bar.

It has this disadvantage:

� It is unsuitable for large documents. Impression loads the
entire single file document into memory. With documents
saved as a directory, Impression can load just part of a
document. (The part being worked on.) This means that
documents saved as a directory can be much larger than the
memory in your computer.

Single file document in File ⇒ Preferences selects the save format.
Ctrl-Shift-F3 toggles between the two formats.

You can save a document in either format and change between
formats. (Unless the document is too large to be saved as a single
file.)

If you want to change the default save format, you can edit the
default document. This is described in 2.16 Customising
Impression.

The single file format used by Impression Publisher is incompat-
ible with similar, older formats used in Impression II and
Advance. Files saved in the new format cannot be read by
Impression II or Advance. (Impression Publisher can read these
older format files.)
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the first time, drag the icon 
to the destination directory window

OK button should only be used
if the document has already been
saved to disc. It makes sure the disc
is completely up-to-date

When saving a document for

Filename

Saving a document

On floppy-disc systems, if the current document is on one disc
and the document is being saved to another, you may be
prompted to swop floppy discs.

Saving a document for the first time or 

Saving to a different filename

Display the save box using:

� File ⇒ Save Document or

� F3 or

� the Save tool.

Type in a suitable filename and then drag the Impression icon to
a directory window.

Saving a document either to a different directory or with a
different name generates a new document on disc and is much
slower than saving to the same filename. 

To backup a document you save the document to the current
filename (which becomes the backup) and then save the docu-
ment again using a new name (which becomes the current
document). If you number your files (such as Manual1,
Manual2, Manual3 etc.) you will find it easy to keep track of the
backups. We cannot stress too strongly that you should always
make ample backups. Even if you have a hard-disc, you should
regularly save documents to floppy discs for security. Similarly,
on a floppy disc system, you should use several different floppy
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discs for storage. Modern discs are reliable but failures do occur.
Remember that an Impression document can represent many
hours of typing and layout work.

Subsequent saves

The easiest ways are to click on the Save document menu option
or type F3-Return. 

You can also display the save box (see above) and click on OK. 

Impression only saves the information that has changed since the
last save.

Saving stories & graphics

For information on text and selected text see 2.3 Text handling
For information on graphics see 2.9 Graphics handling.

Use 

� File ⇒ Save text/graphics/selected or

� Ctrl-F3 or

� Adjust-click on the Save tool. 

The menu option reads:

Save graphics if you have clicked in a graphics frame, 

Save text story if you have clicked in a text frame and there is
no selected region, or

Save selected text if there is a selected text region.
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Save graphics

Sprites are saved as Draw files; other types of graphic are saved
in the same format used to import them into Impression (Draw,
ArtWorks, Equasor etc.).

Save text story /Save selected text

The Selection button is greyed unless there is a selected region
of text. It allows you to save either the current text story or just
the selected region.

Selecting Linefeeds saves the text with a Line feed (code 10) at
the end of each line.

Selecting Returns saves the text with a Return (code 13) at the
end of each line.

Selecting both Linefeeds and Returns saves the text with Return
and Linefeed on the end of every line. 

If neither button is pressed, then the text is saved with only those
Return characters that you specifically typed in. This is probably
the most useful option for saving plain text into another word
processor.

If With styles is selected then any effects and styles used in the
text are output as a special ASCII control sequence. This allows
you to incorporate the text into Impression in the future and all
styles and effects will still be present.

� If text is going to be re-loaded into Impression, then select
only With styles.

� If text is going to be used in a text editor such as Edit or
Twin, then it is usually preferable to select only Linefeeds.

� If text is going to be used for sending to an electronic mail

system, then select only Returns.
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Impression remembers the filename so that subsequent saves can
be performed simply by clicking the OK button in the dialogue
box � it is not necessary to drag the file icon.

The Save text option supports in-memory transfer, so you can
drop the file icon onto another program�s window to transfer the
text directly to the other program.

Auto-saving

Auto-save lets you automatically save an edited document to disc
at regular intervals. (This is a big help in ensuring that the disc file
is kept fully up-to-date.) File ⇒ Preferences displays the dialogue
box that controls auto-saving:

The operation can be entirely automatic or an Alert box can pop-
up to prompt you when it�s time to save the document. (You are
always prompted the first time the document is saved after
loading,) The time interval is user-defined between 1 and 99

minutes. Auto-saving only saves if there has been a change made
to the document.

After the time interval has elapsed, Impression waits until the
computer is inactive (nothing has happened for 3 seconds) and
then auto-saves. (This ensures that you won�t get interrupted in
the middle of typing.)

If you have With prompt set, saving is not automatic; at each time
interval an Alert box prompts you. Click on OK of the Alert box to
save the file. With this option you can postpone the save. (Useful
if you are in the middle of an edit.)

Each document has its own set of auto-save settings. This allows
different documents to have auto-save enabled or disabled and to
have different time intervals. The settings are stored with the
document and used whenever that document is loaded into
memory.
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Loading documents from Impression II &

Impression Junior

(These are earlier versions of Impression Publisher.) You can load
documents created in these applications. Loading does not alter
the document � it appears on screen exactly as it does in Impres-
sion II or Impression Junior. However, editing the document
converts it to Impression Publisher format and its appearance may
change. The File ⇒ Preferences dialogue box gives you extra
controls for such documents:

Impression Publisher can make use of the auto-kerning tables in
some RISC OS 3 fonts. (These tables adjust the spacing between
letter pairs.) Automatic kerning gives you control over whether to
use auto-kerning tables.

This switch is automatically set to off when loading documents
created using older versions of Impression to ensure their
appearance is unchanged.

Similarly, the operation of rule-offs has changed slightly from
older versions of Impression. Rule-offs in older documents could
change if New rule offs is on. (2.6 Styles has more information on
kerning and rule-offs.)

Loading Advance documents

(The Advance package, sold by Acorn, contains a word processor
based on Impression Junior.)

You can load files produced in Advance. You cannot save
documents in Advance format.

 22 Impression Manual

Impression Publisher



Info boxes

Impression has two Info boxes:

� One on the Icon Bar Menu (Info) gives information about the
Impression application:

The most significant item is Version. If, for any reason, you
contact your supplier for support concerning Impression,
you may be asked for the exact version number and date of
the copy that you�re using.

� The second Info box (File ⇒ Info, Ctrl-F1) gives information
on the current document:

To remove the Info box from screen, perform some action on the
main window. This could be typing something, moving the
window, or moving the cursor.
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The title bar may read
Info on ‘document’ Original

 if the document has not changed since the last save, or
Info on ‘document’ Modified

if you have made changes and not yet saved them. If you have
unsaved changes, the document title bar also has an asterisk (*) to
the right of the document name.

Document

Pages - the total number of pages in the document.

Cur page - the number of the page containing the selected frame.

Size - the total size of the document including all text and
graphics. This is the amount of space the document will
occupy on the disc.

Memory - the amount of memory occupied by the current
document. For smaller documents, Memory and Size will be
equal, showing that the whole document is resident in
memory. If there is insufficient space for the entire document
in memory, part of it is saved to disc.

This value for memory usage is always greater than the sum
of text memory and graphics memory. This is because
additional space is required to hold details of the document�s
structure.

Text

Stories - the total number of text stories in the document.

Memory - the total memory required by all the text stories
currently resident in memory.

Chapters - the total number of chapters in the document.

Words - the number of words in the current story.

Graphics

Pictures - the number of pictures (graphics) in the document.

Memory - the memory occupied by those graphics currently
resident in memory. This is 0 if all graphics have been saved to
disc.
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Impression Help system

This is controlled from Help.

Contents provides a list of subjects in the on-line documentation.
Choose this if you are unused to on-line documentation.

Interactive help provides the standard Acorn help system.

The remaining options (which may vary from those shown in the
illustration) provide fast access to specific areas of the on-line
documentation.

Memory management

Files saved as a directory can be larger than the available memory
by holding non-current parts of the document on disc. Usually
this is only done automatically when memory is getting short.
However Minimise memory on the Icon Bar Menu saves all non-
current parts of the document to disc and reduces the memory
requirements of Impression as much as possible.

Impression always keeps the text of the current chapter in
memory. If a graphic is selected then this is also kept in memory.
Therefore this menu option only has an effect if a document
consists of more than one chapter or contains any graphics. It
always saves any non-current documents to disc (if they have
been loaded from file, or have been saved to file at least once). 

Because of this feature, Impression always treats the document on
disc exactly as if it were part of the document in memory. This
has several consequences. For example, it is not possible to
rename a file on disc while it is in Impression as this is rather like
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removing part of the document. Impression cannot stop you
using the filer Rename and Delete options and so we can only
warn you: Never rename or delete a document file from the disc
while it is currently being held as an Impression document.

All sections of the document that have been saved to disc will
show their frames as crosses. Clicking in any crossed-out frame
restores that section to memory again (possibly saving some other
part of the document to disc in the process if there is not enough
memory to fit it all in). Therefore it is possible to scroll around all
pages in a document, irrespective of its length. Those sections
resident in memory show normally; those sections that have been
saved to disc show as crossed frames.

Typical Installation

The main applications provided with Impression-X, Publisher or
Style should either be placed in the directory �Apps� on your boot
drive or be included in either the �Add to Apps� or �Look at�
configuration options. This ensures that an Impression document
will load correctly when double-clicked.

On 32 bit systems, Aemulor should be set to include these
applications in the list of software that requires 26 bit support.
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Where on disc should things go?

Loaders for graphics files:
- 'Clear' (filetype &690)
- 'JPEG' (filetype &C85)
- 'PhotoCD' (filetype &BE8)
- 'TIFF' (filetype &FF0)

Other applications

Equation editor

The main application

Table editor

Font convertor (TTF to RISC OS)

Dictionary and Thesaurus

Directory of Hard Disc
239 files, 9 Mbytes

74 files, 887 kbytes
Boot:Resources

27 files, 601 kbytes
!AWViewer

47 files, 286 kbytes
!System

47 files, 286 kbytes
!CCShared

7 files, 22 kbytes
!TransClr

11 files, 98 kbytes
!TransJPEG

7 files, 14 kbytes
!TransJPG2

11 files, 47 kbytes
!TransPCD

11 files, 103 kbytes
!TransTIFF

163 files, 5 Mbytes
Apps

6 files, 122 kbytes
!Equasor

129 files, 2221 kbytes
!ImpressX

9 files, 107 kbytes
!TableMate

9 files, 973 kbytes
!TTF2f

10 files, 2165 kbytes
!WordWorks

2 files, 3301 kbytes
ImpDocs

Manual/pdf
15:06:28 13-Mar-2020

Tutorial/pdf
13:27:22 13-Mar-2020



Quitting Impression

It is good practice before you switch off your computer to quit
any applications that may be loaded. This is especially true with
Impression as some of the files (such as auto-loaded dictionaries)
are only updated when you quit Impression.

With RISC OS 3 you can either quit applications individually or
use Shutdown.

To quit only Impression, choose Quit on Impression�s Icon Bar
Menu.

We strongly recommend that you always quit Impression before

you switch off the computer.

If you have a document loaded with unsaved changes, an Alert
box warns you. You then have three options:

� save the document and then quit,
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� quit without saving the document and so discard the
changes, or

� cancel the Quit request.
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2.2 The Toolbar

This section covers:

• using the Toolbar

Related sections of this manual:

• 2.1 The basics

• 2.3 Text handling

• 2.4 Printing

• 2.5 Effects

� 2.6 Styles

� 2.7 Rulers

• 2.8 Frame handling

• 2.9 Graphics handling

• 2.13 Spell checking & the dictionaries

• 2.16 Customising Impression

29 



 30 Impression Manual

Impression Publisher



The toolbar provides a quick and simple way of selected many
commonly used functions. The toolbar has three horizontal rows
of information:

Button bar

Text bar

Ruler bar

The View ⇒ Tool bars submenu controls which bars are
displayed:

Ctrl-Shift-R turns the current selection on or off.

You can also display the bars using Preferences on the Icon Bar
Menu (2.16 Customising Impression describes Preferences in
more detail.)

Button bar

a b c d e f g h i j k l m n o p q

This gives you general information and lets you easily select
frequently used functions.

Screen mode 12 and similar modes cannot display the full width
of the button bar and so crop the right-hand side of the bar. For
this reason, the most frequently used functions are on the left of
the button bar.

The first two options give information. You cannot edit them.
a Chapter/page number. This tells you the chapter and page

number for the selected frame. 

These numbers use Impression�s internal numbering system
which starts from chapter 1 page 1 and continue sequentially
throughout the document. These numbers are independent
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of any page or chapter numbers shown on the individual
pages.

b Information field. This gives information on either the
current frame or the selected action.

The next three buttons select display options. Click on the button
to select or deselect the option. Selected buttons have an orange
background.

c Show flow. This shows how a text story flows from frame to
frame. Refer to 2.3 Text handling for information on flowing
text stories. It also displays the page grid � see 2.8 Frame
handling for details.

This duplicates Show flow on the Icon Bar Menu.
d Frame outlines. The outline of the current frame is always

displayed. This button controls the display of the outlines of
other frames. Turning outlines off can make it easier to see
how the document will look when printed.

It duplicates Show frame outlines in Preferences on the Icon
Bar Menu and keyboard short cut Ctrl-O.

e Frame snap. This helps you accurately align frames when
moving or creating frames. Refer to 2.8 Frame handling for
more details.

The button is shown on when any of the snap options
(Frames, Guides or Grid) is on. Click on the button to toggle
the current snap selection on or off.

The following buttons provide short cuts to commonly used
functions:

f Save/Save text or graphics. Select-click on this button to
display the Save dialogue box (keyboard short cut F3).

Adjust-click to display the Save text/graphics dialogue box
(keyboard short cut Ctrl-F3)

Refer to 2.1 The basics for more on saving.
g Scaling. Select-click on this button to display the Scale view

dialogue box (keyboard short cut Ctrl-F9).

If you have previously altered the scale, Adjust-clicking on
this button returns to the previous scale value.
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h Cut.  This cuts to the clipboard (removes) either the selected
region of text including any styles and effects (if there is one)
or the current frame.

Refer to 2.3 Text handling for cutting text; 2.8 Frame
handling for cutting frames.

i Copy. This copies to the clipboard (retains in place) either
the selected region of text (if there is one) or the current
frame.

Refer to 2.3 Text handling for copying text; 2.8 Frame
handling for copying frames.

j Paste. This pastes the clipboard contents.

Refer to 2.3 Text handling for pasting text; 2.8 Frame
handling for pasting frames.

k New frame. Select-clicking displays the New frame menu.

Adjust-clicking is a short cut for Blank frame.

Refer to 2.8 Frame handling for more details.

l Change frame stacking order. These move the selected frame
or frames in front of or behind any overlapping frames. The
top two buttons move the selected frame towards the front;
the bottom two buttons towards the back. The right-hand
buttons move the selected frame to the front or back in one
operation. The left-hand buttons step the selected frame
towards the front or back.

Refer to 2.8 Frame handling for more details.
m Spell checker/dictionary. Select-clicking displays the

Utilities ⇒ Spelling menu.

Adjust-clicking displays the main dictionary.

Refer to 2.13 Spell checking & the dictionaries for more
details.

n Insert. Select-clicking displays the Utilities ⇒ Insert menu.

Adjust-clicking inserts the current date at the cursor.

Refer to 2.3 Text handling for more details.
o Print. This displays the print dialogue box. Refer to 2.4

Printing for more details.
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p Quality. Select-clicking (or Menu-clicking) displays the
View ⇒ Quality menu.

Adjust-clicking selects Quality 10.

Refer to 2.9 Graphics handling for more details.
q Alter frame/graphics. Select-clicking displays the Alter frame

dialogue box. Refer to 2.8 Frame handling for details.

Adjust-clicking displays the Alter graphics dialogue box if
the selected frame is a graphics frame. Refer to 2.9 Graphics
handling for details.

Text bar
This bar gives you information on the current text font and size
and lets you apply and remove the most commonly used effects.
You can also define a new style or redefine an existing style using
the Define button

a b c d e f g h i

a Define. This provides a quick way of defining a new style or
modifying an existing style. Refer to 2.6 Styles for more
information.

b Style. Click on the menu icon to display a menu of available
styles. This provides a quick way to apply or remove styles
from the cursor or selected region of text. Refer to 2.6 Styles
for more information.

c Text effect/Tabs. Click on the top radio button to display the
text effects buttons.

Text effects

For more details of these options refer to 2.5 Effects.

The + is black if there are any effects applied at the cursor or in
the selected region.

d Text font. Displays the current font. This is set by a text font
effect (if any) or a style. It is blank if there more than one
font used in a selected region.
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Clicking on the menu icon displays a menu of available font
families. This duplicates Effects ⇒ Text font.

e Text size. Displays the current font size. This is set by a text
size effect (if any) or a style. It is blank if there more than
one text size used in a selected region.

To change the text size either:

� type the new value into the editable field, or

� click on the menu icon and choose from the menu.

This duplicates Effects ⇒ Text size.

f Bold. This duplicates Effect ⇒ Bold and applies or removes
the bold text effect.

g Italic. This duplicates Effect ⇒ Italic and applies or removes
the italic text effect.

h Underline. This duplicates Effect ⇒ Underline and applies or
removes the underline effect.

i Alignment. This duplicates Effect ⇒ Alignment and selects
(from left to right) left-justify, right-justify, centered, fully
justified.

a b c d e

The tabs and margins, when placed on the ruler, allow you to
change the layout of your document. For more details of these
options refer to 2.7 Rulers.

a Text effects/Tabs. Click on the bottom radio button to
display the tab and margin options.

b Select tab. Use these bump icons to select tabs on the ruler,
showing their exact position as you move left and right.

c Tab icons. This displays the available tabs. You can drag
icons onto and off the currently displayed style ruler.

d Tab position. This shows the position of the currently
selected tab. You can edit this field to move the tab. (You
can also drag the tab along the ruler.)
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e Units. This selects the units used on the ruler. Options are:
� centimetres,
� inches (1/10 ths of an inch divisions),
� picas (6 picas = 1 inch),
� inches (1/8 ths of an inch divisions).

The ruler

This is described in 2.7 Rulers.
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2.3 Text handling

This section covers:

• entering text

• deleting text

• selecting regions of text

• importing text

• exporting text

• search & replace

• the Insert menu option

• swop case

Related sections of this manual:

• 2.10 Master pages

• 2.11 Chapters

• 2.13 Spell-checking & the Dictionaries

• 2.16 Customising Impression 
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Entering text

You can only enter text in the selected frame. (The selected frame
has a green outline � for more on frames see 2.8 Frame han-
dling.) Position the mouse pointer where you want to insert text
and click Select. If you click

� within some text, the cursor appears at the pointer,

� beyond the end of the text, the cursor appears at the end of
the text,

� in an empty frame, the cursor appears in the top left-hand
corner of the frame.

You can now start typing and, as you type, the cursor moves
along the line. 

When you reach the edge of the frame, the cursor automatically
drops down to the next line � you don�t need to press Return as
you would on a normal typewriter. This means that if you later
add or delete something in the middle of a paragraph, the line
lengths automatically adjust to suit the new text.

Pressing Return indicates the end of a paragraph and an optional
extra vertical gap appears between the end of the last line and the
beginning of the next. The size of this gap is set by Space below

paragraph in the current text style (see 2.6 Styles).

You can also import text from a disc file. This is described later in
Importing text.

When text fills a frame it attempts to flow into another linked
frame. (Linked frames are described in 2.8 Frame handling.)
Usually Impression creates extra pages as needed. This is
described in more detail in Automatic page creation.
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Truncated text

If there is no linked frame available, the excess text is not
displayed. The hidden text is truncated. A small red arrow appears
in the bottom right-hand corner of a frame that contains truncated
text.

 
(These arrows are not displayed if you have turned off frame
outlines.)

Similar arrows are displayed if you choose Show flow in the Icon
Bar Menu or the Show flow tool. 

The Show flow tool
The number underneath the frame is the number of unplaced
words.

The Alter frame dialogue box indicates if the frame has truncated
text and the number of unplaced words. (This dialogue box is
described in 2.8 Frame handling.)
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Moving around the text

You can move the cursor using the arrow keys ←↑↓→. 

Using the arrow keys by themselves moves the cursor one line up
or down or one character left or right.

Hold down the Ctrl key and:

← - moves to start of line,

→ - moves to end of line,

↑ - moves to the start of the story, and

 ↓ - moves to the end of the story.

The Home key acts like Ctrl-↑.

You can also move to a specific page or chapter using
Utilities ⇒ Find ⇒ Go to page or Utilities ⇒ Find ⇒ Go to chapter.

Deleting characters

You can delete characters by using these keys:

� Delete - deletes the character to the left of the cursor,

� Backspace - same as Delete,

� Ctrl-H - same as Delete,

� Copy - deletes the character to the right of the cursor.

Selecting a region of text

At some stage you will want to delete or copy some text. Before
you can do this, you have to select that text. There are several
different ways of doing this. Three ways can be used to select text
of any length; the others select a defined length of text (a word, a
line, a paragraph, or a story). The selected text is always shown
highlighted like this.

If you want to alter where the selected region ends, position the
mouse pointer to the required place and click Adjust. This lets
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you extend or reduce the selected region. You can also use Shift
plus the cursor keys. (See Using the cursor keys below.)

Selecting any length of text

Dragging the mouse

1 Position the mouse pointer over the start of the region. 

2 Press and hold down Select and drag the mouse pointer to
the end of the required region. As you drag the mouse, the
selected region becomes highlighted. 

3 Release the mouse button when you reach the end of the
region.

Clicking the mouse

1 Position the mouse pointer over the start of the region and
click Select. 

2 Move the mouse pointer to the end of the region. 

3 Click Adjust and the region becomes highlighted. 

This is the easiest way for selecting a large region of text. 

Using the cursor keys

1 Position the cursor at the start of the region. 

2 Hold down Shift. You can now use the ↑↓←→ keys to
move the end of the selected region.

Selecting a word

Either

� double-click on the word, or

� type Ctrl-Q.

(Double-click means press and release Select twice in quick
succession.)
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Selecting a line

Either

� position the mouse pointer anywhere on the line and triple-
click (three times) on Select, or

� type Ctrl-L.

Selecting a paragraph

Either

� position the mouse pointer anywhere in the paragraph and
quad-click (four times) on Select, or

� type Ctrl-2.

Selecting the whole story

Either

� type Ctrl-A, or

� use Edit ⇒ Select text story.

A story is a self-contained block of text. It could fit in a single
frame or flow across many frames on several pages. You cannot
have more than one story in a frame. Stories cannot flow between
chapters (see 2.11 Chapters).

Select text story selects all the text in the current story. This is
much quicker than putting the cursor at the start of the story and
drag-selecting the entire story.

This option would normally be used to apply a style or effect over
the entire story or delete or copy the entire story.

Deselecting a region of text

If you no longer want the region of text selected, you can:

� type Ctrl-Z, or

� press one of the arrow keys, or

� click in the region keeping the mouse stationary, or

� click outside the region. 
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Replacing text (overwrite mode)

Unlike many older word-processors, Impression does not have a
replace or overwrite mode. Instead, select the region that you
wish to replace (see above). When you start typing, the selected
region is cut to a special area of memory (called the Clipboard)
and your new typing appears in its place. (If a large region is
selected, an Alert box asks for confirmation before replacing.)

If you have made a mistake, you can restore it by pasting it back.
(See Cut & Paste.)

Importing text

You can import text from outside of Impression. If the frame
already contains some text, you must first position the cursor
where you want to make the insertion. No action is needed if the
frame is empty.

Plain text or text from other Impression documents can be
incorporated simply by dropping their file icon onto the required
frame.

Text in certain other formats can be imported but you must first
load an appropriate loader module. In the Impression package,
modules are included for Acorn DTP, BASIC, C, CSV, FirstWord
Plus, Inter-Word, Pipedream, RTF, WordPerfect, WordStar, and
Wordwise Plus formats.

See Appendix 8: Loading alien file formats for more details of
importing text.
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Moving blocks of text

Impression has two ways of moving text � Drag & Drop and Cut
& Paste.

Transferring a region of text also transfers any embedded frames
with the region. (For more information on embedded frames, see
2.8 Frame handling.)

Drag & Drop

You can Drag & Drop within a document. You cannot use it
between documents.

1 Select the region of text you want to move.

2 Move the pointer over the selected region.

3 Press and hold down Select. The pointer changes shape.
You can now drag the selected region to its new location in
the document. (A red cursor shows the insert point.)

If you want to copy the region and not move it, hold down Shift
as you drag the selected region in step 3.

To position the cursor in the selected region (rather than Drag &
Drop), press and hold down Select. (See also Deselecting a
region of text.)

Cut & Paste

You can Cut & Paste within the same document or to another
document.

You can either copy the text (which leaves it in place) or cut it
(which removes it from its original position).

Cutting or copying text may fail because of lack of memory; an
Alert box tells you if this happens.

Copying to the clipboard

First select the text then either

� type Ctrl-C, or

45 

2.3 Text handling



� click on the Copy tool on the Toolbar, or

� use Edit ⇒ Copy text.

Cutting to the clipboard

First select the text then either

� type Ctrl-X, or

� press the Delete key, or

� click on the Cut tool on the Toolbar, or

� use Edit ⇒ Cut text.

There are two other cut options; Cut line and Cut word. To use
these, position the cursor anywhere inside the line or word. You
do not have to select the text.

� To cut the line containing the cursor, type Ctrl-Copy. 

� To cut the word under the cursor, type Ctrl-D.

Deleting

Deleting removes the text completely; no copy is made to the
clipboard. It is useful if you want to delete and discard a large
region of text without affecting the clipboard.

Either

� type Ctrl-K, or

� use Edit ⇒ Delete text.

An Alert Box asks you to confirm the delete. 

Pressing a Delete key cuts the selected region to the clipboard. It
does this rather than delete as you can then undo the action using
Paste. However, as cutting to the clipboard holds the text in
memory, this operation may fail because of lack of memory. In
this case delete the text using Delete text rather than Cut text.
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Pasting (Inserting) an item

You always paste the item held on the clipboard.

Text is pasted at the current cursor position or overwrites the
selected region of text.

Either:

� press the Insert key,

� type Ctrl-V, or

� click on the Paste tool on the Toolbar, or

� use Edit ⇒ Paste text.

Pasting preserves the clipboard contents so you can paste more
than once.

Automatic page creation & deletion

Creating pages

There are two options for creating new pages:

� Copy master page. When text flows out of a master page
frame and there is no other frame for it to flow into, Impres-
sion creates a copy of the current master page. This is the
usual option. (For more information on master pages see
2.10 Master pages.) 

� Copy previous page. When text flows out of any frame
(master page or local) and there is no other frame for it to
flow into, Impression creates a new page with copies of the
frames from the previous page. Local text or blank frames
are copied from the previous page but text frames are empty.
Local graphic frames are only copied if they are grouped
frames.
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The choice of options is controlled by the New chapter dialogue
box. The page creation rule used in any chapter is shown in the
Alter chapter dialogue box. 

(These dialogue boxes are described in 2.11 Chapters.)

Documents created in Impression Junior (an earlier version of
Impression Publisher) don�t have master pages and so if these
documents are loaded, they will always use the Copy previous

page method.

If your document uses local frames for flowing text stories and
Copy master page is the selected option, Impression does not
automatically create extra pages. You must do this manually using
Edit ⇒ Insert new page. This creates a new page following the
current page, containing all the frames from the master page. If
your document consists solely of pages created automatically as
text is entered, then this option has little use � Impression always
creates pages as you type. However, this option is useful if you
want to include blank pages in a document. If you have pages
with local frames on, inserting a new page shifts all those pages
along.

Another use is when the master page consists only of Guide
frames. In this case, there is no master text frame, so no new
pages are created as you type. Every time you wish to start a new
page, you can use Insert new page, then add any frames neces-
sary to your page. This method is likely to be used when creating
a magazine, where column widths may be fixed, but the height
and layout of the columns varies from page to page.

If you create a new page by using Insert new page, any frames on
that new page are not linked to other frames, as they would
normally be if the page was automatically created. You may
therefore need to link the frames to create a flowing text story.
For details of this operation, refer to Flowing text in 2.8 Frame
handling.
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Do not use this option if you just want to force text to start at the
top of the next frame. For this, use Frame ⇒ Force to next. (This
has a keyboard short cut of Ctrl-G.)

Deleting pages

Edit ⇒ Delete page deletes the page that contains the currently
selected frame and all frames on that page. Because text and
graphics may be irretrievably lost, you are asked to confirm the
action.

If you try to delete a page that was automatically created and has
no changes made, then the text story will no longer fit within the
available frames and so Impression automatically creates another
new page. It might appear that nothing has happened. 

If the amount of text is reduced so that there are surplus pages,
these are deleted by Impression. 

Therefore, Delete page is normally used to delete pages that:
� have no flowing master text frames or 
� have new local frames placed on them or
� were created using Edit ⇒ Insert new page.

You cannot directly delete a blank page as, by definition, a blank
page has no frame to select. You must first create a new frame on
the blank page and then select this option.

If the page is based on two facing pages, both pages are deleted.

If a chapter has only one page, use Edit ⇒ Delete chapter. 

Hard space

Sometimes you don�t want the end of a line to divide two pieces
of text. Examples are telephone numbers (0442 63933) and word
pairs like RISC OS. In such cases, use a hard space (Alt-space)
between the two parts. This has the appearance of a normal space
but Impression never splits text joined by a hard-space. 

Also, when text is fully justified, normal spaces may be stretched
to increase the separation between words. A hard-space is treated
as a fixed-width character and is never stretched.
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The Character fonts

These are a special family of fonts for use only with documents
that are to be printed as pure text using the Draft print option.
(Draft printing is described in 2.4 Printing.) They are also useful
if you want to use Impression as a text editor where it is impor-
tant to have the text as clear and as readable as possible. 

Unlike the other fonts, they are bit-mapped and not outline fonts
and should not be used with the conventional RISC OS printer
drivers. (If printed using the RISC OS printer drivers, they will
give a poor-quality result.)

At 16pt no anti-aliasing occurs and these fonts do not have the
fuzzy appearance of other fonts; Character font text appears crisp
and sharp on the screen. At larger or smaller sizes, they may
appear slightly fuzzy. If you want to use the Character fonts at
smaller sizes and still want a sharp image, it is possible to use
13pt text and 120% window scaling.

Letters and other characters in the Character monospaced fonts
are (as the name suggests) all of the same width. They are
suitable for 9-pin and those 24-pin printers that cannot support
proportional printing. They are almost identical in appearance to
the system font.

The other Character fonts are proportionally spaced (the charac-
ters vary in width), and are suitable for those printers that support
proportional printing. You will probably find that the propor-
tional fonts are easier to read when displayed on the screen.
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The Insert menu option

Use Utilities ⇒ Insert or the Insert tool.

 Use this to insert the current:

� page number,

� chapter number,

� date,

� time,

and control sequence numbering.

Current page number

Current chapter number

Normally page and chapter numbers start from 1 at the beginning
of the document. The Alter chapter and New chapter dialogue
boxes let you reset the numbering at the start of any chapter. See
2.11 Chapters for details of these dialogue boxes.

If you insert a page or chapter number on a normal page, it shows
the correct number. It automatically updates if subsequent edits
or adding or deleting chapters change the page or chapter it
appears on. 

Page numbers on master pages are shown as <pn>; the correct
page number is substituted on all normal pages based on that
master page. Similarly, chapter numbers are shown as <cn> on
master pages. 

You can apply styles and effects to page and chapter numbers.
Impression treats page and chapter numbers as single characters �
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you cannot delete or modify just part of a multi-digit number.

Page and chapter numbers can be

� numeric 1 2 3 4,

� upper case Roman I II III IV, or

� lower case Roman i ii iii iv.

Current date

Current time
Insert current date has a short cut of Ctrl-Shift-D or you can
Adjust-click on the Insert tool.

These read the current date or time from the computer�s internal
clock. You can edit the inserted values as normal text. Note that
the inserted values do not update automatically; they show the
date and time when you inserted them.

Sequence numbering

Many types of document include sequentially numbers. Examples
are specifications, operating instructions and parts lists. Controll-
ing this numbering is easy in Impression.

You can either:

� insert numbers individually, or

� select several paragraphs and number the paragraphs in one
operation.

If you later remove one of the numbers or add another one in the
sequence, subsequent numbers change to reflect the change. 
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Inserting numbers individually

1 Position the cursor where you want to start the numbering.

2 Insert the initial number using Utilities ⇒ Insert ⇒ Initial

number.

3 To insert subsequent numbers, position the cursor and use
Utilities ⇒ Insert ⇒ Subsequent number (or Ctrl-Shift-F9).

If the sequence starts from 1, you can also insert the initial
number using Utilities ⇒ Insert ⇒ Subsequent number. 

Numbering several paragraphs in one operation

1 Select the paragraphs you wish to number.

2 Choose Utilities ⇒ Insert ⇒ Number region (or Ctrl-Shift-
F10). This displays a dialogue box (described below).

3 Set up the dialogue box as required and click on OK.

This inserts a number or bullet point at the start of each
paragraph you selected. Numbers can be preceded and
followed by optional characters (such as brackets) and then
a Tab.

Sequence numbering menu options:

Initial number

Use this option for the first number in the sequence. Numbering
can be:

� numeric (1, 2, 3...)
� upper-case roman (I, II, III...)
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� lower-case roman (i, ii, iii...)
� upper-case alpha (A, B, C,...)
� lower-case alpha (a, b, c,...)
� bullet points (�).

Subsequent number

Keyboard short cut Ctrl-Shift-F9

Use this option to insert the next number in the sequence.

Number region

Keyboard short cut Ctrl-Shift-F10

This option provides a quick way to number several paragraphs.
It also gives you extra controls.

À Á
Â

Ã

À Character before/after

This lets you insert a character before or after the number (such
as enclosing the number within brackets).

Á Starting number

You can either:

� continue from previous numbers (deselect the button), or

� start from the number in the editable field.

Â Number type

Click on the menu icon to display a menu of numbering types.
(Listed above.)
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Ã Insert tabs

Select this option to insert a Tab character after the number and
any Character after.

Remove numbers

Use this to remove paragraph numbers from the selected region
of text.

Search & Replace

This lets you find:

� a specified word or phrase,

� selected occurrences of a word or phrase and substitute a
different word or phrase, or

� all occurrences and substitute a different word or phrase.

You can also search for styles � see Advanced searching.

You can search either within the confines of the current story or
through the entire document.

Find dialogue box

Utilities ⇒ Find text or keyboard short cut: F4

À Á
Â

Ã
Ä

Å

The Find dialogue box

À Find what: 

Type in the word or phrase you want to search for. 
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Á Style buttons

These are used when you want either Find what: or Replace with

to include style information. See Advanced searching for more
information.

Â Replace with: 

Type in the replacement word or phrase. 

If you want only to find and not replace, you can leave this field
blank.

Wildcards

You may not want just to find an exact match. Suppose you want
to find  fill,  full and  filter. In this case, you use wildcards in the
search string. These are special characters that match against a
number of characters in the text. There are three wildcard
characters:

# matches with any single character

* matches with any group of characters in a word

@ matches with any group of characters

If you actually want to search for one of these characters, refer to
Advanced searching later in this section.

Ã Whole document / Current story

These switches let you search only in the current story or all
stories in the document. Search whole document in Preferences

on the Icon Bar Menu selects the default setting.

If you choose Whole document, the search starts at the beginning
of the document and runs through each story until the end of the
document.

If you choose Current story, the search starts at the cursor position
and finishes at the end of the story

Ä Case sensitive

This switch determines whether searching takes account of the
case of the words. To show its use, suppose we want to replace
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abc with xYz.

If unselected, then the search will match on abc, Abc and abC.
When the substitutions are made, capital letters are retained so
you would get xyz, Xyz and xyZ. The capital Y in the substitution
word has no effect.

If case sensitive is selected, then the search only matches abc and
not Abc or abC. xYz is substituted for abc.

Replace all / Find next

When you have decided

� what text to search for

� whether to be case sensitive or not

� whether you want to replace it

� whether you want to deal with the whole document, or just
the current story

click on either Find next or Replace all. Pressing Return is the
same as clicking on Find next. Either option starts a search for text
matching that in Find what:

If a match is found:

Find next displays the Text found dialogue box (see below),

Replace all replaces the text with the Replace with: text and
continues the search.

With either selection, how far Impression searches depends on
whether you�ve selected Current story or Whole document.

The Text found dialogue box

This dialogue box is displayed if you selected Find next: and a
match is found.

À Á
Â
Ã Ä

The Text found dialogue box
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À Replace

This replaces the highlighted occurrence of the Find what: string
with the Replace with: string. Impression then performs a Find

next to find the next occurrence of the search string. If the
Replace with: field in the Find dialogue box is empty, then
clicking Replace deletes the found text.

Á Replace all

Replace all occurrences of the Find what: string with the Replace

with: string.

This button duplicates Replace all in the Find dialogue box. Its
advantage is that replacement can start part-way through a
document. It also lets you find a word, make edits, and then
continue.

Â Replace until end of story

Replace all occurrences of the Find what: string, from the current
highlighted occurrence to the end of the story, with the Replace

with: string.

For single story documents this option has the same effect as
Replace all.

Ã Cancel

This terminates the search.

Ä Find next

Find the next occurrence of the Find what: string in the text. If no
match is found in this story, and the Whole document button was
set in the Find dialogue box, Impression moves to the next story
(if there is one) and tries to find the string. This process continues
until Impression finds either a match or the end of the text. When
all the text has been searched, the message Couldn’t find search
string in text, is displayed.
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Truncated text

If truncated text is encountered while searching (that is, text
overflows one frame, and has no other frame to flow into), the
search does not end. Impression can then tell you that it has
found some text but cannot display it on the screen.

Advanced searching

This section describes how to perform search and replace
operations involving:

� control characters such as carriage-return

� characters not on the keyboard (such as ©)

� styles.

Where these characters appear in your search or replace strings
use the format
  curly bracket � style information or character � curly bracket

Examples are:
{CR} carriage-return (end of paragraph character)
{Tab} tab character

For © (character 169) you can use either
{Code 169} or {\169}

Appendix 5 lists the character sets and character numbers.

* # and @ are wildcards and cannot be used directly in search
strings. Instead, use their numbers

* 42 � enter as {Code 42} or {\42}
# 35
@ 64

The case of characters within commands is not important. The
commands are a subset of DDF. The on-line help contains more
details on DDF commands. 

The Style buttons (Á in the illustration of the Find dialogue box)
make it easier to include style commands into the Find what: and
Replace with. Clicking Menu on either field or clicking on the
style buttons brings up a menu of available styles. Choosing a
style inserts it into the field at the cursor.
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The Find what: and Replace with: fields can contain any combina-
tion of these commands and ordinary characters. For example, to
search for the phrase �spinning card� and replace it with the word
�thaumatrope� in a pre-defined style called Index

Find what: 
spinning card

Replace with: 
{"Index"}thaumatrope{"Index"}

(You can insert style information at any point in the search or
replace string.)

To delete all occurrences of the style Index you would enter
{"Index"}@{"Index"}

into Find what and leave Replace with blank.

Swop case (ctrl-S)

If there is no selected region, Ctrl-S swops the case of the
character after the cursor. (From UPPER to lower-case or lower to
UPPER-case.)

If there is a selected region, Ctrl-S displays a dialogue box:

Capitalise start of sentences

Force the first non-space character after a full
stop to upper-case.

Capitalise initial letters

Force the first letter of each word to upper case.

All upper case

Force all characters in the selected region to
upper-case.

All lower case

Force all characters in the selected region to lower-case. 

Swop case of all letters

Change upper-case characters to lower-case and vice versa.
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2.4 Printing

This section covers:

• the Print dialogue box

Related sections of this manual:

• Appendix 7: Draft printing
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When you have finished your document, you will probably want
to print it. Impression offers two modes of printing:

� a high-quality mode which uses the fonts displayed on
screen and prints the graphics, and,

� where useful, a text-only mode which uses the character sets
provided by the printer and does not print graphics. (This is
only useful with slower printers. Faster printers such as laser
and most ink-jet printers always use high-quality mode.)

With either mode, you can:

� print single or multiple copies

� print all pages or only a selection

and, for high-quality mode only:

� scale (up or down) the page size so you can, for example, to
print an A4 page on screen to A5 sized paper.

The Print dialogue box controls the various options in Impres-
sion. The current print settings are stored when you save the
document and redisplayed when you next call up the Print
dialogue box.

Printing time depends on the type of printer and on the complex-
ity of the page. Some printers (such as dot matrix) can take 4-5
minutes to print a complex page. Others, such as modern laser
and inkjet printers, a few seconds. Printers such as Laser and
PostScript printers retain the page image in their memory and so
printing multiple copies of the same page takes only slightly
longer than printing a single copy.

Some printer drivers need setting up to define the type of
interface (serial or parallel) and protocol required. To do this,
refer to Acorn�s User Guide and the manual for your printer for
interface details.

Pages and Paper

To avoid confusion, throughout this section:

�pages� refers to the pages of an Impression document and

�paper� refers to the sheets of paper produced by the printer.
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The Print dialogue box

To display this dialogue box:

� use File ⇒ Print, or

� click on the Print tool on the Toolbar, or

� press Print.

You can also display this dialogue box using Ctrl-Print. This
resets the print options to their default states.

You must have a printer driver or a printer module loaded before
you can print anything.

À
Á Â
Ã
Ä Å
Ç
È É

Above: Impression Publisher

Below: Impression Style
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The print settings are stored with the document. You may want to
set these up and store them but not to print anything now. To do
this

1 make any required changes,

2 click on È Set values,

3 save the document.

Clicking on É Print (or typing Return) starts printing. All Impres-
sion windows are blanked, the pointer turns into an hourglass
and the Print information box appears:

While printing, the hourglass occasionally turns back into a
pointer for a short period. At this point, Impression is giving other
programs a chance to operate, offering a small amount of multi-
tasking.

Clicking Pause (even while the hourglass is up) pauses printing
after a few seconds, allowing other programs to be used. (Note:
when the program is paused you cannot close or resize Impres-
sion windows.)

Clicking Continue continues printing.

Clicking Stop terminates the printing, although it waits for the
next round of multi-tasking. This can be a few minutes on a
PostScript printer.

À All / From-To

Select All to print all pages in the document. (The To box displays
the number of pages in the document.)

Select From to print the range of pages specified in the two
editable fields. These use the physical page numbers, which
always start from 1 and are independent of any page number
shown on the document. The actual number of the current page
(the page containing the selected frame) is shown:
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� in the Info box (File ⇒ Info or Ctrl-F1) or

� on the Toolbar:

Á Copies

This is the number of copies of each page you want to print.

For multiple copies of a multi-page document, Impression can
either:

� print each page n times (1,1...,2,2...), requiring you to sort
the pages into order by hand, or 

� print n copies of the document in order (1,2...,1,2...). 

This is controlled by the Collated switch (described later in the
Setup dialogue box).

Â Pause

When this switch is selected, printing suspends after each page.
This is useful if you want to print on single-sheet paper without a
sheet feeder. Press Continue on the print information box to
continue printing.

Ã Upright / Sideways

These buttons tell Impression whether to print upright (portrait)
or sideways (landscape) on the page. For example, use sideways
to print two A5 pages onto an A4 sheet of paper.

Ä Scale

The scaling field affects how large the page will appear on the
paper. 100% is full size but the actual size depends also on how
large the pages are in Impression. By default, the page size is
exactly A4. However, if you require an A4 page to be printed at
A5 size, the scaling factor can be reduced to 70% or 66% depen-
dent upon the setting of Ignore page borders (see later in Setup
dialogue box). At 100% measurements made on the page should
always be accurate on all printers; for example, a frame of 100mm
width should always print as 100mm wide.
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The two bump icons to the right of the scaling field increase or
decrease the scale in steps of 1%.

Å Fit lots

When this switch is off, Impression prints one page on one sheet
of paper. 

When this switch is on, Impression fits as many pages as it can on
one sheet. For this option to be of any use, the Scaling field
should usually be set to less than 100%, so that more than one
page can fit on the paper.

The scaling required to fit several pages on one sheet of paper
depends on the Ignore page border switch (in the Setup dialogue
box). If this is off, account is taken of the non-printable margins
around the edge of the page. If this is on, these margins are
ignored.

As a guide the number in brackets to the right of Fit lots tells you
how many pages can fit on a sheet of paper. 

(Impression assumes all the pages are the same size as the first.)

So, for example, one particularly useful option is to print two
pages of an A4 document on a single sheet of A4 paper. For this,
use these settings:

Sideways

Scale 66%

Fit lots (the 2 after Fit lots tells you that Impression can fit two
pages on one sheet of paper)

Æ Draft

With some types of printer you can use the fonts built into the
printer for faster printing of text. However, there are a limited
number of fonts available and you cannot print illustrations.
Suitable printers are:

Epson FX, LQ, LX, RX ranges and compatibles,

Canon BJ-10 range,
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Hewlett Packard Deskjet and Laserjet ranges. 

If you have TurboDriver software for Canon or Hewlett Packard
printers, draft mode offers little speed advantage.

Before you can use draft printing you must have a special printer
module loaded. (These modules are different to the standard
RISC OS printer drivers.) The field to the right displays the current
type of printer module loaded. To display a list of available
printer modules either:

� click Menu on the editable box, or

� click on the arrow to the right of the name.

Refer to the Appendix 7 for more information on draft printing.

Note: the method of draft printing, using the character set of

the printer, is now obsolete.

Ç Setup

Click on this to display an extra dialogue box (see below).

Ç Typesetting

Click on this to display an extra dialogue box (see below).

Postscript printing

A postscript printer driver can be used either for a direct connec-
tion to a postscript printer or to create a disc file containing the
postscript data. The postscript file can be converted to a PDF file,
see Appendix 7.
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Print setup dialogue box 

À
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Postscript: these
options are under
development

À Collated

If you want to print 3 copies of a 4 page document:

� with Collated on the pages are printed in the order 1,2,3,4,
1,2,3,4, 1,2,3,4

� with Collated off the pages are printed in the order 1,1,1,
2,2,2, 3,3,3, 4,4,4.

Some printers, such as dot-matrix printers, take the same time to
print a page, even if that page has already been printed once.
Other printers keep an image of the current page. As a result, one
copy of a page might take several minutes to print, but subse-
quent copies of that page considerably less time. So for more than
one copy of a large document, it is faster on some printers to
leave Collated off, while for others no advantage is gained. In the
latter case the switch may be turned on, allowing Impression to
stack the pages in order.
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Á No Illustrations

When printing a page to certain printers (notably PostScript) the
more information there is on the page, the longer a page takes to
print. Graphics often take a particularly long time, especially large
sprites. It is often useful to print out just the text on a page, and
No illustrations can be used to speed up this function. When it is
selected, any graphic frames on a page are replaced by boxes
with a cross through them. 

This can dramatically reduce the time it takes to print pages on
PostScript based printers.

Â Left pages / Right pages

These let you print only left-handed pages, only right-handed
pages, or all pages. Note that the �handedness� of a page has
nothing to do with the page number, but depends on whether it
has been created as a left/right pair.

When using Pamphlet mode, these two switches are ignored, as
Pamphlet mode only makes sense if you are printing left and right
pages.

Ã Ignore page border

There is usually a small border around the edge of the page
where the printer cannot print. This is called the print border or
the page border. Impression can take account of this border and
printing is relative to the page borders. Some printers have a
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larger border on the left than on the right and this results in the
printing being offset to the right.

With this option on, the page borders are ignored and the page is
printed relative to the edges of the paper. Use this option if it is
important that items on the printed paper are in exactly the same
position as they appear in the document.

This has an effect on Fit lots which normally tries to fit the pages
within the print borders. With this option on, Impression prints
pages within the full dimensions of the paper. This allows a
slightly larger scaling. For example, to exactly fit two A4-sized
pages on an A4-sized sheet of paper with this option off may
require a scaling of 66%. With this option on, you can use 70%. 

You can make the current page borders visible on the screen
using View ⇒ Print borders or Ctrl-Shift-O.

Ä Pamphlet

One application for which a program like Impression is often
used is to produce small booklets or leaflets. Quite often these are
A5 sized, but printed on both sides of an A4 sheet, then folded
over and stapled.

Selecting Pamphlet gives you the option of �Two-up� or �Four-up�
printing. Selecting Two tells Impression that you wish to print a
pamphlet with two Impression pages on each side of a sheet of
paper, ready to be folded. 

1

3
14 32

This option should be used in conjunction with the scaling, and
usually with the Sideways mode as well. For example, when
printing two A4 pages on one A4 sheet, set:

Scaling to 66%, and 

Sideways. 

�Four-up� printing prints four pages on each side of a sheet of

71 

2.4 Printing



paper. 

8 1 2 7

This would normally be used in Upright mode. For example, to
print an A6 pamphlet from A4 pages, set: 

Scaling to 46%, and

Upright.

When Impression starts printing, it prints one side of the sheet.
When finished, it beeps, and asks you to turn the pages over and
feed them back into the printer. Then it prints the other side.

Note: If you are using a page printer such as a Laser printer, the
message to turn the paper over might appear before all the pages
have been printed. Wait until the printer has finished printing.

It is important to turn the pages over so that they are the right way
round. Different printers feed paper in different ways. You may
need to experiment to find the correct way to turn the paper.

2nd half

When this switch is on, Impression prints only the second side of
the pamphlet. This makes pamphlet printing easier as you do not
have to print the second side immediately after the first (which
can lead to paper jams). 

If you only want to print the first half, turn 2nd half off. When the
first half has been printed press the Stop button on the Print
information box. 

Å Reverse

This controls the order in which Impression prints multiple page
documents. With this option off, printing starts with the first page.
With the option on, printing starts with the last page.

Printers stack paper either face-up or face-down after printing. If
they are stacked face-up the pages will be in the wrong order.
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Reverse lets you change the order so that pages stack in the
correct order.

This switch has no effect when printing the first side in Pamphlet
mode. Pages are always printed in the same order. (First and last
pages printed first.) When printing the second side, Reverse

applies to cater for the different stacking orders.

Æ Fit same pages

This has no effect unless Fit lots is selected and the scaling allows
more than one Impression page to be printed on a sheet of paper. 

If this option is off, as many different pages as can fit on the
paper are printed.

1 21 2

If this option is on, as many copies of the same page as can fit on
the paper are printed.

1 21 1

Ç Centre pages

With this button off, pages are printed relative to the top-left
corner of the paper. With this button on, pages are centered
within the available space.
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This option is most noticeable when, for example, printing a
single A5 page on an A4 sheet of paper. With Centre page off, the
page is printed close to the top-left corner. 

With it on, the page is centered on the paper.

È Colour table

Factors such as ink colour and print density vary greatly between
printers. As a result, the same document can look different when
printed on different printers. Colour tables compensate for this on
printers that use four-colour (CMYK) printing such as Canon BJC-
600/800 in combination with TurboDrivers (see note) and when
producing PostScript separations.

Colour table shows the name of the current table. If you do not
want colour correction, choose Linear table. To change to a
different table, choose Preferences on the Icon Bar Menu. Colour

table is the last option on the scrolling list. (2.16 Customising
Impression describes Preferences in more detail.)

Note:

The Acorn printer drivers for the Canon BJC and other CMYK
printers do not use CMYK printing. Instead, they use the RGB
system which is converted to CMYK in the printer driver. There-
fore, colour tables do not affect printing on these systems.
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The Impression colour tables are used to create the CMYK
separations when separating to PostScript devices or to CMYK
colour printers using the TurboDriver printer drivers. Specifically
the tables adjust the intensity levels of the separate C, M, Y and K
inks. It also controls the level of grey component replacement,
the process by which black ink is substituted for neutral colours.
Different tables use different settings to compensate for non-
linearities in the inks of different printer types, or to compensate
for dot-gain or other printer artifacts.

Creating curves is a skilled and specialised process. However, for
those interested in creating their own tables for different printers.
A simple curve editing utility to create alternative colour tables is
included with applicable modern versions of Impression. Because
of the nature of the program, no support can be provided and it�s
supplied �as is�.

É Page Origin

The editable fields move the printed image relative to the sheet of
paper. (0 is no movement.) Note that you move the printed
image; this is the Impression pages after applying scaling,
landscape/portrait rotation, Centre pages, Fit lots and similar
factors.

� Positive values of X move the image to the right;
Negative values to the left.

� Positive values of Y move the image up the paper;
Negative values down the paper.

One use is when outputting an A4 landscape or A3 portrait page
with crop marks (required width 314mm) on a Linotronic
typesetter (maximum usable width 304mm). Normally the right-
hand crop marks are not printed. Setting X to –5mm moves the
image to the left and gives half-width crop marks on both sides.
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Typesetting dialogue box

This dialogue box sets parameters for typesetting monochrome
and colour-separated output for commercial printing. Refer to the
Commercial Printing Guide for explanations of many of the
expressions used below.

À
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The OPI button is greyed unless you have the optional OPI
supplement.

À Printers marks

When producing colour typeset output, you normally require
both Separation names and Registration marks. They are not
needed for monochrome work. Both options are greyed when
Full colour is selected.

Separation names prints the appropriate colour name on each
separation. The names are those displayed in the separations
options box (see below).
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Registration marks are targets (see left) printed around the edge
of the image. They allow the printing press operator to accurately
align the colours when printing.

Crop marks

Crop marks are used by commercial printers as aids to guillotin-
ing the paper after printing. They are printed in the margins of the
paper in the area that will be discarded after guillotining. It
therefore follows that if you want a full-size A4 image with crop
marks, it must be printed on paper larger than A4.

If you want to print crop marks and use Fit lots, the scaling must
be smaller than usual. For example, to fit two A4 pages on an A4
sheet of paper normally requires a scaling of 70% (with page
borders off). To fit crop marks requires a scaling of 62%.

Page size

Bleed area

Crop marks

Á Full colour/Separations

Use Full colour when printing a monochrome document or when
printing to a colour printer. (The output generated by this option
is known as composite output.)

Select Separations to produce typeset separations for commercial
printing. (Or for proofing the colour separations to a mono-
chrome printer.) Also use this option when using spot colours �
there is more information on this in the Commercial Printing
Guide.
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Â Separations option box

This lets you select which separations to print and which to
overprint. (The ticks show separations to print � Cyan and
Magenta in the illustration � and the black dots show which to
overprint � Black in the illustration.) 

To change the print setting click on the tick area.

To change the overprint setting click on the circle.

You may want to print only selected separations for several
reasons:

� Your document may not use all four colours (spot-colour
work). Printing unwanted separations wastes time and materials.

� You may want to print a single separation to proof it.

� If printing to disc for sending to an typesetting bureau, the
four separations can be bigger than a floppy disc. You then need
to create two or more files on different discs.

If you are producing typeset film separations -

Always have the complete set of separations produced at the
same time. Temperature, humidity, and operating conditions
within the typesetter all affect the film.

For the same reason, never rerun just one film from a set. Always
rerun the complete set.

Ã PostScript screen

Set this option if you are outputting to a PostScript device and you
want to specify variables such as resolution of the half-toning
screen (this determines the number of grey-levels in the printed
output) and screen angles. 

The Alter graphic dialogue box lets you specify a screen value for
individual graphics. Any value set in Alter graphic takes priority
for that graphic.
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Screen density

Typical values are

� outputting to a laser printer 60-70;

� for monochrome typesetting 100-120; 

� colour typesetting 150.

Ä Screen type

Half-tones and tints are printed as clusters of dots. There are
several ways of arranging the individual cells within each cluster.
Screen type offers you several alternative arrangements. Unless
you are experienced in producing typeset output we recommend
always using the default value.

Å Printer resolution

Set this to match the resolution of the printer or typesetter. If you
are producing output for typesetting, check with the bureau
which resolution to use.

Either type a value into the editable field or choose from the
menu of common resolutions.

Æ Screen angles

These only apply when outputting to a PostScript device such as
an typesetter. 

Half-tones and tints are printed as clusters of dots on a regular
grid or screen. The human eye is particularly sensitive to horizon-
tal and vertical alignments. For this reason, the most prominent
colour � black � is usually printed with the grid rotated to 45°.

There is a further problem when printing different colours.
Because of slight movements during printing, interference
patterns are easily created. (These are called moiré patterns.) To
avoid this, each colour grid is rotated by a different angle. These
angles must be carefully chosen and vary with resolution. For
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these reasons we recommend always selecting Use recom-

mended. Only change the screen angles if you are experienced in
producing half-tone separations.

Some typesetting machines can run special software that recalcu-
lates the screen angles to avoid moiré patterns. This software is
called HQS (high-quality screening) or similar names. Note that
pages take much longer to print with HQS (uo to ten times
longer) and, if you use a typesetting bureau, often attracts an
extra charge.

If you want to change a screen angle, click on the colour name
and then edit the value in the Screen angle field.

As a footnote:

The recommended angle for yellow is 0° which is horizontal.
This is not a problem as the eye is least responsive to yellow and
so does not detect the horizontal and vertical orientation.

È Reflect page

Pages are printed as mirror-images. This is useful for producing
typeset film for printing plates.
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2.5 Effects

This section covers:

• what are Effects?

• using Effects

Related sections of this manual:

• 2.6 Styles

• 2.7 Rulers
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What are Effects?

To change the appearance or alignment of the text in Impression,
you can apply one or more Effects. For example, you may want
larger characters so you would choose a larger font-size. You may
want the characters to have a different typeface so you would
change the font.

Either action applies an Effect; applying a different font size is one
Effect, a different font is another Effect. Some Effects can be
combined; a section heading might be a combination of two
Effects: (1) a bolder font and (2) a larger font size.

Effects and the cursor

When you are typing in text, you can apply or cancel Effects at
the cursor and then continue typing. To change an Effect, choose
the required option from the Effects menu or the Toolbar. If the
Effect is already applied, its name on the menu is ticked; 

Bold Effect is applied at the cursor

To cancel the Effect, click on the name; it becomes unticked.

You can apply or cancel several Effects at once. For example, to
create a headline you might press Return to start a new line and
then select a new font, a larger font size, and centre-justification.
You then type in the headline. To cancel all three Effects at once,
choose Clear all effects from the menu. 

If you want to continue with the new font but revert to normal
font size and alignment, cancel only those two Effects

83 

2.5 Effects



To apply or cancel Effects you can use either Select or Adjust. 

� If you use Select, the change is made and the Effects menu
disappears from the screen. 

� If you use Adjust, the change is made and the menu remains
on the screen. This is useful if you want to make a number of
changes. In most places in Impression, you can make several
changes using Adjust to keep the menu or dialogue box on
the screen.

Effects and existing text

Before you can change which Effects are applied, you must first
select the region of text that you want to change. Selecting
regions of text is described in 2.3 Text handling.

When the Effects menu is displayed, any Effect which is used
anywhere within the selected region has a tick against its name. 

Bold Effect is used in the selected region
You could have several Effects in the same group ticked. For
example, this page uses two different font sizes and four fonts. A
tick just means that the Effect has been used somewhere in that
region, not necessarily over the entire region.

To remove all Effects, choose Effect ⇒ Clear all effects. 

This option removes:

� character-based effects (such as font or size) from the cursor
or selected region, and

� paragraph-based effects (such as alignment) from the entire
paragraph. Any selected region is automatically extended to
cover the entire paragraph.

This option does not clear any Styles that may also be applied.
See 2.6 Styles.
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If you want to remove an Effect from the entire selected region,
click on its name in the menu. 

Click on Centre to remove the Effect

Its name is then no longer be ticked.

Similarly, to apply an Effect over the entire selected region, click
on its name. A tick appears against the name. If the Effect is used
anywhere in the region, its name is already ticked on the menu.
In this case, click once to remove the Effect from those areas of
the text where it is currently used:

and then click a second time to apply it over the entire region:
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The Effects menu

Clear all effects

This removes all Effects from the cursor or selected region. It does
not remove any Styles that may also be applied.

Text font

You can also apply this Effect from the Toolbar:

The list is displayed in two parts:

� First, the font family names (Corpus, Greek, Homerton, etc.).
The currently selected font family is ticked. Slide over the
arrow to the right of the required name to display:
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� Second, a submenu of the font variants (Regular, Bold,
Bold.Italic, etc.). The currently selected font variant is also
ticked.

Clicking on the font family name chooses the Medium or Regular
font variant.

The Character font (described in 2.3 Font handling) is for
documents that are to be printed as pure text in draft-mode (see
the 2.4 Printing for details). Unlike the other fonts, it is unsuitable
for high-quality printing.

Text size

This lets you change the width and height of characters. You can
also apply this Effect from the Toolbar:

Condensed makes characters narrower (like this). They are con-
densed to 70% of their original width.

Expanded makes characters twice their original width (200% �
like this).

The other entries change the height of text (72 pt = 1 inch):
sample text in 8pt

sample text in 14pt

sample text in 24pt
You can also change the font size from the keyboard. Ctrl-Shift-Y
decreases the font size; Ctrl-Shift-T increases it.

87 

2.5 Effects



Line spacing is set by underlying styles (such as Normal).
Conventionally, line spacing is 120% of the font size but you can
change this if required.

You can also type a font height into the Other editable field. (This
has a keyboard short cut of Ctrl-Shift-S):

On applies the font height to the cursor or selected region.

Off removes any font height effect from the cursor or selected
region.

Text colour

This controls the colour of the characters which is, by default,
black. It displays the Colour Picker. See 2.12 Colour handling for
more information.

Line spacing

(Ctrl-Shift-L) This lets you specify the distance between lines of
text:

These two lines of text are in 10pt
with 12pt line spacing.

These two lines of text are also in 10pt

but with 16pt line spacing.

These two lines of text are also in 10pt
but with only 9pt line spacing.

If you want to set a line spacing less than the current value, apply
the line spacing Effect to the complete line. (The default line
spacing is 120% of the current font size.)

We suggest you always apply line spacing effects to complete
paragraphs. This helps to maintain a consistent appearance to
your document.
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Kerning & Tracking

The menu option reads 
Kerning when there is a cursor in the text,
Tracking when there is a selected region.

There is a keyboard short cut of Ctrl-T.

Kern effects option

Horizontal kerning adjusts the space between two characters:

AW    A W         AW
Left to right: no kerning, positive kerning, negative kerning

Vertical kerning moves the baseline of the right hand character of
a pair of characters (and subsequent characters on the line):

AA      AA          AA
Left to right: no kerning, positive kerning, negative kerning

Kerning is measured in ems. One em is equivalent to the size of a
capital M in the current font, so kerning is always proportional to
size of the text. The dialogue box expects values to be entered in
1000ths of an em, so entering a value of 1000 in the horizontal
field moves the two characters apart by one em. Values can be
positive or negative.

Vertical movements occur at the cursor position. Unless you want
the rest of the characters on the line to be moved up by the same
amount, it is usually necessary to place an equivalent kern down
later in the line.

89 

2.5 Effects



Set applies the kern. Cancel simply cancels this operation and
removes the dialogue box. Clear clears any kerning set at the
cursor.

Displaying the Kern dialogue box while the cursor is between
two previously kerned characters shows the current kern values.
You can then alter or remove (with Clear) any existing kern
values. (Kern characters are invisible characters in the text. You
can also delete them using the normal delete keys.)

There are key short cuts for kerning. (You do not need to display
the dialogue box.) Ctrl-E and Ctrl-R extends or reduces the gap
between two characters while Ctrl-U and Ctrl-J moves the next
character up or down. In all cases one press of the key alters the
kern value by 50

/1000 (0.05 em). 

Tracking

This is similar to horizontal kerning except that it applies to a
selected region of text. Values can be positive (move the charac-
ters apart) and negative (move them together). The keyboard
short cuts Ctrl-E and Ctrl-R increase and reduce the tracking (each
key press alters the tracking by 0.01 em). Tracking is typically
used to spread text in headings.

An example of its use:

TRACKING no tracking

TRACKING 0.1em (100/1000) tracking

T R A C K I N G 0.5 em (500/1000) tracking

If you output this document to a PostScript file:

Applying tracking to a large area of text can create very large
PostScript files.
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Alignment

Keyboard short cuts: 
F5 for Left align,
F6 for Centre,
F7 for Right align,
F8 for Fully justify.

F5 means just the function key � you do not need to press Ctrl or
Shift.

You can also apply these Effects from the Toolbar:

Left to right � left, right, centre, fully justified

Impression always applies Alignment Effects to the entire para-
graph even if just a part of the paragraph is selected.

Examples of alignment:

Text in this paragraph is left-aligned and so has a ragged margin on the
right-hand side. This is normally how you lay out letters as it gives a
less formal appearance to your documents. Left-aligned is also called
left justified or ragged-right.

Text in this paragraph is centre-aligned and so has ragged margins on
both sides. This is often used in posters and simple leaflets. You may

need to adjust the text margins to avoid a short final line (like this
paragraph).

Text in this paragraph is right-aligned and so has a ragged margin on
the left-hand side. It has limited uses but can be effective to the left of
illustrations. Right aligned is also called right justified or ragged-left.

Text in this paragraph is fully justified and so has an even margin on
both sides. It gives a formal appearance to a document. (Most of the text
in this manual is fully justified.) The even margins are created by
increasing the spacing between words.
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Keep together

These Effects control if and how paragraphs break over frame
boundaries. They always control complete paragraphs, even if
you apply them to just a part of the paragraph. 

Paragraph

This ensures that the whole paragraph appears in the same frame
and does not split at a frame boundary.

Paragraphs

Normally you would apply this to a region of several paragraphs. 

It ensures a group of paragraphs always appear in a single frame
and do not split over two frames.

With next

This ensures that the whole of this paragraph and the following
paragraph appears in the same frame.

A common use is to stop a heading appearing at the bottom of
one frame with the text to which it applies at the top of the next
frame.

Ruler

This option is ticked if there is a local ruler at the cursor or in
selected region. Clicking on Ruler removes the local ruler. (Rulers
are described in 2.7 Rulers.)

Bold

Keyboard short cut Ctrl-B. You can also apply this Effect from the
Toolbar:

    
This applies the Bold or, if this does not exist, the Demi variant of
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the current font. If neither variant exists, text is unchanged.

Applying Bold to a region containing two or more fonts applies
the appropriate fonts:

This is Trinity medium font and this is Homerton medium.
Applying Bold to all the text gives you:

This is still Trinity and this is still Homerton but now

the Bold variants.

If you later change the font, the Bold Effect is applied to the new
font. So if you apply Bold to some Trinity text:

This is some sample text.

and later change it to Homerton, the result is Homerton.Bold:
This is some sample text.

Italic

Keyboard short cut Ctrl-I. You can also apply this Effect from the
Toolbar:

This is similar to Bold. It applies Italic or Oblique font variants (if
these exist).

You can combine Italic and Bold to give Bold.Italic text (if a
suitable font variant exists).

Underline

Keyboard short cut Ctrl-Shift-U. You can also apply this Effect
from the Toolbar:

This underlines text (like this). The position and thickness of the
underline is set by underlying styles (such as Normal). (Refer to
the description of underline in the Style Editor Text dialogue box
in 2.6 Styles.)

Underlining is rarely useful for emphasis. You will find emphasis-
ing text using Bold or Italic generally look better when printed.
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Superscript

Keyboard short cut Ctrl-Shift-J.

This displays text in superscript (like this). The position and size of
superscript characters is set by underlying styles (such as Nor-
mal). (Refer to the description of superscript in the Style Editor
Font dialogue box in 2.6 Styles.)

Superscript 1, 2, 3 (¹ ² ³) are available directly from the keyboard.
(Characters 185, 178, 179 or Alt-1 to Alt-3. Not all fonts include
these characters.)

Subscript

Keyboard short cut Ctrl-Shift-K. 

This displays text in subscript (like this). The position and size of
subscript characters is set by underlying styles (such as Normal).
(Refer to the description of subscript in the Style Editor Font
dialogue box in 2.6 Styles.)
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2.6 Styles

This section covers:

• what are Styles?

• using Styles

• when to use Effects and when Styles

• the Style Editor

• creating grids, tables etc.

Related sections of this manual:

• 2.5 Effects

• 2.7 Rulers
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What are Styles?

A style is a named collection of effects and text markers.

Some effects (such as font and alignment) duplicate options on
the Effects menu; others (such as paragraph rules) are unique to
Styles. All text has at least one Style applied to it � the default or
Normal Style. This defines all possible effects. You can then
overlay Normal with other Styles, Effects and Rulers to alter the
appearance of your document.

For example, section headings in this manual are 18pt Homerton
Bold. Because this combination is frequently used, the two Effects
are grouped together in a Style. Whenever a new section heading
is required, this Style can be applied to it. The heading then
appears with the required combination of Effects. Applying a style
is also quicker than applying several effects. 

All Styles are named; we call the Style for section headings
Heading. The name can show its use (�Heading�) or its appear-
ance (�Green italic�). Impression has several Styles already
defined but you can modify these if required as well as create
totally new Styles.

A further advantage of Styles is that if you change them, all text in
that Style automatically the changes. For example, if we changed
Heading to 20pt, every section heading in this manual would
automatically change to 20pt.

The Style menu

The Style menu gives access to editing existing Styles, creating
new Styles and applying and removing Styles from the cursor and
regions of text. It also shows which Styles are currently applied to
the cursor or region of text.

You can choose the Style menu either from the Main Menu or
from the toolbar   .
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Applied styles

Available styles

An example Style menu

New style...

(Ctrl-F5) This displays the Style Editor ready for you to create a
new Style. The Style Editor is described later.

Edit Style...

(Ctrl-F6) This displays the Style Editor ready for you to edit or
examine an existing Style. The Style Editor is described later.

Clear all styles

(Ctrl-N) This removes all Styles (except Normal), Effects and
Rulers applied at the cursor or over the selected region.

The applied Style list

The second section tells you which Styles (other than Normal,
which is applied underneath all Styles and Effects) are currently
applied at the cursor or selected region. Applying and removing
Styles is described later.

Currently applied styles are ticked:

Main Heading is currently applied
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If there is a selected region, this list tells that a Style is used over
some part of that region, not necessarily the entire region.

The Style list

Sample Style list     

The last part of the menu lists Styles available in this document.
Usually this is a full list of Styles. However, the Style Editor
(described later) allows you to exclude selected Styles from the
list. (The Show on style menu option.)

Using Styles

Applying Styles

To apply a Style to a region of text, first select the region. (Some
Styles automatically apply to whole paragraphs � this is controlled
by Automatic paragraph apply in the Style Editor. For such Styles
you can select any part of the paragraph.)

Then choose the required Style from the Style list.

Click here to
apply this Style

Applying the Style to a selected region applies it over the entire
region even if the Style was previously applied to a part of the
region.

Style changes at the cursor only apply if you type something.
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However, if you move the cursor using the mouse or the arrow
keys, the change is forgotten. If you return to the original position
and start typing, the Style change is not applied to your typing.

As with most menu operations, Select-clicking applies the Style
and removes the menu. Adjust-clicking applies the Style but does
not remove the menu. This lets you make further changes.

If you apply conflicting Styles the last applied Style takes prece-
dence. For example, if you apply a Style that sets text to 18pt then
a Style that sets 24pt, the second Style (24pt) applies.

If there is a cursor, the Style list shows the order in which Styles
were applied (latest at the top of the list):

Sub-Heading was applied first followed by Main Heading. Effects
set by Main Heading take precedence over the same effects
defined in Sub-Heading. The resultant text is controlled by effects
set by Main Heading and non-conflicting effects in Sub-Heading.

If there is a selected region, the order of Styles in the list has no
significance.

The merits of when to use Effects and when to use Styles are
described later in Effects & Styles.

Overlaying Styles

More than one Style can be applied to any region of text. So, for
example, a Style that sets the text colour to green can be applied
to a region of text that already has a Style that italicises the text.
The visible result is italic, green text.

If you overlay two Styles that set conflicting effects, the last
applied Style take priority. For example, if the existing Style uses
Trinity font:

Here is some sample text.
and you overlay it with a Style that uses Homerton font, the text
now appears in Homerton font:

Here is some sample text.
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A Style does not have to visibly change text. An example is a Style
that marks text for inclusion in an index. This might just set the
Index label attribute.

Removing a Style from the text

Click on the Style name in the applied Style list to remove it from
the cursor or selected region of text.

Click here to
remove this Style

Removing a Style at the cursor (unless it is paragraph-based; that
is, Paragraph apply is set) only takes effect if you type something.
If you move the cursor without typing, the change is forgotten.

Modifying Styles

The power of Styles is that you can modify them and the modifi-
cation applies to all text that uses that Style. You can use either:

� the Toolbar, or

� the Style Editor (described later).

Using the Toolbar

1 Create some text with the required Effects, Styles and Rulers
applied.

2 Position the cursor in that text.

3 Click on the Define button on the Toolbar:
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This displays a dialogue box:

4 The modified style always includes applied Effects and any
local ruler in the example of text.
Click on Take styles to also include any applied Styles.

5 Click on Redefine style.

6 Click on the menu icon to display a list of Styles.

7 Choose the Style.

8 Click on OK to modify the Style. This applies the Style to the
text example and removes any applied Effects.

Creating a new Style

You can either:

� Choose Style ⇒ New style. This displays the Style Editor.
You can then set effects as required or merge effects from
existing Styles or from the cursor. See Style Editor for more
information.

� Use the Toolbar. This is similar to modifying a Style. That is,
you apply the required Effects, Styles and Rulers to some text
and then display the Define style by example dialogue box.
Select Define new style and type a name into the editable
field. Click on OK.

Deleting an unwanted Style

1 Display the Style Editor.

2 Click on Delete. (An Alert box warns you if the Style is used
anywhere.)
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Creating tables, grids, etc.

Impression lets you create tables and grids using:

� rules-offs � these are lines drawn above and below lines of
text,

� vertical rules � these are vertical lines drawn to connect to
the rule-offs,

� line spacing and rule-off offsets � used in combination, they
let you join or separate the other elements of table drawing.

Rule-offs and their associated offsets are described in the Style
Editor section under Rules dialogue box.

Vertical rules are also described under Rules dialogue box. Placing
the associated Vertical rule tabs (which specify where to draw
vertical rules) is described in 2.7 Rulers.

Line spacing is controlled either using Effects or in the Text
section of the Style Editor.

Here are a few hints when using these features:

� A table often looks better with a wider than normal spacing
between lines of text. To do this, increase the Line spacing

value.

� To move an entire table up or down relative to the text, alter
only the Below text offset value. (Negative values move the
table downwards.)

� To draw boxes using rule-offs and vertical rules, type a
negative value into the Above text offset. This leaves a gap
between the two rule-offs. Separate the boxes using blank
lines in a Style with no rule-offs set.

� To draw sidebars against a paragraph (as this paragraph has),
create a special Style with

� a ruler with one or more vertical rules,

� the Vertical rule width button on, and

� a Vertical rule width other than 0.
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An alternative is to use TableMate, the OLE utility supplied with
Impression. This can create two types of table:

� a �DDF� text file that uses a combination of vertical and
horizontal rules, or

� a graphic table that uses the OLE mechanism to display and
edit the table.

Effects & Styles

This section provides guidance as to when to use an Effect and
when to use (or create) a Style. In many cases it is obvious which
is better but there is a grey area where the two overlap. Often the
decision will be on personal preference.

� If you want to make a simple change, such as centre justify
some text, then use the Effect provided rather than create a
new Style.

� Some changes cannot be made using Effects such as setting
rule-offs or background colour. For these changes you must
create a Style.

� If you are producing a simple document, for example a
letter, it is easier to use combinations of Effects. If you want
to change the application of an Effect, this is reasonably
quick in a short document.

� If you are producing a long document, using Styles rather
than combinations of Effects is easier. You can alter a Style
and all text in that Style changes to reflect the Style alteration.
The heading at the top of this page (Effects & Styles) is in the
Style Main heading. We wouldn�t use a combination of
Effects (24pt and Homerton Bold) because Main heading is
used so often in this document. If we wanted to change to,
say, 22pt, it would be tedious to go through the manual and
change every example. 

� If you are producing a template document that will be used
to produce other documents (for example, a basic newsletter
layout document), then creating a range of suitable Styles
helps to maintain a consistent appearance to documents
produced from it. You need a good memory to remember
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that main titles are always in 20pt, centre-justified Homerton
Medium and subtitles in 16pt Trinity Medium Italic. It�s a lot
easier to create suitable Styles and give them the names Title
and Sub-Title. You will then know later what their use is.

Style summary

� A Style sets only certain stylistic effects. Effects not set by a
Style take their appearance from the Styles and Effects
applied earlier to the text.

� A Style may be applied by choosing its name from the Style
List (the bottom section of the Style menu).

� A Style may be cleared (turned off) from the selected region
by choosing its name from the Applied Style List (the central
section of the Style menu).

� One or more Styles may be turned on or off using Adjust �
this retains the menu on the screen.

� If there is a selected region � pressing the Style short cut key
applies the Style over this region if it does not occur any-
where within the region. If the Style already occurs within
the region then it turns it off.

� If there is a cursor � pressing the Style short cut key turns
that Style on at the cursor if it is currently off, and turns it off if
it is already on.

� Styles currently applied at the cursor (and the order in which
they were applied) are shown in the current Style list.

� The Styles that occur in a selected region are also shown on
the current Style list. (No information can be inferred from
the order of the list.)

105 

2.6 Styles



The Style Editor

À

Â
Ã

Å

Æ

Ä

Á

This dialogue box is displayed when you create or change Styles.
While the Style Editor is on the screen you can continue to edit
the document.

When you edit an existing Style you are actually working on a
copy of the Style. Any changes you make are not applied to the
document until you click on either the Apply or OK button. If you
want to quit the Style Editor and leave the original Style
unchanged, you can click on Cancel.

Similarly, if you are creating a new Style, it is not copied into the
document until you click on Apply or OK. Therefore, if you
decide you don�t need the Style you are creating, click on Cancel

and the document is unchanged.

À Style name

This shows the name of the Style currently displayed in the Style
Editor. To change to a different Style either

� click on the menu icon to the right or

� click Menu on the editable field
and choose from the menu. 
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If you click using Adjust, this menu remains on screen and you
can browse through several Styles.

If you want to change the name of the currently displayed Style,
click in the editable field and edit the name. Style names can be
up to 31 characters long and you can use any character including
Space.

If you are creating a new Style, you can either change it by typing
in a new name or let the Style Editor assign it a name when it is
copied into the document. Automatic Style naming is described
later.

Á Loading Styles

Dropping an Impression document from a directory window onto
this target adds Styles from that document into the current
document. 

This is useful for loading pre-prepared Style templates. For
example, a blank document could be created that has one or
more new Styles defined. If this is then saved, it can be used as a
�Style file� and loaded into other documents.

Â Key short cut

This lets you apply and remove the Style using the keyboard.
Click in the field and then press the required combination of keys.
You can use a-z in combination with Ctrl and Shift and F1-F12
directly or with Ctrl and Shift. (We do not recommend F12 as this
is used by RISC OS.)

For example, if you click in the field, hold down Shift and press
F9, Shift-F9 appears in the field. After you click OK, whenever,
you press Shift-F9, you select or remove this Style. Note that using
a key combination for a Style over-rides any existing use. In the
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example, Shift-F9 no longer selects 90% scaling (its normal use).

To remove a short cut, display the Style, click in the field and
delete the contents. (Ctrl-U is a quick way to do this.) Click OK to
implement the change.

Ã Show on style menu

When this switch is set, the Style name appears on the Style list.

Not showing a Style reduces the length of the Style list. However,
you can then only select the Style by using the key short cut or
clicking Apply in the Style Editor.

Ä Paragraph apply

Select this option to apply the Style to entire paragraphs. (A
paragraph ends when you press Return. Therefore, a paragraph,
in Impression terminology, can be as short as a single line.)

Selecting any of the paragraph-based options (such as Space

above paragraph, described later) automatically selects this
option.

Å The action buttons

These are the buttons on the right of the Style Editor window.

If you click Select on any of these, the selected action takes
place and the dialogue box is removed from the screen.

If you click Adjust on any of these, the selected action takes
place but the Style Editor remains on screen so that other
changes can be made. This is useful if you are trying out
changes and want to see how they look. You only see a change
if some text in that style is displayed in the document window.

Apply
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This applies the Style to the selected region or to the cursor. It is a
quick way of defining or modifying a Style and applying it to a
selected region.

The Style, complete with any changes, is copied into the Style list
as if you had clicked on OK.

Merge

You can merge the information in the Style Editor with either an
existing Style or the combination of Styles and Effects set at the
cursor. This operation is described later in Merging Styles. 

If you click this button by mistake, remove the menu by clicking
on another part of the Style Editor dialogue box.

Delete

Use this to delete an unwanted Style. An Alert box warns you if
the Style is used in the document.

Cancel

Click on this to cancel any changes you have just made to the
Style. If you are creating a new Style, the Style is discarded as it
does not currently exist in the document.

If you are editing a Style, clicking Adjust on this button discards
any changes you have made and then copies the existing version
of the Style from the document into the Style Editor again. 

OK

Pressing Return has the same effect as clicking on this button.

If you have created a new Style, it is added to the Style list.

If you have edited an existing Style, the changed version over-
writes the old version of that Style. Any text in that Style changes
to reflect your alterations. This reformatting can take several
seconds for a long document.

Æ Text & Paragraph

These display dialogue boxes that let you alter the effects that are
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set by this Style..

All effects have a switch to their left: 

� If the switch is off, the effect is not defined in this Style (it is
�don�t care�). That effect is then controlled by other Styles
already applied to the text (such as Normal). 

� You can only select or set a value for an effect if its switch is
on. Where you can type in a value (such as font size) you
can use any of the units recognised by Impression. (These
are listed in Appendix 3. Using dialogue boxes.) The dis-
played units (by default points, pt) can be changed � see
2.16 Customising Impression for details.
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Font dialogue box

This controls effects that apply to individual characters such as the
font, character size and colour.

À
Á
Â

Ã
Ä

Å

Æ
Ç

À Font name

This acts in the same way as the Text font Effect � see 2.5 Effects
for details.

Á Bold

This acts in the same way as the Bold Effect. It applies the Bold

font variant (or Demi, if there no Bold variant) to text to which it
is applied. If neither variant exists, the text is unchanged.

If you wanted this Style to use a specific bold font you would
normally set Font name to use that font directly. You would
normally use Bold to select the bold equivalent of the current
font. (See the description of the Bold Effect for more details.)
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Â Italic

This acts in the same way as the Italic Effect. It applies the Italic or
Oblique variant of text to which it is applied. Fonts which do not
have these variants are unchanged.

Ã Font size

This acts in the same way as the Text size Effect.

The font size is the size of the characters. It is usually measured in
points (pt � 72pt = 1 inch).

Ä Font aspect ratio (X:Y)

This controls the relative width of characters. It is a percentage
and so does not have any units. 

As an example, an aspect ratio of 50% displays characters at half
their normal width. The height of the characters is unchanged.

Å Script

Off - characters are displayed at their normal height,

Sub - characters are displayed in a smaller font size and in the
subscript position; thus, 1 2 3. This acts in the same way as the
Subscript Effect. (The size and position are controlled by the
Size and Offset fields described below.)

Super - characters are displayed in a smaller font size and in the
superscript position; thus, ¹ ² ³. This acts in the same way as
the Superscript Effect.

The line spacing is unchanged.

Size

This specifies the size of subscript and superscript characters
relative to the current font size. For example, 50% sets subscript/
superscript characters to half the current font size. Note that you
can set Size independently of Sub and Super. This provides extra
flexibility for specifying subscript and superscript characters.

A value of 0 has a special meaning. Subscript and superscript
characters then appear in the default values that applied to

 112 Impression Manual

Impression Publisher



previous versions of Impression (such as Impression II or
Impression Junior) that had fixed values for size.

Offset

This is similar to Size (described above). These fields specify the
offset of subscript and superscript characters from the baseline.
For example, for 12pt text, a value of 50% offsets the subscript or
superscript characters by 6pt.

Like Size, a value of 0 uses the same default offsets as previous
versions of Impression.

To maintain a consistent look to your document, you often define
Size and Offset in Normal Style but set Script to off. Other Styles
can then set Sub or Super on and use the settings for Size and
Offset defined in Normal Style.

Æ Colour

This controls the colour of the characters which is, by default,
black. Click on the colour icon to display the Colour Picker
(described in 2.12 Colour handling).

Ç Background colour

This defines the colour of the background on which the text is
displayed. Click on the colour icon to display the Colour Picker
(described in 2.12 Colour handling). It is unusual to set a
background colour.

Technical note: the font manager�s anti-aliasing tries to anti-alias
between the font background and the font foreground colours.
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Text dialogue box

This controls effects that usually apply to areas of text rather than
individual characters.

À

Á
Â
Ã

Ä

Å
Æ

Ç
È

À Underline

Off - no underline is drawn.

1 - a single line is drawn under text in this Style (like this). This
acts in the same way as the Underline Effect.

2 - a double line is drawn under text in this Style.

Offset

Offset is the position of the underline relative to the character
baseline. Size specifies the thickness of the underline. In both
cases, the value is relative to the current font size. 0 selects the
same default values used in previous versions of Impression.

For flexibility, you can specify Offset independently of applying
an underline. Often you define Offset in Normal Style but set
Underline off.
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Á Strikeout

When this attribute is on, a single line is drawn through the
characters (like this). The line is drawn in the Under/Strike colour.

Â Under/strike colour

This controls the colour of the underline and strikeout lines. You
could create a Style that sets only this one attribute (although it
would probably not be very useful).

Ã Tracking

This lets you change the spacing between characters. Specify the
extra space between characters in 1/1000ths em.

sample text with no tracking
s a m p l e  t e x t  w i t h  2 0 0 / 1 0 0 0  t h s  e m  t r a c k i n g

If you output this document to a PostScript file:

Applying tracking to a large area of text can create very large
PostScript files.

Note the difference between tracking and kerning. Tracking

changes the horizontal spacing between groups of characters.
Kerning changes the spacing between individual pairs of charac-
ters. Kerning can also change the vertical alignment between a
pair of characters.

Ä Hyphenation

This turns on or off the automatic hyphenation. For hyphenation
to work, the hyphenation module must be loaded; see Hyphen-
ation in 2.14 Spell checking and the dictionaries for more details.

Selecting on automatically loads the hyphenation module if this is
not already loaded.
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Å Leadering string

The leadering string can be from one to four characters long and
contain any printable character. This string is drawn by Impres-
sion whenever it meets a tab character in text with this Style
applied. The space between the tab character and the next tab
position on the current ruler is filled with the leadering string. A
commonly used string is three full stops and a space (�... ... ... ... �).

Its most common use is in contents pages to draw the eye across
to the page numbers.

Æ Decimal tab character

This is the character that decimal tabs align numbers or text to.
You can use any single character such as 

. , · ± (12.3 12,3 12·3 12±3)
(Centre decimal point is character 183, ± is character 177.)

Tabs are described in 2.7 Rulers.

Style labels

Style labels are not true effects because they do not change the
format of the text. They mark text for inspection by the index and
contents compilers. Any text with these effects set will be found
by the compilers even if they are overlaid by other Styles that do
not have this attribute set. See 2.15 Contents and index genera-
tion for more details.

Ç Index label

This marks text that is to appear in the index. Normally you create
a Style that has only this attribute set and apply it to appropriate
words or phrases. 

It is sometimes useful to set the background colour so that you
can see which text has this attribute set. Remember to reset the
background colour before printing anything.
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È Contents label

This marks text that is to appear in the contents list. Typically, the
Styles used for main headings and sub-headings have this
attribute set so that they are automatically included in the contents
list.

See 2.15 Contents and index generation for details of using
Level.
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Paragraph dialogue box

This controls effects that are normally applied to complete
paragraphs. Selecting any of these effects, sets the Paragraph

apply button on the main Style Editor dialogue box.

À
Á
Â
Ã
Ä

Æ
Ç

Å

È
É

Î

À Space above paragraph

This sets the amount of extra space inserted above a paragraph.
Set 0 if you do not want any extra space.

Typically you would use this to insert extra space above
headings.

Á Space below paragraph

This is the amount of extra space inserted below a paragraph. (A
paragraph ends when you press Return.)

If you want a blank line below each paragraph, set Space below

paragraph to the same value as the line spacing. Using Space

below paragraph avoids the chance of a blank line at the top of a
frame as can happen if you type an extra Return character at the
end of each paragraph.
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If you do not want any extra space below a paragraph, set Space

below paragraph to 0.

Â Ruler and Auto-indent

Click on Ruler if you want to associate a ruler with this style. That
is, if you want this Style to set different tabs and margins. Click on
Auto-indent if you want text in this Style to auto-indent from the
current ruler. Rulers and auto-indenting are described in 2.7
Rulers.

Ã Alignment

This acts in the same way as the Alignment Effect. Refer to that
description for examples of the four types of alignment.

Ä Line spacing

This acts in the same way as the Line spacing Effect. It is the space
between the top of one line of text and the top of the next line.
This is often called leading from the strips of lead traditionally
used when setting metal text. 

You can define line spacing as:

� An absolute value. For example, 15pt. If you later change the
text size, the line spacing does not change. To enter an
absolute value, clear the % button (É).

� A percentage of the current font size. For this set the
% button (Î). If you later change the text size, line spacing
automatically adjusts to suit the new value. Traditionally line
spacing is 120% of the current font size.

Examples:

This block of text 10pt text; 10pt line spacing
shows the effect
of line spacing.

This block of text 10pt text; 12pt line spacing
shows the effect (120% spacing)
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of line spacing.

This block of text 10pt text; 16pt line spacing

shows the effect (160% spacing)

of line spacing.

A spacing of 0 has a special meaning. Any text using this spacing
does not affect the line spacing. This is useful if you want to
include some large text in the middle of a line without affecting
the line spacing. For example:

Without defining the line spacing, the words “large text”
move the middle line down. large text. This gives an
unbalanced look to the paragraph.
In this paragraph “large text” has a line spacing of 0. This
retains the existing line spacing. large text. The paragraph
now has even spacing between the three lines.

A common use for large text is including the Dingbats telephone
symbol (character 37) in a line of text. This is a small character
and looks better in a larger font size:
   a 0442 63933 (a and text at 10pt)

 a 0442 63933 (a at 14pt) (To get the telephone symbol
level with the number, we kerned the number up slightly. The
second telephone symbol shows the result without kerning.)

Å Lock to page grid

On complex, multi-column documents, you often want to ensure
that lines of text are aligned across the columns.

With this option selected, lines of text lock to an invisible grid
covering the entire page. The result is that any text in a Style with
this grid-lock attribute set always aligns across columns regardless
of where the tops of the frames are positioned or what text
occurred before or what objects occur over the frames.

Lock to page grid overrides the current line spacing value.

The Alter master page and New master page dialogue boxes let
you specify the grid spacing. Refer to 2.10 Master pages for more
information. Note that only Y offset & spacing affects text. 
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Show flow on the Icon Bar Menu or the Toolbar displays the grid.

Æ Keep together

Often the bottom of a frame splits paragraphs across two frames.
Documents look better if you avoid having only the first line of a
paragraph at the bottom of a frame. (The technical term is an
orphan.) Keep together lets you avoid this.

If the first line of a paragraph is closer to the bottom of the frame
than the Keep together value, the text moves to the start of the
next frame. 

text with Keep together set

Keep together value

The value entered is the distance from the bottom of the line. So,
for example, if you want to keep the first two lines together, make
Keep together equal to the line spacing. If you want to keep three
lines, make Keep together equal to twice the line spacing.

Ç Keep single paragraph

This acts in the same way as the Keep together ⇒ Paragraph

Effect. (See 2.5 Effects for details.) It ensures that the whole
paragraph appears on one page and is not split across a frame
boundary.

È Keep multiple paragraphs

This acts in the same way as the Keep together ⇒ Paragraphs

Effect. (See 2.5 Effects for details.) It ensures that a group of
paragraphs appears on one page and is not split across a frame
boundary.
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É Keep with next paragraph

This acts in the same way as the Keep together ⇒ Next Effect.
(See 2.5 Effects for details.) It ensures that this paragraph and the
following paragraph always appear together on the same page
and do not split across a frame boundary.

Its main use is to prevent headings appearing as the last line on a
page. Keep with next, applied to a heading Style, ensures the
heading is kept with the body of the paragraph. (The heading and
first paragraph immediately above are so marked, forcing a page
break before it, if part of it would otherwise split acreoss a page.)
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Rules dialogue box 

This part of the Style Editor controls Rule-offs and Vertical rules.
For more details on using these to create tables and grids, refer to
Creating tables.

À
Á Â
Ã Ä
Å
Æ

A rule-off is a horizontal line drawn whenever a Return (end of
paragraph) is met in this Style. Rule-offs can be drawn either
above and below the text or in just one of these positions. 

Note the difference between rule-offs and the underline effect.
Underline only draws a line under those characters where the
attribute is set. Rule-offs are drawn between margins only when a
Return character in this Style is seen. (The margins are the special
rule-off margins or, if you do not define these, the text margins �
for more information, see 2.7 Rulers.) You cannot draw a rule-off
in the middle of a paragraph.

À Rule off

Set this switch on if you want to draw horizontal rule-offs above
or below a paragraph. (Remember, a paragraph is any block of
text terminated by a Return � it can be just a single line of text.)

Rule-offs are displayed behind any text. This can be used to
highlight the last line in a paragraph.

Thickness controls the vertical width of the rule-off lines. A
thickness of 0 is an invisible line.
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Á Above text switch

Set this switch on if you want to draw a rule-off above the text.
The Offset field Â controls the position of the rule-off.

A rule-off above is drawn if this effect is applied to the first line in
a paragraph.

If the preceding paragraph has Rule-off below set, this overrides
any settings for Rule-off above for this paragraph. In fact, no rule-
off above is drawn and vertical rules (if any) align with the
preceding rule-off below.

Â Offset editable field

This controls the vertical position of the rule-off or top of vertical
rules (described in 2.7 Rulers) relative to the top of the text.
(Technically the top of the text�s bounding box.) A negative value
moves the rule-off downwards; a positive value upwards.

If necessary, Impression increases the distance between lines of
text to ensure rule-offs do not overlap the previous line:

        

This line has no rule-off.
This line has a rule-off
above with 0 offset.

This line has no rule off.

This line has a rule-off
above with 5pt offset.

Ã Below text switch

Set this switch on if you want to draw a rule-off below the text.
The Offset field Ä controls the position of the rule-off.

A rule-off below is drawn if this effect is applied to the last line in
a paragraph.

Ä Offset editable field

With a value of 0, the rule-off or the bottom of a vertical rule is
directly below the text. In this position rule-offs may clip
descenders on characters such as �y�. A negative value moves the
rule-off downwards; a positive value upwards.
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Å Rule-off colour

This controls the colour of the rule-offs.

Æ Vertical rule width

Set the switch on if you want vertical rules (described in 2.7
Rulers). Remember to put vertical rule tabs on the ruler in the
required positions.

The editable field controls the width of the vertical rule. Note that
a thickness of 0 is an invisible line.
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Merging Styles

Click on the Merge button in the Style Editor to display a menu of
available Styles. (The first option Merge from cursor is described
below.)

Clicking on a Style name merges the effects of that Style with
the information in the Style Editor. Only the information in
the Style Editor changes; the merging Style (the one you
chose from the menu) is unchanged. You can merge several
Styles in this way.

The new Style name is a combination of the names of the Styles
that were merged into it. For example, if you merge Style1 and
Style2, the Style in the Style Editor is called Style1/Style2. You can,
of course, edit this name if you wish.

Merge from cursor

This is the first option on the menu. It is greyed if there is no
cursor (for example, when there is a selected region). If you click
on this option, the information in the Style Editor (if any) is
merged with the Effects and Styles set at the cursor. This is useful
for easily creating new Styles from combinations of Effects. By
creating some text with the required Effects and Styles applied,
you can preview the appearance of the new Style. The new Style
is called From cursor.

You can also use Merge from cursor to alter an existing Style
(including Normal). Display the Style you want to change in the
Style Editor and then click on this menu option. The Effects and
Styles set at the cursor are then merged with the existing Style
information in the Style Editor. The Style name has /from cursor
appended to it.

Automatic Style naming

When you create a new Style, the name in Style name is Untitled.
If you do not change the name before clicking on OK, the Style
Editor will give it an appropriate name.
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2.7 Rulers

This section covers:

• types of ruler

• using Text rulers

Related sections of this manual:

• 2.5 Effects

• 2.6 Styles
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Rulers in Impression

There are two completely separate types of ruler:

� page rulers, and

� text rulers.

Page rulers are displayed along the top and left-hand edges of the
frame. 

Page rulers

They allow you to measure items but have no effect on the format
of the document. They are only displayed for information. Show

page rulers in Preferences on the Icon Bar Menu, View ⇒ Page

rulers and a keyboard short cut of Ctrl-P turn the page rulers on

and off. 

The following descriptions cover text rulers.

Text rulers allow you to adjust the margins and tab positions for
the document and so have an important part in formatting the
document. A �ruler� is a specific set of margins and tab positions.
There are two types of text ruler:

� local rulers, and

� style rulers.
Local rulers are used in just one place. You create them by simply
dragging the blobs on the ruler. 

Style rulers are, as the name suggests, associated with a style. (A
style can merely define a ruler, if that is what you require.) You
can use a style again and again throughout a document.

If you look through this manual, you will see that we use a
number of different rulers. For example, headings in this manual
have their own ruler which positions them to the left of the body
of the text. 
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Similarly, sections are often indented to the right like this, to
emphasise something or to list options. This requires a
different set of margins and tabs to the default ruler that
controls the main body of the text.

To display or hide the current ruler (local or style) use View ⇒

Tool bars ⇒ Style ruler. 

A typical text ruler

Rulers are always displayed at the top of the Impression window.
The zero point on the ruler usually aligns with the left-hand edge
of the selected frame. (It does not align if you have set Insert in
the Alter frame dialogue box � see 2.8 Frame handling for
details.) If you click in a different frame, the ruler moves to keep
its alignment with the frame edge.

All text has at least one ruler applied to it (the ruler defined in
Normal Style).

The ruler shown is that currently applied at the cursor or in the
selected region. The exceptions are:

� When the Style Editor (see 2.6 Styles) is displayed on screen
� the ruler associated with that style is then shown. (No ruler
is shown if the style does not define a ruler.) 

� When you display a selected region that contains more than
one ruler. The appearance of the ruler changes to indicate
that multiple rulers are present.

Note to users of Impression II and Impression Junior:

This is different to the way rulers worked in these programs. The
ruler now always reflects the state at the cursor or in the selected
region as a result of local rulers and styles � as you move the
cursor, it updates.
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Changing text margins (create a local ruler)

1 Select the region of text you want the ruler to apply to.

2 If necessary, display the text and ruler bars. (View ⇒ Tool

bars ⇒ Show text/ruler bars.)

3 Modify the ruler by adding or removing tabs or changing the
margins. This automatically creates a new local ruler and
applies it to the selected text.

This operation creates a local ruler, that is, a set of margins that
applies only to this text. A style ruler, on the other hand, is a set of
margins and tabs that can be used in many different parts of the
document. It is a just a ruler within a style.

Creating a new style ruler

You can either:

1 Create a new local ruler or select some text containing an
appropriate local ruler.

2 Create a new style using the Define dialogue box. (This is
described in Creating a new style in 2.6 Styles.) You can
therefore reuse a local ruler by converting it to a style ruler.

or

1 Create a new style using the Style Editor.

2 Select Ruler in the Paragraph dialogue box of the Style
Editor. This displays the ruler bar which you can modify as
required.

4 Click on OK in the Style Editor to implement the change.
(For more details. see 2.6 Styles.)

A style ruler is just a style that defines a ruler. So like a style, it has
a name and can be used in many different places.
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Changing a style ruler

You can either:

1 Display some text in the required style.

2 Move the tabs and margins as required on the ruler.

3 Redefine the style using the Define dialogue box. (This is
described in Modifying styles in 2.6 Styles.)

or

Use the Style Editor (described in 2.6 Styles).

Creating an auto-indenting ruler

These are useful when creating lists and tables. An auto-indenting
ruler automatically indents from the left-most tab of the current
ruler. For example:

� This is the current ruler:

This is some sample text to show the effect of the above ruler. This is
some sample text to show the effect of the above ruler. This is some
sample text to show the effect of the above ruler. 

� The ruler below is auto-indented, created from the current
ruler. Notice that it is indented from the left-most tab of the
current ruler at 3.2cm.

This is some sample text to show the effect of the above ruler. This
is some sample text to show the effect of the above ruler. This is
some sample text to show the effect of the above ruler. 

Auto-indented rulers are created when you apply a style with the
Auto indent option set. This option is in the Paragraph dialogue
box of the Style Editor.

The auto-indented ruler has no effect if you later overlay the text
with a local ruler or another style that defines a ruler.
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Removing a local ruler

1 Select the region of text with the ruler applied.

2 Choose Effects ⇒ Ruler:

Removing a style ruler from the text

1 Select the region of text from which you want to remove the
style ruler.

2 Remove the style. For details of removing styles see remov-
ing a style from the text in 2.6 Styles.

Removing a ruler from a style

1 Display the style in the Style Editor.

2 Display the Paragraph dialogue box of the Style Editor.

3 Click on Ruler to deselect it. This removes the ruler from the
Style.

4 Click on OK in the Style Editor to implement the change.
(For more details. see 2.6 Styles.)
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The ruler bar

À Á Â Ã

Click here to display the tabs

À Bump icons

Use these to step through items on the ruler.

If the cursor is in the editable field Â, pressing Tab has the same
effect as clicking on the right-facing bump icon. Pressing Shift-
Tab is the same as clicking on the left-facing bump icon.

Á Ruler icons

left right

right

left

left

right
centre

decimal

Rule-off margins

Text margins Tabs

Vertical rule

1st Line

The tabs are described later. Vertical rule in Creating tables in 2.6
Styles.

Left margin

Except for the first line in a paragraph (which is controlled by the
1st line margin), this defines the left margin for all text using this
ruler.

Right margin

This defines the maximum right-hand margin. The right margin is
relative to the right-hand edge of the frame and so defines the gap
between the edge of the text and the edge of the frame.

The right margin is normally relative to the right-hand frame
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edge. If you position it 3mm from the right-hand frame edge, it
maintains that 3mm margin even when the ruler is applied to a
different sized frame or the frame resized. When typing into
editable field use:

� negative numbers for right-relative values, and

� positive numbers for left-relative values.

Be careful about placing small text actually touching a frame�s
edge. It can be very difficult when using the mouse to position
the text cursor between the frame�s edge and the adjacent letter.

1st line margin

(Also called the Return margin.) When you press Return, the
cursor moves to this position on the next line. If you want all left-
hand margins to be in line, set this margin to align with the left
margin. (If you are creating or editing a ruler and you do not
place the 1st line margin on the ruler, it is automatically aligned
with the left margin.)

Rule-off margins

These control the left and right margins of rule-offs. (Refer to
Rules dialogue box in 2.6 Styles for details of associating rule-offs
with a style.) This is the ruler for the rule-off below this
paragraph:
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Â Editable field

Click on a tab or margin to select it. The editable field then tells
you the exact position of that tab or margin on the ruler. You can
move items on the ruler by:

1 selecting the item,

2 typing their new value into the editable field, and

3 pressing Return.

You can also place extra tabs on the ruler by:

1 clicking on the appropriate icon in Ruler icons,

decimal tab selected
2 typing the required position into the editable field,

3 pressing Return.

(You can also move and place items on the ruler by dragging
icons � this is described later.)
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Ã Units

Click on this box to step through the available ruler measurement
units. These are 

centimetres
inches (1/10ths divisions)
picas (a pica is 1/6th inch).
inches ( 1/8ths divisions)

Changing the units only changes measurements displayed on the
ruler. It has no effect on items placed on the ruler.

137 

2.7 Rulers



Tabs

This diagram shows how the types of tab available in Impression
are used:

This is some 1.0
text that illustrates 123.45
the various types .0123
of tab. The 67.89
right hand column .00004
is a decimal tab

� The first column is controlled by the conventional left tab.
Text is left aligned. 

� The second column is controlled by a centre tab meaning
that the entire column is centered around the tab position. 

� The third column is controlled by a right tab. Text is right
aligned to the tab point. 

� The last column is controlled by a decimal tab which is only
usually used for columns of numbers. In this case the whole
column is aligned around the decimal point as is traditional
for tables of figures. Anything without a decimal point in it
treats this as a right tab.

The character used as a decimal point is specified in the Style
Editor (see 2.6 Styles).

Vertical rule

These are placed on and moved around the ruler exactly like
ordinary tabs. However, they are not used to format text but to
position vertical rules. These are lines used to construct tables
and grids � for more information, see Creating tables in 2.6 Styles.
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Note that before a vertical rule is drawn, you must have set:

� a vertical rule in the required position on the ruler,

� set the Vertical rule width switch in the Rules dialogue box
section of the Style Editor, and

� set a width other than 0 (which is an invisible line).

Placing and moving items on the ruler

You place or move items on the ruler by:

� Clicking on one of the icons to highlight it. 

Then, click on the graduated scale. This places one of those
items at that position on the ruler. 

This mainly applies to tabs, as you can have up to 32 tabs (of
varying kinds) on the ruler at once. With margins, you can
only have one of each type on the ruler, so clicking with a
margin highlighted moves that margin to a new position on
the ruler. 

Restriction: The right margin must be to the right of both
the return margin and the left margin. The margin does not
appear if you click in an illegal place.

� The icons can also be dragged, either from their current
positions on the ruler, in which case that item�s position
changes,

 ß

ß

or from the icons at the top of the ruler which places a new
item on the ruler. 

à

If there is already one of those items on the ruler (in the case
of margins) or there are already 32 tabs on the ruler (in the
case of tabs) then dragging has no effect.
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� The editable field lets you accurately place the icons. This is
described above in Ã Editable field.

You can combine dragging icons with using the editable field.
You could drag or drop icons on the ruler in approximately the
required position and then accurately position them using the
editable field.

When dragging items around the ruler, notice that they appear to
�stick� to the ruler, as if the ruler were magnetic. This means you
can tell if an item is being placed correctly: if it sticks, it stays on
the ruler if dropped.

Notice that when you drag items along the ruler, they snap to the
ruler marks. To disable this snapping, hold down Shift during the
drag. 

If you Adjust-drag an item, you also move any items (except the
margins) to its right. This lets you move several tabs in one
operation.

Removing items from the ruler

To remove an item from the ruler, drag it from its current position
upwards, until it no longer sticks to the ruler. 

à

Dropping the item while it is still sticking to the ruler only alters
its position. It does not remove it.

Changing tab types

Remove the existing tab and place a tab of the correct type in the
same place. The editable field shows the exact position.

Indents and hanging indents

It is quite a common requirement to have a series of numbered
paragraphs where the numbers hang to the left of the main text
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left margin. This is sometimes referred to as an �outdent�. Impres-
sion can create this attribute very easily by using the 1st line
margin. The position of this on the ruler controls the left edge of
the first line of every new paragraph. This is often useful if the
first line of each paragraph is to be indented, in which case the
symbol would be positioned a small amount to the right of the left
margin indicator.

A hanging indent would be the opposite. The 1st line margin
symbol would be positioned slightly to the left of left margin thus

This creates the following result.

1. This is a numbered paragraph. As this line is at the start of a
new paragraph it starts slightly to the left of this second
line. Indeed all subsequent lines will use the left margin
until the start of the next paragraph.

2.  In fact we can go one better than this by using the tab
feature as well. With the ruler shown above, the first line
of every paragraph will start outdented. However this may
not always be wanted.

For example, a paragraph that does not start with a number
would normally look better if it lines up with the normal
left margin and is not outdented. 
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Of course this can be achieved simply by typing a few spaces at
the line start but it can be quite difficult to get accurate results.
However, if a tab symbol is positioned exactly coincident with the
left margin thus:

then it is only a matter of pressing the tab key at the start
of a paragraph to move the line start to the normal left
margin position. In the above diagram the left tab is
positioned directly over left margin mostly obscuring it.

1. This is an outdented numbered paragraph.

Whereas this paragraph starts with a tab so that its left
edge aligns with the left margin.

2. Whereas this is a normally outdented line again.
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2.8 Frame handling

This section covers:

• the types of frame

• flowing text stories

• grouping frames

• frame borders

• the Alter frame dialogue box 

Related sections of this manual:

• 2.9 Graphics handling

• 2.10 Master pages
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How Impression uses frames

A frame is a box that contains either text or a graphic. Everything
in a document is contained within frames and all editing action
occurs within a frame. You cannot mix text and graphics inside a
single frame, but by overlaying text and graphic frames you can
produce a page that appears to freely mix text with graphics.

Example text and graphic frames

A frame cannot be larger than the page it exists on nor can it
extend onto another page. Within these limits, you can create,
move and adjust frames as you wish.
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There are these types of frame:
� blank 

� text

� graphic
� guide,

and they can be used as
� master page frames

� local frames

blank, text, and graphic frames can also be used as
� repeating frames

� headers & footers (a special form of repeating frame)
� embedded frames.

You create a frame as either a blank frame, a blank repeating

frame or a guide frame.

Blank frames

If you type or drop text into a blank frame, it becomes a text
frame.

If you drop a graphic into a blank frame, it becomes a graphic
frame. A graphic is usually an illustration. (For more details on
graphics, see 2.9 Graphics handling.)

You cannot drop a graphic into a text frame or put text into a
graphic frame.

Irregular frames

These are a special form of graphic frame. Irregular frames can
have any number of sides, which do not have to be horizontal or
vertical. All other frame types are rectangular with vertical and
horizontal sides. Irregular frames are useful in masking parts of a
graphic or flowing text around a graphic.

Guide frames

These are used to position other frames and cannot themselves
hold text or graphics. They are used to create magazine-type page
layouts which are usually multi-column. Guide frames would then
show the positions of these columns, and text and graphic frames
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would be positioned to the column outlines. 

Guide frames have an orange outline.

Guide frames cannot be used as repeating or embedded frames.

There is more on guide frames later in this section.

Master page frames

Any frame on a master page is a master page frame. (For informa-
tion on master pages see 2.10 Master pages.)

Local frames

A local frame appears only on a single normal page (that is, a
page that is not a master page).

Repeating frames and Headers & footers

You sometimes want to repeat information on several consecutive
pages (like the heading to this page � 2.8 Frame handling). To
do this you use these types of frame. 

There is more later in this section.

Embedded frames

These are text or graphic frames embedded into the text. They are
described in detail later.

The selected frame

Normally you can only move or resize the selected frame. The
selected frame always has a solid outline (orange for guide
frames, blue for irregular frames and green for other frame types).
Click Select inside a frame to select it.

You can also move or resize a frame if it is a multiple selected or
grouped frame � described later.
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Creating new frames

Use Frame ⇒ New frame ⇒ submenu or 
Ctrl-Shift-I for a new blank frame or 
Ctrl-Shift-E for a new repeating frame.
There is no keyboard short cut for guide frames.

You can also use Frame tool on the Toolbar. Select-click on the
tool to display the submenu. Adjust-click to choose Blank frame.

1 A pair of cross-wires tracks the mouse pointer. Position them
where the top left-hand corner of the frame is to be. 

2 Press and hold down Select. 

3 Drag the cross-wires to where you want the bottom right-
hand corner to be. 

4 When in position, release Select. 

The newly created frame is always the selected frame.

Dragging frames about the page

Frames can only be physically moved about a single page. To
move a frame to another page or document, use cut and paste.

Frames can be moved using either the mouse or a dialogue box.
Using the mouse is generally easier but is not so precise as using
the dialogue box.

Using the mouse

This method will not work if the frame has been locked in place.
(Lock frame is set using the Alter frame dialogue box � described
later.) Also, it does not work for master page frames except in the
master page window. (See 2.10 Master pages.)
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Position the mouse pointer inside the frame and then either

� hold down Select for at least a second, or,

� for immediate effect, first hold down the Ctrl key and then
press Select. (This only works if the frame is the selected
frame.) 

In both cases, the mouse pointer changes shape to signify that the
frame can be moved about. You must keep the mouse button
held down as you move or drag the frame about. 

Alternatively position the mouse pointer over any edge of the
selected frame, avoiding the frame handles (described later). The
mouse pointer changes shape. You can now slide the frame as
just described. This method requires precise positioning of the
mouse pointer. You may not be able to pick up some of the
edges (particularly vertical edges).

Using the Alter frame dialogue box

Use Frame ⇒ Alter frame or the Toolbar to display the Alter frame
dialogue box. This is described later.

Cutting, Copying and Pasting frames

Cut Frame

Edit ⇒ Cut frame or Ctrl-X or the Cut tool on the Toolbar.

This option copies the frame to the clipboard and deletes it from
the document. 

If the frame contains a complete story or a graphic, or an embed-
ded frame, then the story, graphic, or embedded frame is cut as
well. 

If the frame contains a text story that flows into other frames, then
removing this frame causes the text to re-flow in the remaining
frames. That is, it only cuts the frame, not the contents.

A frame is cut with all its attributes including border style,
dimensions, background colour and story type. 
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If the frame is a master page frame, it can also be deleted from the
page on a local basis. This does not cut the frame from the master
page � it simply removes the local copy of it on this page. To
delete the frame from the master page, go to the master page
(View ⇒ View master pages) and use this option or the similar
Delete frame option.

Copy frame

Use Edit ⇒ Copy frame or Ctrl-C or the Toolbar.

This is similar to Cut frame except that the frame is only copied to
the clipboard. It is not removed from the document.

Paste Frame

Use Edit ⇒ Paste frame or Insert or Ctrl-V or the Toolbar.

A pair of cross-wires tracks the pointer. Position them to where
you require the top left-hand corner of the frame. When in
position, click Select to paste the frame.

If the frame holds a complete story, then the story is also pasted.
Similarly, if the frame contains a graphic, that is also pasted. 

If a frame has been cut or copied from a series of flowing text
frames, then its contents are not copied to the clipboard. In this
case, the frame becomes an empty frame when it�s pasted back �
relink text into it if required.
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Resizing frames

There are two ways of changing the size of the selected frame.
You can either:

� Use the mouse to drag one of the eight frame handles.

Frame handles
ß

ß

ß

ß

This allows you to see how the resized frame will look as
you alter it. You cannot use this method if the frame has
been locked in place or for master page frames on local
pages.

You can use either Select or Adjust to resize the frame. If the
frame contains text or is empty (blank), both buttons have
the same effect. If the frame contains a graphic, Adjust

resizes both the frame and the graphic; Select only resizes
the frame and leaves the graphic size unchanged.

� Use the Alter frame dialogue box (described later). This
option lets you alter the position on the page, the height, and
width of the frame. Although you cannot preview how the
resized frame will look, this lets you accurately control the
frame�s position.

Impression reformats any text within a frame when it is resized.

Transparent frames and repelling text 

Normally, any underlying text flows up to and around the
boundaries of the frame. If required (by using the Alter frame
dialogue box), text can be repelled away from a frame�s bound-
aries or can flow under the frame as in this example (the frame
has a solid outline):
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This is some sample text. This is some
sample text. This is some sample text.
This is some sample text. This is some
sample text. This is some sample text.
This is some sample text. This is some

If you want underlying text to be repelled away from the borders
of a frame, set the Repel text outside option and enter the
required values in the editable boxes. This example uses 2mm
repel to the left and 10mm on the right.:

This is some sample text. This
is some sample text. This is some
sample text. This is some sam-
ple text. This is some sample text.
This is some sample text.

If you want to see text or a graphic that is underneath the frame,
set the frame background to transparent. (This option is on the
View page of the Alter frame dialogue box.)

This is some sample text. This is some sample text.
This is some sample text. This is some sample text.
This is some sample text. This is some sample
text.This is some sample text.This is some sample
text.This is some sample text.This is some sample 

If you want the frame to hide any text or a graphic that is under-
neath it, make the frame opaque by setting a background colour.

This is some sample text. This is some sample text.
This is some sample text. This is some sample text.
This is some sample text. This is some sample
text.This is some sample text.This is some sample
text.This is some sample text.This is some sample 

Irregular frames have only a single value for repel which applies
to all sides. There is more on irregular frames later.
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Changing the stacking order of frames

When you create a frame, that frame is always the �front� frame
(other than a guide frame, which is always behind other frames)
and masks any parts of other frames that it overlaps. 

Front frame

Back frame

You can change the frame order using:

� Bring to front or the Bring to front tool. These move the
frame in front of all other frames. 

� The Move forward tool. This moves the frame one step
towards the front.

� Frame ⇒ Put to back or the Put to back tool on the Toolbar.
These move the frame to the back, behind all other frames.

� The Move backward tool. This moves the frame one step
towards the back.

Move forward
Move backward

Bring to front
Put to back

Be careful when using the backwards options as you may
accidentally hide a frame behind a larger frame. If this happens,
the next section explains how to retrieve the frame.

Selecting overlapping frames

If you have a frame hidden by another overlapping frame, you
cannot select it by clicking on it because of the overlapping
frame. To select the underlying frame:

� Use the Put to back menu option to move the overlapping
frame to the back. This lets you select the previously hidden
frame as normal.

� Position the mouse pointer over the underlying frame. Hold
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down Alt and then click on a mouse button to select the
frame. Using Alt-click allows you to alternate between the
two frames. This method can be used on any number of
overlapping frames.

Flowing text 

Where you want text to flow from one frame to another, you can
link those frames. The text can then flow from frame to frame and
from page to page as you require.

To allow text to flow

from this frame

to this frame

first click Select
in this frame

and then click
Adjust in this frame

(The right-hand frame

must be a null frame)

You can link frames together at any time, either before entering
any text or while you are typing in the text.

You can also link in more frames this way. Click Select in the last
frame in the story and then click Adjust in the frame to be added.
(You can add more frames in the middle of the chain in exactly
the same way.)

If you subsequently delete one of the frames, the text story
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reformats itself in the remaining frames.

Although a frame may appear to be empty on screen, it could be
a text frame linked to others in a chain of text.

Show flow on the Icon Bar Menu or the Show flow tool shows the
text flow of those frames currently displayed in the editing
window. Arrows from the bottom-right corner of a frame to the
top-left of the next frame indicate the text flow.

Text story frames linked

More on...

...repeating frames

Repeating frames are ideal for inserting headers and footers into a
document. These are small frames at the top and bottom of each
page containing, for example, section headings or page numbers.

If you put a repeating frame on one page of a left/right pair of
pages, it does not repeat on the other page of the pair. This lets
you position different headers and footers on both sides.
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To show its application, assume you have a 6-page document

1 2 3 4 5 6

and you want a repeating frame on pages 2, 3, & 4.

If you put a repeating frame (RF) on page 2, it will initially appear
on pages 2 to 6 but not on page 1:

1 2 3 4 5 6

RFRFRFRFRF

To stop the frame appearing on pages 5 and 6 of the finished
document, remove it from page 5 by selecting and then deleting
it. It then disappears from pages 5 and 6 but remains on pages 2
to 4:

1 2 3 4 5 6

RFRFRF

There are certain rules with repeating frames:

� You can move or resize a repeating frame on any page
where it is used. This changes the other copies of that frame.

� You can move a graphic in a repeating frame on any page
where the frame is used. This changes the graphic in the
other copies of the frame.

� You can only edit text in the first frame and not in any of the
copies. A quick way to move to the first frame is to double-
click in any of the copies.

� Repeating frames cannot be grouped. (Grouping and
multiple selection of frames are described later.)

...Headers & Footers

These are a special form of repeating frame. Edit ⇒ Add Header
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adds a header frame to the top of the page and Edit ⇒ Add Footer

Adds a footer frame to the bottom of the page. You can then enter
text or drop a graphic into the frame.

You may want to change to a different header or footer part way
through a document. Make the first page where the new header
or footer is required the current page. (The current page contains
the selected frame.) Then choose Add Header or Add Footer. 

...guide frames

To help when aligning frames  set Frame ⇒ Snap ⇒ To guides.
When this option is set, any frame edge brought close to a guide
frame snaps to the guide frame as though drawn to a magnet.

(There is a similar option, Frame ⇒ Snap to frames, that snaps to
the other types of frame. You can make snapping the default �
see 3.14 Customising Impression for details.)

If you change a local guide frame, this does not affect any frames
already snapped to it. 

If you change a master page guide frame, the change applies to
any local frames already snapped to it.

...irregular frames

Only graphic frames can be made irregular. Irregular frames have
a blue outline if they are the selected frame and a solid light-grey
outline otherwise. Irregular frames are useful for cropping
graphics (as shown below) or repelling text away from an
irregular shaped graphic.

To make a frame irregular use
Frame ⇒ Make irregular.
When you make a frame irre-
gular, the only visible change is that the frame outline changes to
blue. However, the eight frame handles are now separate handles
on the edge of the frame. 
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Left: a graphic in a normal frame. 
Right: the same graphic cropped by an

irregular frame.
(Frame outlines shown solid.)



To make the frame regular again use Frame ⇒ Make regular.

You can only edit an irregular frame (add, delete or drag handles)
if Frame ⇒ Show irregular is set. (Shift-F1 toggles this option on

and off.) If Show irregular is off, a rectangular outline is drawn
surrounding the frame. You can resize the frame as a normal
frame.

To change the shape of the frame, drag any of the handles on
the frame edge.

To add a new handle, click on the frame edge.

To delete a handle, either:

� Shift-Select click on the handle

� drag the handle over another handle.

To rotate a graphic frame, Adjust-drag on the Rotate handle of
the graphics tool. (The graphics tool is described in 2.9 Graphics
handling.) Rotating a regular frame automatically makes it
irregular.

To scale the frame and the graphic inside it, Adjust-drag on the
Scale handle of the graphics tool. (You can also scale a frame and
graphic by Adjust-dragging a frame handle.)

You can apply a simple line border to an irregular frame. Refer to
the View dialogue box (later) for details.

You can repel text away from the edges of the frame by specify-
ing a repel offset in the Alter frame dialogue box (described
later). This offset is perpendicular to the frame edge:

Offset

Frame
edge
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Embedded frames

These are text or graphic frames that are embedded in the text
story. They retain their relative position in the story regardless of
any edits that may be made to earlier text. Most of the pictures of
menus and dialogue boxes in this manual are in embedded
frames.

    
You can increase or decrease the size of embedded frames,
except that they cannot be wider than the current text margins.

Embedded frames act like text. Thus, you can apply styles and
effects to them, such as centering them within a column of text.
Cut & paste or drag & drop operations on text that includes
embedded frames also copies those embedded frames.

To embed a frame, you

1 Create a local frame of approximately the required size.
(Final adjustments to the size can be made after the frame is
embedded.) 

2 Cut the frame to the clipboard.

3 Position the cursor where you want to insert the frame.

4 Embed the frame, either by typing Ctrl-Shift-F or using
Frame ⇒ Embed frame.

There is a quick way to embed a graphic:

1 position the cursor where you want to embed the graphic,

2 drop the graphic onto the current frame. This embeds the
graphic at the cursor � see 2.9 Graphics handling for more
details.
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For example, the graphic to the left and this text are in embedded
frames. (Frame outlines shown solid for clarity.) Embedding a
text frame next to a graphic is an easy way to add captions or
annotations to graphics.



Aligning frames

Aligning to other types of frame

Often you want to align the edges of two or more frames.
Impression makes this easy. Choose Frame ⇒ Snap ⇒ Snap to

guides (for guide frames), Frame ⇒ Snap ⇒ Snap to frames (for
other frame types). (The Frame snap tool toggles the current snap
selection on or off.) Then frame edges snap together or into
alignment as though drawn to a magnet. This option has two
uses:

� to snap frames or frame edges together:

Dragging this frame

close to this frame
snaps the frames together

� to align frames or frame edges:

Dragging this frame edge

close to this frame edge
snaps the edges like this

You can make frame snapping the default � see 2.16 Customising
Impression for details.
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Aligning to the page grid

The horizontal and vertical spacing of the grid is set when you
create the master page. See 2.10 Master pages for more details.
Click on the Show flow tool to display the page grid.

With Frame ⇒ Snap ⇒ Snap to grid selected, moving frames and
frame edges causes them to snap to the nearest grid point.

Multiple selection of frames

An example of using multiple selection � a graphic frame may be
overlaid with several text frames containing captions or com-
ments. To move the frames, you can multiple select them and
then move them as though they were one frame.

To do this either:

� select any of the frames in the usual way by clicking Select

inside it. Then hold down the Shift key and click Select in
each of the other frames in turn. As you click inside a frame,
its outline changes from dotted to solid. (To select overlap-
ping frames, you may need to also hold down the Alt key.)

� Hold down Shift and drag the mouse diagonally. This creates
a frame-selection rectangle.

When you have selected all the frames you can move them as a
single frame by dragging or cut and paste and so on.

You can also detach a frame from the group by Shift-clicking in it
again. (You cannot detach the frame showing handles.)

Multiple selection is useful if you want to delete several frames on
a page. Instead of selecting and deleting each frame in turn, you
can quickly multiple-select them and then delete them all at once.
It is also useful if you want to move several independent frames
together by the same amount (for example, to make space for
inserting a new frame).

Multiple selection only groups the frames temporarily. If you click
in another frame that is not part of the group, the grouping ends
and the frames again become independent of each other. To
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make the grouping permanent use Frame ⇒ Group frames. The
frames then always move as if they were a single frame.

To cancel the Group frames option, click Select in one of the
frames and then choose Frame ⇒ Ungroup frames. Do this if you
want to reposition one frame relative to the others in the group.

Grouped and multiple-selected frames can be cut, copied,
deleted, pasted, and dragged exactly the same as normal frames.

Grouped frames also scale together in proportion. This feature is
very powerful in two ways:

� Suppose you have three columns of text and you want to
make them all slightly wider. By grouping all three frames,
the group now acts as one, three-column frame. If you now
resize the group, all three columns change in proportion.
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Grouped and multiple selected frames rescale in slightly
different ways. 

      
The original frames

  

ß
Moving the right hand edge of multiple selected frames only

moves that edge. The left hand edges do not move and so the
distance between the frames gets narrower.

        

ß
Moving the right hand edge of grouped frames rescales the

frames and the gaps between them. The distance between the
frames gets wider.

� If a selection of graphic frames are grouped, they then
behave like a single graphic frame. Resizing the group
changes the size of all the individual parts. Using Adjust also
rescales the graphics (exactly the same as for a single
graphics frame).
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Creating duplicate frames

Frame ⇒ Duplicate frames lets you replicate one or more frames.
This is useful for creating forms and similar documents that have
several identical frames equally spaced. (For example, when
laying out business cards.)

Creating a series of duplicate frames

1 Either create a new frame or select an existing frame. (You
can also duplicate multiple selected frames.) This example
uses a 10mm square frame:

2 Display the Duplicate frame dialogue box (Frame ⇒

Duplicate frame) and enter the required values. Positive
values duplicate frames to the right (X offset) or down the
page (Y offset). Negative values duplicate to the left or up. A
blank field (Y offset in the illustration) means no offset:

3 Click OK to create the duplicate frames:

If the document layout requires it, you can now multiple select
these frames and then duplicate them again down the page.
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Drawing lines

Impression does not have a separate line drawing function.
Instead for drawing horizontal lines under text you can use rule-
offs. (These are described in Style Editor in 2.6 Styles.) For
drawing vertical lines you can use vertical rules. (These are
described in the 2.6 Style Editor and 2.7 Ruler.) 

There are also two ways of using frames:

� put a border on one or more edges of a frame (described
later), or

� create a separate frame and set an appropriate background
colour.

You can create lines of any size and in any position by creating a
long, thin frame the length and width of the required line. You
will find it easier to adjust the frame using the Alter frame
dialogue box rather than dragging the frame handles.

When you have created the frame, go to the View page of Alter
frame. Click on the Colour radio button and then click on the
Colour editable box. This displays the colour picker (described in
2.12 Colour handling) and you can use this to change the frame�s
background to black.

You can also create faint lines this way by changing the frame
colour. For printing, you may need to experiment using different
colours to get the required density of line.

Once a thin frame has been created, it can easily be used again
and again by copying it to the clipboard and then pasting it where
required.

If you want to create more complex lines or curves, we suggest
using !Draw to create the line. Place this in a transparent frame.
You can then use the graphics tool to scale, rotate, or position the
line as required.
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Borders

You can put a border around any type of frame (except a guide
frame). Each edge of the frame can have a different border design
or can have no border. (Special limitations apply to irregular
shaped frames � see below.) You can also specify a border
colour.

Eleven border designs are provided as standard by Impression.
These are:

1 ¼1/4 pt black line

2 1 pt black line

3 4 pt black line

4 ¼ 1/4 inch Dark grey mitred slab

5 ¼1/4 inch Light grey mitred slab

6 1/8 inch Black drop shadow left

7 1/8 inch Black drop shadow right

8 ¼ 1/4 pt black line and 1/8 inch offset 2pt black line

9 1/8 inch offset, centre and corners only, 4pt black line

10 ¼ 1/4 inch offset 4pt black line with curved corners.

11 Cut marks. This border is useful if you want to print one or
more a small cards or leaflets (such as business cards) on a
larger sheet of paper and then cut them to size after printing.

Appendix 6 shows these borders.

You can also create other border designs using !Draw and then
include them in a document. There can be up to 29 of these
borders (numbered 12-40).

There are some differences between the standard borders 1-10
and the draw-file borders 12-40:

� You cannot delete borders 1-11 from the borders list.
Borders 12-40 can be deleted.

� Borders 12-40 occupy space in the document. A complicated
border can require large amounts of storage space. This can
make even simple documents occupy a lot of disc space.
Borders 1-11 do not occupy space in the document.
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Putting a border around a frame or changing the border colour  is
described later in Alter frame.

The file Borders in the Impression package provides a range of
extra borders. Appendix 6 also shows these borders. Loading
extra borders and controlling the border list is described below.

Available from your supplier is a Borders package which provides
over 100 extra borders in a wide variety of styles.

Importing and deleting borders

Use Frame ⇒ Border import.

ÀÁ

Â

Importing borders

Import borders in Draw format. Drop their file icon onto the load
target À. This loads the border and adds it to the scrolling list Á.

Deleting borders

You can only delete borders 12 to 40.

1 Display the required border in the scrolling list Á.

2 Click on it to select it. (The illustration shows border 12
selected.)

3 Click on Delete Â to delete it.

Creating new borders using !Draw

There are some rules to follow when creating a new border
design using !Draw. These are

� Create the left-hand border. That is, make it tall and thin and
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designed so that it touches the left-edge of the frame. When
Impression uses this border on the other edges of a frame, it
rotates the border as required.

� You can have several objects in your draw-file. If so, there
are differences between how the backmost object and the
other objects are handled:

� The edge of the frame is aligned with the right-hand
edge of the backmost object. The other objects are
positioned relative to this edge.

� The backmost object is stretched so that it exactly fits the
edge of the frame. The other objects do not change
shape but slide to a scaled position along the edge of the
frame.

The backmost object is, by default, the first object created. You
can change the stacking order in !Draw using the Select com-
mand. For more information on !Draw, refer to Acorn�s User
Guide.

Irregular shaped frames

These cannot use standard or imported borders. Instead, the View
dialogue box of Alter frame lets you specify a border thickness
and colour. This border is applied to all frame edges.
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The Alter frame dialogue box

Use Frame ⇒ Alter frame or Ctrl-F10 or the Alter frame tool.

This lets you alter the size and position of the selected frame
which can be of any type (text, graphic, guide or blank). It also
lets you change the frame borders and the colour (if any) of the
frame background. These two groups of functions are controlled
by two separate pages of the dialogue box. Use the Info and View

buttons Ç to flip between the pages.

If the Alter graphics dialogue box is on screen, it is automatically
closed if this option is chosen.

À
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While the Alter frame dialogue box is on screen, documents can
be edited normally. If the selected frame changes during editing
(you might click in another frame or move the cursor into a new
frame), the Alter frame dialogue box is updated to show the
newly selected frame. 

Changes are incorporated in the document only when you click
on OK. If you make changes and then move on to another frame
without clicking on OK, those changes are discarded.
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Adjust-click on OK to make the changes and keep the dialogue
box on screen.

Info page

À Information panel

This describes the type of frame (for example, Local frame:
Graphic).

The final item only applies to text frames and it tells you whether
the text story overflows from this frame. Text can overflow from a
frame if there is more text than will fit in the frame and there is no
other frame for the text to flow into (truncated text). This is a very
important warning because it means that some of the text is not
shown in the document! 

Position area

These options are greyed if the frame is a master frame and the
cursor is not in the master page window.

Á Lock in place

This allows the frame to be locked onto the page so that it cannot
be accidentally moved or resized by the mouse.

Â Dimensions

These describe the position and size of the frame on the page.

 X and Y give the distance of the top left-hand corner of the frame
from the top left-hand corner of the page. 

Width and Height give the width and height of the frame. The X,
Y, Width and Height values are shown in millimetres by default,
but they can be entered in any of the standard units. See the
Appendix 2: Using dialogue boxes for a full list of units recognised
by Impression.
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Frame repel area

These options are greyed if the frame is a guide frame.

Ã Repel text outside

The frame only repels text in frames underneath it if this switch is
on; when off, text in lower frames flows underneath the frame. 

Ä Repel distance

When the Repel switch is on, these describe how far the text will
be pushed from that edge of the frame. The repel distance is in
addition to the width of any frame border that might be drawn
along that edge.

Ä Offset (irregular frames)

Irregular frames have a single repel value that applies to all edges
of the frame. Refer to Irregular frames for more information.

Å Inset

The Vertical and Horizontal settings allow you to repel text or a
graphic inside a frame away from the edges of the frame. If a
frame has a border, usually you want text to start about 3 mm
away from the edge of the frame. You would therefore set both
values to 3mm.

Æ Make local

Local frames can be resized and can be dragged around the page
whereas master page frames cannot. So there are occasions when
you want to adjust a master page frame, but only on one page.

This is used to make a master frame become local to the page on
which it exists. Only the copy of the frame on the current page is
�made local�; the parent frame on the master page itself is
unchanged. The button is disabled if the frame is not a master
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page frame. 

Making a frame local means it is no longer automatically altered
when the parent frame is altered on the master page. A warning
box appears reminding you of this before the frame is made local.
The change is only made when you click on the OK button so
you still have the option of clicking on Cancel to keep the frame
as a master frame.

If this frame contains part of a flowing text story, making the
frame local has no affect on this. The story continues to flow
through this frame as before.

Ç Info / View buttons

Click on View to display the View dialogue box.
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View dialogue box 

You cannot access this dialogue box if the frame is a guide frame.
Irregular shaped frames have a special version of this dialogue
box (described later).

À
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The View display describes how the frame is drawn. The thin
white rectangle À represents the frame and the editable fields
against each of the edges Á hold the border number for each
edge. A half-size version of the border is drawn in the dialogue
box to show you the effect. The border numbers can be changed
by:

� Clicking on the bump icons Â around them.

� Clicking on them and typing. Any changes are only imple-
mented when the cursor is moved out of the editable field
with the cursor keys, Tab, Shift-Tab or Return.

� Moving the mouse pointer over where the half-size border is
displayed À. The mouse pointer changes to a page shape
when in the correct place. Click Menu to display the border
list (described earlier). Click on the required border in the list
to select it.
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Creating additional borders is described in Borders (in this
section).

Notice that the illustration of the dialogue box shows how to use
the drop shadow borders 6 and 7.

All Ã lets you alter all the borders simultaneously. While this
switch is on, changing any one of the four border numbers
changes the other three to the same value.

Colour Ä displays the current frame border colour. Click on it to
display the colour picker; this is described in 2.12 Colour
handling.

Transparent and Colour Å determine whether the frame has a
filled background or not: 

� If Transparent is set, the frame has a transparent background.
Anything underneath the frame will show through wherever
text or graphics don�t fill the frame.

� If Colour is set, the frame background is set by the colour
field and anything underneath the frame is hidden. Click in
the colour field Æ to display the colour picker; this is
described in 2.12 Colour handling.

View dialogue box (irregular frames)

You can apply a single line around all the edges of an irregular
frame. Specify width and colour in the Border section.

Background is identical to Å and Æ in the normal View dialogue
box.
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2.9 Graphics handling

This section covers:

• what are graphics

• loading graphics

• manipulating graphics

• saving graphics

• the Quality menu option

• Object Linking & Embedding (OLE)

• the Alter graphics dialogue box 
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What are graphics?

Graphics are generally illustrations but could be, for example, an
equation generated in Equasor (a separate application supplied
with Impression). In Impression graphics can be:

� Draw files. Many packages on Acorn computers can export
data in Draw format.

� Sprites or bit-images. These are produced by painting
packages such as !Paint and also scanners. Impression
supports new format 16-bit and 24-bit sprite. It can display
these and print them on suitable colour printers. Your
supplier can provide suitable drivers for many colour
printers.

� ArtWorks files produced by MW-Software�s ArtWorks
application.

� Any graphics file that follows the OLE conventions. For
example, Equasor and TableMate. (There is more informa-
tion on OLE later in this section.)

� Any graphics file for which Impression has a loader or
converter such as TIFF images. (TIFF files are widely used on
other types of computer.) A graphics loader package is
provided as part of Impression-X. This includes enhanced
TIFF and JPEG loaders and loaders for Clear and PhotoCD
files.

Generally Impression treats all these types of graphics in the same
way. The following descriptions use Graphics to mean any of
these file types and only uses the individual names where the
particular file type is treated differently.
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Loading graphics

You can load graphics into Impression in three ways:

� Create a blank frame and drop a graphics file icon onto it. 

This loads the graphics and scales it to exactly fit the frame.

� Drop a graphics file icon on an existing graphics frame.

This overwrites the existing graphic. The new graphics is
scaled to exactly fit the frame (unless Lock values �
described later � is set).

� Position the cursor where you want to embed the graphic.
(Refer to Embedded frames in 2.8 Frame handling.) Drop
the graphics file icon onto the frame containing the cursor.
This creates a new embedded frame which contains the
graphic. The graphic is shown full size (100%). If the graphic
is wider than the embedded frame, it is scaled to fit (that is, it
is displayed at less than 100%).

Except for an embedded graphic, a text frame can never hold a
graphic. If you want to replace a text frame with a graphic, you
must first delete the text frame and then create a new graphics
frame of the same size. (The converse is also true � you can never
use a graphics frame as a text frame.)
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The graphics tool

Click inside a graphics frame to display the graphics tool:

Rotate

Pan

Scale

Pan is described in Moving graphics.
Rotate in Rotating graphics.
Scale in Resizing graphics.

Moving the mouse pointer over a handle changes the pointer
shape. Hold down either Select or Adjust. The tool disappears
and you can then perform the required action.

Using Select...

...pans, rotates, or scales the graphic, as appropriate.

Using Adjust...

...pans the graphic or

...rotates both the graphic and the frame or 

...scales both  the graphic and the frame.

Resizing graphics

You can resize (enlarge or reduce) a graphic by:

� resizing the frame using Adjust, or

� using the Scale editable field in the Alter graphics dialogue
box (described later), or

� dragging the Scale handle. This interactively scales the
graphic. If the frame is too small to do this accurately, use the
Zoom feature to enlarge your view of the frame, or

179 

2.9 Graphics Handling



� double-clicking on the Scale handle (this scales the graphic
to 100% and sets the aspect ratio to 100% � the aspect ratio is
described later).

Resizing the frame scales the graphic from the edge of the frame.
The other methods scale the graphic around the centre of the
frame.

If Lock aspect (in the Alter graphic dialogue box) is off, resizing
the frame or dragging the Scale handle may change the X:Y
aspect ratio. Using the Scale editable field or holding down Ctrl
while dragging the Scale handle maintains the aspect ratio.

Moving graphics

You can move the graphic within the frame without moving the
frame itself by:

� Dragging the Pan handle.

� Double-clicking on the Pan handle. This moves the graphic
to the centre of the frame.

� Using the Alter graphic dialogue box. This allows you to
change the X-Y coordinates of the graphic and is useful for
large movements of the graphic.

If you have the Alter graphic dialogue box on screen while
sliding the graphic with Select, you see the X-Y co-ordinates
update as the graphic moves. 

Rotating graphics

To rotate a graphic either

� drag the Rotate handle (hold down Ctrl to constrain the
rotation to multiples of 45°), or

� double-click on the Rotate handle (this cancels any previ-
ously applied rotation to the graphic � it has no effect on any
applied rotation of the frame), or

� type in an angle (in degrees) into the Angle editable box in
the Alter graphics dialogue box.
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All methods rotate the graphic around the centre of the frame.
You can always rotate Draw files. If you have RISC OS 2, you can
only rotate Sprites if Dither graphics is set in Preferences on the
Icon Bar Menu. (See 2.16 Customising Impression for details.)
This option is not needed for graphics rotation in RISC OS 3.

Linking graphics

Graphics can occupy a lot of memory. Where you require the
same graphic in more than one place, it saves memory if they are
linked. In this way, the graphic is stored only once but can be
used in several frames. As the complete graphic is always stored,
each view can show a different part of the same graphic.

To link graphics, first create a frame and drop in the graphic.

Then, next time the graphic is required, create a blank frame.

Click Select on the original graphic and click Adjust on the blank
frame. (This is the same sequence as linking text frames.) The
complete graphic now appears in the second frame; the view in
the first frame is unchanged. 

You can now re-size or crop the second view as normal.

The graphic is always stored separately from the frame informa-
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tion. This allows you to delete the original frame without affecting
the second view of the graphic. Only when all frames that use the
graphic are deleted is the actual graphic removed from memory.

Hiding graphics

Complicated graphics can be slow to redraw on the screen. To
speed up screen updating you can hide graphics. Hidden
graphics appear as vertical and horizontal crossed lines. (Graphics
also not displayed when they have been saved to disc by a
Minimise memory operation. In this case, the frame contains two
diagonally crossed lines.)

   
Left: a ‘hidden graphic’ frame                                 

        Right: frame contents saved to disc to minimise memory.

You can either 

� hide an individual graphic by using the Alter graphic
dialogue box, or

� hide all graphics in the document by using View ⇒ Hide all

graphics.

To restore a hidden graphic either 

� cancel Hide graphic in the Alter graphic dialogue box or

� choose View ⇒ Show all graphics.

To restore a graphic that has been saved to disc click in the frame.

Note that hidden graphics are not printed; graphics saved to disc
by minimise memory are printed.
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Quality menu option

Complicated illustrations can take several seconds to redraw on
screen. The View ⇒ Quality menu option lets you control the
amount of detail shown and hence control the speed of redraw-
ing. 

(You can also display this menu from the Toolbar.)

Quality controls illustrations prepared in ArtWorks or imported as
Draw files. Changing the Quality setting only changes the
appearance of the document on-screen; it has no effect when
printing.

Quality 11 Anti-aliased � this displays illustrations in complete
detail and anti-aliased. (This improves their appearance on-
screen.) Redrawing is slightly slower.

Quality 10 Normal � again the illustration is shown in full detail
but is not anti-aliased. (Adjust-clicking on the Quality tool
directly selects Quality 10.)

Quality 5 Simple � line thickness is ignored; all lines are drawn
the same width. Line dash patterns and end caps are ignored.
ArtWorks graduated fills are shown as flat fills.

Quality 0 Outline � illustrations are shown purely as outlines
(wire-frames) with minimal detail. However, this gives the
fastest redraws.

Exporting graphics

Use File ⇒ Save graphic or Save file in the graphic information
dialogue box (described later).

Sprites are exported as Draw files (as Draw files can contain
Sprites). Files imported using loaders (such as TIFF files) are

183 

2.9 Graphics Handling



exported as Sprites or Draw files. Other types of graphic are
exported as the same file type used to import them.

Object Linking & Embedding (OLE)

This provides a simple way to modify a graphic in Impression.
Simply hold down Ctrl and double-click in the graphic frame.
Impression exports it to a suitable external application (for
example, !Draw for draw files). Impression even loads the
application if it is not already on the icon bar.

After you have made any changes, close the window in the
external application. This usually displays a Save box � click on
OK and the graphic is returned to Impression. (Most applications
follow the convention of having an F3 short-cut, so you can
transfer the graphic back to Impression by pressing F3-Return.)
The graphic is displayed at the previous scale and position.

Points to note

� OLE can only load an application if it knows where it is.
Usually this means that the application�s icon has been
displayed in a directory window (even if you later closed the
directory window).

� To return the graphic to Impression just click on OK. Altering
the filename shown in the Save box in any way breaks the
link to Impression. 

� Graphics are transferred using a disc file. OLE may fail if
there is insufficient space on your disc.

If you are using floppy discs, you may be prompted to swop
discs.

� If you are using Acorn’s 3D ‘NewLook’

If you find that some applications crash when transferring
files back to Impression using OLE, run BorderUtils (supplied
on the new-look disc).

Loading an OLE object

Several applications handle the OLE protocol so that they can
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save and load information in their proprietary format, using a
registered file type. If the same file is imported into Impression, it
will be treated as a graphic file in a very similar way to a Draw
file. Such applications include TableMate, FamTree, Equasor and
ArtWorks. 

Many types of graphic load back into the application that created
them. For example, Equasor format files load back into Equasor.
Other types load back into !Draw. (This is controlled by the
application that created the file and not by Impression.)

For more information on OLE refer to the on-line help as this
contains many technical details.

The diagram above shows an OLE graphic (actually a TblMate
file) being loaded. It is treated as a graphic object as it is, in fact, a
Draw file with special tags which identify it but with a file type
that identifies it to the parent application.
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The Alter graphics dialogue box

Call up this dialogue box by:

� double-clicking inside a graphics frame, or, 

if the selected frame is a graphic frame,

� Ctrl-F11, or

� Frame ⇒ Alter graphic, or

� Adjust-clicking on the Alter frame/graphics tool.

Displaying this dialogue box closes the Alter frame dialogue box
if this is open. You can edit while the Alter graphics dialogue is
on screen. Selecting a non-graphic frame automatically closes the
Alter graphics dialogue box.

À
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À X & Y

These show the distance of the bottom-left corner of the graphic
from the bottom-left corner of the frame. These can show
negative values when you are showing only a part of the graphic.

Clicking on the bump icons moves the graphic in steps of 1/8 th of
an inch (approximately 3mm). Clicking the icons moves the
graphic immediately.
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Á Angle

This allows you to rotate the graphic by any angle between 0°

and 360°. (You can also rotate the graphic using the Rotate handle
on the graphics tool.)

Â Scale

This shows how the graphic has been scaled relative to its
original size. 200% means the graphic is twice its original size.

Ã Aspect X:Y

This shows the �fatness� or �thinness� of the graphic. It measures
how the graphic is scaled in the horizontal direction relative to
the vertical direction (as set by the Scale field). When Aspect X:Y

is set to 100% the graphic is equally scaled in both directions. That
is, a square in the original graphic remains as a square in the
scaled graphic. Numbers smaller than 100 in the Aspect X:Y field
make the graphic thinner than the original, larger numbers make
it fatter.

The appearance of the graphic on the screen may be distorted by
the aspect ratio of the pixels displayed by the monitor.

Notes on Scale and Aspect X:Y

Altering either value rescales the graphic around the centre of the
frame.

To show a graphic at its original shape and size, set both the
Scale and Aspect X:Y fields to 100%. 

Acorn sprites do not store any information about the original size
of the bitmap and so Impression treats sprites as always being
stored at screen resolution no matter where they originally came
from.
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Ä Lock aspect

When it is on, the graphic keeps the aspect ratio set in the Aspect

X:Y field no matter what the shape of the frame. This is a useful
protection against accidentally changing the aspect ratio when
changing the size of the frame with Adjust. It also stops the
aspect ratio changing when you drag the Scale handle.

Å Lock values

Lock values is similar to Lock aspect. With it set, you cannot use
the mouse to slide the graphic around in the frame. It also locks
the Scale. Even if you drop another graphic into the frame, the
scaling is unchanged.

Æ Hide graphic

This controls whether or not the graphic is shown in the docu-
ment. Some graphics take a long time to re-draw, which can slow
down the response time of the program, so it is useful to be able
to hide the picture once you have made sure that it looks right.
There is also an option in the View menu to hide all graphics.

Note that hidden graphics do not print.

Ç Fit to frame

Fit to frame is a quick way to resize the graphic to fill the frame. If
Lock aspect is off, the graphic is rescaled both horizontally and
vertically to fill the frame. If the switch is on, the graphic is resized
to fit the frame without changing the aspect ratio. 

È Typesetting/Colour map

These display extra dialogue boxes, described below.

È Information

This displays an extra dialogue box, described below.
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Typesetting dialogue box 

This is used when outputting to a PostScript device such as a
typesetter. It overrides the settings in the Print dialogue box for
Angle, Density, and Spot pattern for this individual graphic. (See
the description of the Print dialogue box in 3.4 Printing for more
details of these functions.)

Frame co-ordinates displays information about the graphic. 
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Colour map dialogue box

This lets you alter the brightness, contrast and colour balance of
graphics. Impression remembers the original contrast and
brightness and you can return to the original values at any time by
clicking on Default Â.

It also lets you change the foreground and background colours of
monochrome illustrations. For example, you can change a black-
and-white illustration to a red-and-yellow illustration. You can
also convert a coloured illustration to a monochrome illustration.

ÀÂÃÄ
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À Colour map

This illustrates the effect of changes to the sliders Á.

 

Original

black
black

white

white

illustration

Midtone

Upper

Lower

The graph represents a map of the brightness levels. The default
straight line means that dark colours map to dark (lower left
corner) and light colours map to light (upper right corner) and all
intermediate shades are mapped linearly.

� Altering Upper alters light colours.

� altering Lower alters dark colours

� altering Midtone alters the brightness of midtones (and has an
effect similar to altering the gamma brightness values).

Á Sliders

These let you adjust the colour balance. The three sliders operate
in the same way.

� 0% means no modification. For example, setting
Midtone to 0% means a mid-tone shade in the original
appears as the same shade on screen and when printed. 

� To increase the contrast select Master and
increase Upper (make it positive) and decrease Lower. 

� Conversely, to reduce the contrast select Master

and decrease Upper and increase Lower.
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� To increase the brightness select Master and increase Midtone. 
With the colour model options, this action increases the

proportion of the selected colour. With the RGB model, this also
increases the brightness. With this CYMK model this decreases
the brightness.

� To decrease the brightness select Master and decrease
Midtone.

With the colour model options, this action decreases the
proportion of the selected colour.

Â Default

This cancels any colour correction applied to the graphic. If you
have been experimenting with changing the colour map, Default

provides a quick way to return to the original values.

Ã Linear

This sets Midtone to 0% and gives a linear colour map. It does not
change Lower or Upper .

Ä Full range

This sets Lower and Upper to 0%. Midtone is unchanged.

Å 10% clip

For some applications (such as scanned photographs that will be
typeset) it is undesirable for illustrations to contain pure white or
pure black. 10% clip reduces the contrast range to 10% to 90%
black.

Æ Model to edit

Master lets you adjust the overall graphic brightness in one
operation. Its main use is to make the graphic lighter or darker or
increase or decrease the contrast.

The other options select a colour model and let you adjust the
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individual colour components by selecting from the Colour to edit

field Ç. Some buttons may be greyed if the colour model is not
applicable for this graphic:

� RGB is the usual model for normal sprites, draw files, and so
on,

� CMYK is only available for CMYK sprites or

for ArtWorks graphics,

� HSV is only available for ArtWorks graphics.

Each option only affects objects that use that colour model. For
example, if you select HSV, moving the sliders modifies only
objects defined using the HSV colour model.

Note:

By altering the various intensities of the individual colours, you
can perform a wide range of colour correction. For example,
when using an RGB sprite, altering the midtone of only the Blue
colour tends to make the picture more blue or more yellow (the
opposite of blue).

0% colour
Original
colour

Midtone

Upper

Lower

c
o

lo
u

r

0% colour

100% 
colour

100% 
colour

A

If the graphic uses only a few colours, dragging the sliders may
appear to have no effect. For example, in the illustration above
small changes to Lower have little effect on the 80% colour A.

Note that in the RGB colour model, black is defined as 0% each of
red, green and blue. Similarly, white is 100% of each colour. Thus,
changing any of the colours can also change white, black or grey
shades. 

In the CMYK colour model, each colour element (cyan, magenta,
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yellow or black) is independent so changing, for example, cyan
does not affect black, white or greys. It just changes the propor-
tion of cyan in the graphic.

È Colour 

This has two functions:

� Converting a multi-coloured graphic to monochrome (single-
coloured). You cannot convert a sprite containing more than 256
colours (�deep colour� sprites).

� Changing the upper and lower colours of a monochrome
graphic. Click on the colour fields to display the colour picker.
(This is described in 2.12 Colour handling.)

Changing the colours provides a simple way to incorporate
spot colours on graphics into a document that will be profession-
ally printed. If one colour is white, you can change the other
colour to be cyan, magenta, or yellow and then produce a
separation for that process colour. The professional printing
company can then print that separation in any colour ink.
(There�s more on producing separations in the Commercial
Printing Guide.)

Impression preserves the original values for the graphic. This lets
you cancel any changes made to the colour by deselecting this
button.

On disc 7 are some tints generated in ArtWorks. You can drop
them into a frame and change the colours to create background
tints to your document.

 194 Impression Manual

Impression Publisher



Information dialogue box

This gives you information about the size and type of graphic
shown in the selected frame.

À
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À Graphic type

 This tells you the graphic type (such as Sprite or ArtWorks).

Á Graphic size

The amount of memory required to hold the graphic. This is
particularly important for scanned images as high-resolution scans
can consume large amounts of memory.

Â Dimensions

The original dimensions of the graphic. These are the same as the
current size when the graphic is displayed at full size.

Ã Resolution

This is blank unless the graphic is a sprite.

It shows the current resolution. Resolution is important when
printing as using too low a resolution (below 60 dpi for a laser
printer) gives poor quality results. If the sprite resolution is higher
than needed for good quality reproduction, more memory than
necessary is required.

Increasing the scaling of the sprite decreases the current resolu-
tion. For example, scaling a 90 dpi sprite to 200% of its original
size reduces the effective resolution to 45 dpi. Conversely,
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decreasing the scale increases the resolution � a 90 dpi sprite
becomes effectively 180 dpi when displayed at 50%. (This
assumes you print the document at 100% � different print scaling
also affect the effective resolution.)

Note:

It is unusual to require an effective resolution greater than
150 dpi, even for the highest quality typesetting.

Ä Colours

This is blank unless the graphic is a sprite. It shows the number of
colours in the sprite. 

Å Save file

This duplicates File ⇒ Save graphic. It displays a Save box Æ.

The
example above shows the information dialogue box for an OLE
object, a TblMate file. As it is an OLE object, CTRL-double clicking
on its image in the graphics frame will open it for editing in its
parent application TableMate (if it has been seen by the filer) and
allow it to be saved directly back into Impression. The save
graphic window above allows it to be saved as a draw file.
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2.10 Master pages

This section covers:

• what are master pages?

• using master pages

• editing master pages

• creating new master pages

• New master page dialogue box

• Alter master page dialogue box

Related sections of this manual:

• Alter chapter dialogue box in 2.11 Chapters
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What are master pages?

The fundamental layout of your document is dictated by a master
page or pages. A master page acts like a template which has a pre-
selected arrangement of frames, empty or containing text or
graphics, that is reproduced on all the actual document pages (the
normal pages).

Normal pages, when created, are copies of the current master

page. The difference is that normal pages can be printed, whereas
master pages exists only inside Impression.

All documents must, by default, have one master page, though
different chapters can use different master pages. All pages in a
chapter are based on the same master page (or pair of master
pages).

Logos, messages, or graphics placed on a master page appear on
every normal page that uses that master page. For example, if you
needed a multi-column page layout, then you would choose a
master page layout with text frames arranged as columns, linked
so that the text story flow from the bottom of one column frame
to the top of the next. (See below for a list of the pre-defined
master pages. Linking text stories is described in 2.8 Frame
handling.)

Of course, new frames containing text or graphics can be
introduced into any local pages throughout a document, and
these may be altered at any time. 

Master pages serve five main purposes:

� They allow a variety of different page sizes to be used in a
document.

� They determine whether the pages appear as left/right pairs
on screen or as single pages.

� They provide a high degree of control over the overall look
of a document and allow simple changes to a master page to
affect the appearance of entire chapters.

� Any changes you make to a master page are reflected in all
pages that use that master page. This retroactive editing is an
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important feature of Impression and gives it much of its
flexibility.

� They simplify layout work because repetitive items need
only be defined once.

The default master pages

A4 (210x297 mm) pages

   A4 portrait one column, portrait

   A4 port DPS one column, portrait, left/right pair

   A4 por 2col two column, portrait

   A4 2col DPS two column, portrait, left/right pair

   A4 landscap landscape

A5 (148x210 mm) pages

   A5 portrait single column, portrait

The default document uses master page A4 portrait.

Using master pages

Changing to a different master page

You can change to another master page at any time. Use the Alter
chapter dialogue box to change the master page. Remember that
this changes all pages in the current chapter to be based on the
new master page.

You can also select a different master page when you create a
new chapter. For a different master page, change the Master page

field in the New chapter dialogue box.

(See 2.11 Chapters for details of the Alter chapter and New chapter

dialogue boxes.)

Example:

If you want to create a document using A5, portrait pages:

1 Open a new document. This displays the usual A4 portrait
page (A4 portrait).
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2 Open the Alter chapter dialogue box (Edit ⇒ Alter chapter).

3 Click on the menu icon.
Click here

This displays a list of available master changes.

4 From the menu choose A5 portrait and click on OK.

The document now uses A5 portrait pages.

Changing master page frames

On a normal page you can:

� delete a master page frame,

� make a local copy of the master page frame. (Use Make local

in the Alter frame dialogue box.)

You cannot:

� move a master page frame, nor

� change its size. You can only move and resize master page
frames on the master page itself.

Editing master pages

Before you can edit a master page you must open the master
page window. Use 

� View ⇒ Master pages or 

� Ctrl-Shift-F2. 
The window initially shows the current master page.

Master pages look like normal pages on screen. You can scroll
around them and put frames on them containing text or graphics.

On normal pages you can:

� enter text into master page blank frames.
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You cannot:

� enter text into master page text frames,

� edit text in master page text frames,

� change the graphic in master page graphic frames.

Any alterations made to the master pages are reflected throughout
the document in all pages based on that master page. Herein lies
the power of master pages. If a frame is re-positioned, or some
text edited on the master page, then closing the master page
window updates all pages based on that master page to reflect the
change. 

For more details of creating and editing master pages refer to New
master page and Alter master page (described below).

Deleting master pages

You can delete unwanted master pages by displaying the master
page window then using Edit ⇒ Delete master page. You can
only delete unused master pages, never those used in the
document.

Deleting unused master pages does not make the document
significantly smaller. The main use is when you have created a
new master page based on an existing master page and want to
delete the old page.
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Master page summary

� The master pages can be seen only in the master
page window, selected by View ⇒ Master pages.

� All pages in a chapter have to be based on a particular
master page, or a particular left/right pair of master pages.

� Master pages, like normal pages, may have blank, text or
graphic frames placed at any position.

� Alterations to master pages are reflected throughout a
document.

� Blank frames, linked together on the master page, indicate
the positions of flowing text in the main document.

� Create new master pages with the New master page or Alter
master page dialogue box.

� The name or number of the master page is displayed in grey
at the top-left corner of the master page in a master page
window. The Alter chapter dialogue box shows which
master page the current chapter is based on.

� Alterations to the master page do not affect the main docu-
ment until either the master page window is closed, or you
click in a normal page window.

� Use Edit ⇒ Alter chapter to change to a different master
page.
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New master page dialogue box 

To display this dialogue box use Edit ⇒ New master page or Ctrl-
F7. These are only available when viewing the master pages.

À
Á

Â

Ã
Ä
Å

Æ
Ç È
É

À Master page name

You can name master pages. This often makes it easier to identify
them (for example, Letters for a master page with the correct
layout for your letters). Names can be up to 11 characters long.
Spaces and punctuation are allowed.

Á Page size

These buttons select standard page sizes.

Â Custom page

If you want a non-standard page size, click on Custom and type
in your own page size.
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Ã Format

Portrait or upright page orientation

Landscape or sideways page
orientation

Ä Facing pages

Facing pages

Selecting Facing pages allows the creation of pairs of master
pages. These are shown as two pages side by side. 

When Facing pages is selected, you may type in a measurement
for the Guttering This is the additional space that is added to the
inner margins to allow for binding the pages. This measurement
is ignored when creating only single master pages.

Guttering

Frame Frame

The right-hand page is a mirror image of the left-hand page. 

Å Margins

These define the distance from the edge of the page to frames. 
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Note the difference between Margins and Gaps:

� margins control the distance from the edge of the page,

� gaps control the distance between frames.

Margin

Gap

Frame Frame

Æ Columns

You can generate simple one frame master pages or pages with
multiple columns.

Type the number of columns into Number. The column width
field is updated as you type.

Gaps controls the space between frames. Again, this changes the
Width measurement. Gap does not define the distance from the
edge of the page to the nearest frame: this is controlled by
Margins.

Ç Guide frames

This creates guide frames rather than blank frames. If a master
page requires both guide and normal frames, it is usually best to
create the guide frames first. You can then add the blank frames
to the page later and, if Snap to guides is on, you can easily align
them with the guide frames.

The advantage of placing guide frames (either now or later by
creating new guide frames) on the master page is that, if you later
move them, all frames in the document that are already snapped
to them move to reflect the change.

È Vertical rules

When this is on, the new page will have black lines between each
column. These lines are 0.141 mm (0.006 in.) wide.

Note that this option has no connection with vertical rules set on
the rulers. This option creates an inter-column line on a master
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page; vertical rules on the ruler draw lines in selected paragraphs.

É Page control

This opens the Page control dialogue box:

Bleed around page

A Bleed is a margin (usually about 3mm) outside the normal page
size. It is needed for documents that have text or graphics running
off the page. The bleed area is cut off after printing. For more
information, refer to the Commercial Printing Guide.

Grid offset & spacing

These options let you create a grid across the page. Offset sets the
start of the grid relative to the top left of the page. Spacing is the
distance between points on the grid.

Frames

If Snap to grid is selected, moving or resizing the frame snaps it to
points on the grid.

Text

Text snaps to the Y grid if the text is in a style with Lock to page

grid set. (Lock to page grid is described in Paragraph dialogue
box in 2.6 Styles.) The X grid has no effect.
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Alter master page dialogue box 

To display this dialogue box use Edit ⇒ Alter master page or Ctrl-
Shift-A. These are only available when viewing the master pages.

This dialogue box is similar to New master page already
described. Use it to create a new master page based on an
existing master page. Use the Alter chapter or New chapter
dialogue box to change to using the new master page. (We
suggest you give the new master page a different name to identify
it from the existing master page.)
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2.11 Chapters

This section covers:

• what are chapters?

• word counts

• the New chapter dialogue box

• the Alter chapter dialogue box

Related sections of this manual:

• 2.10 Master pages

• Automatic page creation and Flowing text 

stories in 2.3 Text handling
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What are chapters?

Chapters in Impression are similar to chapters in a book. That is,
they break the document into smaller sections. The advantages of
chapters are:

� They speed up reformatting of text after changes. This makes
working on large documents easier.

� They let Impression handle documents far larger than the
available memory in your computer. Chapters that are not
being worked on can be saved to disc. (There is more on
memory management in 2.1 The basics.)

� Different chapters can use different master pages. This lets
you use different page sizes and layouts within a document.
For example, index and contents pages often have a different
layout to the main part of the document.

Impression documents are structured like this:
Document

Chapter 1    Chapter 2    Chapter 3 ...

Stories Stories Stories

A simple document (like a letter) contains one story in a single
chapter. A complex document contains several chapters each of
which can have several stories.

Chapter numbering

Internally Impression numbers chapter numbers sequentially
from 1. In the New chapter and Alter chapter dialogue boxes
(described later), you can allocate a different number to a
chapter. You would do this if you wanted to insert into the text a
chapter number different to the internal chapter number. Use
Utilities ⇒ Insert ⇒ Current chapter number to insert the chapter
number into the text.

211 

2.11 Chapters



Deleting chapters

Use Edit ⇒ Delete chapter to delete the current chapter. (The
current chapter contains the selected frame.)

We recommend that you save the document before deleting a
chapter. If you change your mind or delete the wrong chapter,
you can then retrieve the document from disc.

If the document contains only one chapter, you cannot delete that
chapter. 

Word counts

The Main Menu Info box (described on page 23) shows the
number of words in the current story.

A further Info box, Utilities ⇒ Count words or Ctrl-Shift-F4,
displays additional word counts.

The relationship between document, chapters and stories in a
document is described on page 211. Truncated text is described
on page 40.

Words in story automatically updates when a different frame is
selected by either clicking or cursor movement. Words in selec-

tion automatically updates when the selected region changes. You
can also update the counts by clicking Recount. 
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The New chapter dialogue box

To display this dialogue box use Edit ⇒ New chapter or Ctrl-F7.
Use this dialogue box to start a new chapter.

À

Á

Â

Ã

Ä

Å

À  Position

You can insert the new chapter either before or after the current
chapter. (The current chapter contains the selected frame.)

Á Master page

New chapters may be based on any master page. This lets you
alter the page size or layout part way through a document by
starting a new chapter. For example, an index usually has a
different layout from the rest of a document.

To change the master page, click on icon Â; this displays a menu
of master pages. Choose the new master page from this menu.
Master page names and numbers are displayed in the top-left
corner of the master page when viewed in the master page
window. (See 2.10 Master pages for information on the master
page window.)
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Ã Starting on

Left pages

Right pages

These two options control how left/right pairs are displayed on
the screen. 

For many documents (such as this manual), new chapters always
start on the right-hand page. For such documents, select Right

pages. Other documents start on left-hand pages; for these, select
Left pages.

Ä Numbering

Restart page at

Selecting Restart page at and typing in a new page number
restarts the page numbering for this chapter at that number.

If you want to continue the page numbering from the previous
chapter, set this switch off.

You can restart page numbering on any chapter boundary. This is
particularly useful for sections that are numbered separately. For
example, the introduction pages may be numbered in Roman i, ii,
iii etc. the main text pages then starting from page 1.

If you split a document into several files (not really necessary with
Impression) then this mechanism can be used to start numbering
each section at the required page number.

Page numbers may be displayed in Roman (upper or lower case)
or conventional Arabic numerals. Use Utilities ⇒ Insert ⇒ Current

page number to insert the page number into the text.

Restart chapter at

This is similar to Restart page at and lets you renumber chapters.
Use Utilities ⇒ Insert ⇒ Current chapter number to insert the
chapter number into the text.
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Å Page creation

This option controls when a new page is automatically created.
See 2.3 Text handling for more information on flowing text
stories and automatic page creation.

Copy master page

A new page is created when text fills a master page frame and
there is no other master page frame for it to flow into.

The new page is a copy of the master page and contains only
repeating frames from the previous page and master page frames.
This is the normal option.

Copy previous page

A new page is created when text fills any frame, local or master
page, and there is no other frame for it to flow into.

The new page is a copy of the previous page except that any local
frames are empty. A graphic frame is only copied if it is a grouped
frame (that is, it is one of several frames which have been
grouped together). This is how pages are created in a previous
software package, Impression Junior, and this option lets you
work in a manner consistent with Impression Junior.
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The Alter chapter dialogue box

To display this dialogue box use Edit ⇒ Alter chapter or Ctrl-Shift-
A. This lets you change the page layout or page numbering of the
current chapter.

À

Á

Â

Ã

Ä

À Page creation

This shows the current page creation rule � described further in
New chapter.

Á Master page

Changing this changes the master page used for the chapter. For
example, you might want to change the number of columns on
the page, or to change from single pages to left/right pages.

Click on icon Ä to display a menu of master pages.
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Â Numbering

Restart page at

Selecting Restart page at and typing in a new page number
restarts the page numbering at that number.

If you want to continue the page numbering from the previous
chapter, set this switch off.

Restart chapter at

This is similar to Restart page at.

Ã Starting on (left pages - right pages)

This option is described in New chapter.
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2.12 Colour handling

This section covers:

• the RGB, CMYK and HSV colour models

• using the colour picker

219 



 220 Impression Manual

Impression Publisher



The colour picker

The Colour Picker appears whenever you click on a colour field
in a dialogue box.

RGB colour model

This is the model used by the computer screen. 

On older computers using 4- and 16-colour modes, the window
below includes a �Set Palette� option. 
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CMYK colour model

This is the colour model used by colour printers and printing
presses. (CMYK are the colours of the four inks � Cyan, Magenta,
Yellow and Black or Key � used to print full colour documents.)
Printers use Black to reinforce dark colours that cannot be printed
properly using only the Cyan, Magenta and Yellow inks. Colours
specified using CMYK may appear different on screen and when
printed. This is because inks are not pure colours. For example,
100% Cyan+Magenta appears on screen as dark blue but is purple
when printed.

When output to a CMYK device, colours defined in CMYK are
output without modification. Colours defined in RGB or CMYK
are converted to CMYK for output and may therefore show slight
colour changes.

Some older colour printers use only Cyan, Magenta and Yellow
inks (CMY colour model). The CMYK colour model is suitable for
these. Set black to 0 when specifying colours.
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HSV colour model

HSV describes colours in terms which are recognised by artists.
Hue represents the pure pigment. Saturation is the amount of
white added � the smaller the Saturation the greater the amount
of white added. Value is the brightness of the colour or, put
another way, the amount of added black. So Saturation and Value
between them produce all the shades and tones of the basic Hue.

To get pure colours from the HSV model both Saturation and
Value must be set to 100%. Hue gives the colour.

To get greys Saturation must be set to 0 and Value then gives the
amount of white. Hue doesn�t matter.

Altering colours in the Colour Picker

The RGB dialogue box shows the 16 colours on the default
palette (eight greys, two blues, two greens, red, orange, yellow,
and cream). To select a colour from this palette, click on the
appropriate colour panel.
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Registration black

     

This is a special colour defined as 100% each Black, Cyan,
Magenta and Yellow. It is used for printing registration marks and
alignment targets when producing typeset separations.

Do not use this for ordinary text � the printed results may be
disappointingly blurred. Instead use it when you want include
notes on each separation (such as document name or date).

Overprint

 
This is used for typeset separations.

Normally if you print (for example) black text on a cyan back-
ground, the outline of the text appears as a silhouette on the cyan
separation. (The technical term is that the text knocks-out the
background.) In theory, during printing the text exactly fits the
silhouette in the background. In practice, there may be a slight
misalignment and white unprinted lines appear at the text/
background boundary. These areas are usually very small but can
be noticeable when printing dark colours. (The technical term is
that the printing is out of register.)

Overprint gets round this problem by not knocking-out the
background colour. Usually you only overprint black, which is
sufficiently opaque to mask any underlying colour. Other colours
can show colour shifts. For example Blue and Yellow overprinted
gives Green.
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2.13 Spell checking & the

Dictionaries

This section covers:

• what a spell checker can and cannot do

• spell checking your document

• the main spelling word list

• user dictionaries

• abbreviation expansion

• hyphenation and the exceptions dictionary

Related sections of this manual:

• the Hyphenation effect in 2.6 Styles

� 2.16 Customising Impression
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What a spell checker can and cannot do...

What it can do...

It can easily spot two of the most common mistakes, misspellings
and mistyping.

The rules of English spelling are very complicated and there are
many anomalies both in word roots and in the behaviour of
endings. Very few people spell every word correctly every time.
Impression lets you check spelling as you type and also check the
entire document when it is complete. (These are described later.)
It can suggest corrections for mistyped or transposed character
sequences.

Even if you know how to spell words, it is easy to make mistakes
when typing in the text. The main types of error are:

� transposing two letters (exmaple instead of example), 

� omitting the space between two words (aspace instead of
a space).

What it cannot do...

It cannot detect that you have used a valid word in the wrong
context, for example:

�The whether is sunny today� (should be weather).

Nor can it detect typing mistakes if the result is a valid word:

�What time is diner?� (when you meant dinner).

A spelling checker helps you but you should always read through
your documents carefully as a final check. You will find errors
easier to spot from a printed copy rather than reading from the
screen.

The WordWorks thesaurus and dictionary can tell you the
meanings of words. To load WordWorks you can either double
click on its file icon or choose Utilities ⇒ Thesaurus.
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The main word list

The main word list contains almost 60,000 words, with each
different word ending treated as a separate word. It is an English
(UK) list and covers the basic vocabulary of an average person.
Some terms peculiar to the Acorn and computing are included
(such as Archimedes, podule, and byte) as are most country names
and UK county and city names. 

Loading the main word list

You can:

� Set Spelling checker in the Icon Bar Menu Preferences.

If you then click on Save in Preferences, Impression always
starts-up with the main word list loaded. (See 2.16 Customis-
ing Impression for more details.)

� Choose Utilities ⇒ Spelling ⇒ Dictionary. You are asked if
you wish to load the Main word list.

� Using any spelling function (such as Check word or Check

text) asks you if you want to load the Spelling checker if it is
not already loaded.

This is probably the best way if you are short of memory as it
means memory is only used when you actually require the
word list.

Loading the main word list also loads the spelling checker and
requires approximately 112 KB of RAM. 

The error message No room in RMA means that the load failed
because of insufficient memory. Remove any application pro-
grams (apart from Impression) currently loaded and try again. If
necessary, reset the computer to free more memory.

 228 Impression Manual

Impression Publisher



User dictionaries

The main word list cannot include personal words such as names
of people, roads and towns. For these, Impression provides User
dictionaries. You can have up to eight User dictionaries in
memory simultaneously.

Each User dictionary, when loaded, occupies 8 KB of memory.
This is sufficient for approximately 1,500 words. Usually just one
dictionary is sufficient with, perhaps, others containing specialist
vocabularies for use on specific documents.

Saving User dictionaries

This is described later in Word list dialogue box menu.

Loading user dictionaries

You can drop a dictionary file icon onto:

� the Load target of the Word list dialogue box (described
later), or

� the Modules set-up window in Icon Bar Menu Preferences

(described in 2.16 Customising Impression).

The easiest way to load User dictionaries is to include them in
Impression�s Auto directory. (All suitable files in the Auto
directory are loaded every time you load Impression.) To include
a dictionary:

� save the dictionary to the Auto directory using the Word list
dialogue box menu (described later), or

� use the Modules set-up window in Icon Bar Menu Prefer-

ences (described in 2.16 Customising Impression).
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Spell checking your document

You can spell check any word of three or more letters. Words can
include apostrophes (') and hyphens (-).

Checking individual words

You can check the spelling of the word containing the cursor
using either 

� Utilities ⇒ Spelling ⇒ Check word or

� the short cut Ctrl-W.

This check has three possible results:

� The word is correctly spelt. In this case, you hear a �happy�
beep.

� The word is not found in the dictionaries. Then:

� you hear the normal �error beep�,

� the word in the text is highlighted,

� the Word list dialogue box is displayed with the
incorrect word in the editable field, and

� the guess option invoked. (The illustration shows
misatke as a mistyped word. The spell checker has
guessed it should be mistake.)

 
The Word list dialogue box is described below.

� The word is only one or two letters long. Then you hear the
�error beep� and the word is ignored.
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Checking as you type

This automatically checks each word as you finish typing it. (The
word ends when you type a Space, Tab, full stop or Return. The
word is not spell checked if you move off the word using the
cursor keys or the mouse.) An �error beep� warns you if the spell
checker does not recognise the word. You can then

� ignore the warning (the word may be correct but not in the
word list; for example, part of an address),

� correct or retype the word, or

� position the cursor in the word and use Utilities ⇒ Spelling

⇒ Check word or Ctrl-W to recheck the word and display
alternatives.

You can select Check as you type from either:

� The Icon Bar Menu (Preferences ⇒ Check as you type). If
you then click on Save, this becomes the default and applies
every time you run Impression.

� Utilities ⇒ Spelling ⇒ Check as you type.

Checking the text

Impression has two options to check the text in a document. Both
options are in the Utilities ⇒ Spelling submenu:

� Check from cursor (keyboard short cut Ctrl-F). This checks
from the word containing the cursor to the end of the current
story.

� Check entire text. This checks all the text in the current
document.

If any unknown words (words not in the word list) are found, the
Word list dialogue box is displayed with the unknown word in
the editable field. (The Word list dialogue box is described
below.)

The Word list dialogue box

This dialogue box is used to: 
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� add and delete words from User dictionaries, 

� load and save User dictionaries and 

� spell check a word.

It also controls hyphenation and abbreviation expansion diction-
aries (described later).

It is automatically displayed when Check word at cursor, Check

from cursor or Check entire text finds a word not in the word list.
It also has a keyboard short cut of Ctrl-F8 or you can use
Utilities ⇒ Spelling or Utilities ⇒ Spelling ⇒ Dictionary.

Dictionary window Editable field

Dictionary name Menu button Load target

Menu Button

Either click on this or click Menu anywhere on the dialogue box
to display the Directory dialogue box menu (described below).
This controls which dictionary to display and the setting up,
deleting, and saving of User dictionaries.
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Guess

Guess again

This button performs a guess operation on the current word in
the editable field. A list of any words that are found is displayed
in the word list window.

After the operation, the button changes to Guess again, which
provides a different guessing facility. Both Guess and Guess

again highlight the top item in the list:

Guess uses typo matching. This assumes a single typing error
such as two characters transposed or one missing letter or one
extra letter, and searches the word list for close matches. 

Guess again uses fuzzy matching. This performs a �sound-alike�
search through the word list noting any close matches.

Find

Find next

This button finds the closest match to the word in the editable
field in the main word list and displays the word list from this
point onwards in the scrolling list. If the word is in the word list, it
becomes the top item in the list.

If the editable field contains * or # characters in the word in the
editable field, the button performs a wildcard matching operation
on words in the main word list. (This is an easy way to cheat at
crosswords.)

# represents one unknown character. * represents multiple
unknown characters. For example:
Comput#r - lists the word Computer.
Fr#a* - lists all words that start with the letters FR and have an

A as their fourth letter.
Relev#nt - shows whether the correct spelling is relevent or

relevant.
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If the number of words that match the current specification is
more than can be stored in memory, the last word that was
checked is noted and the operation is stopped. 

The words up to this last word are displayed in the scrolling list
and the button changes to Find Next. If the button is pressed
again then the operation continues from the point at which it left
off. The button is reset to Find if either all words in the word list
have been matched against or you change the word in the
editable field.

Anagram

This button performs an anagram operation on the current word
in the editable field. This searches through the entire word list
and lists words that have exactly the same letters as specified in
the editable field. 

Ignore

Pressing this button tells Impression to ignore this word and all
further occurrences of it.

Possible errors include:
No room in RMA = there is insufficient free memory to create

the ignore list. 
Illegal character = a * (star) or # (hash) character is present in

the word (hyphens are ignored).
String too short = word is only 1 or 2 characters long.

If the dialogue box is displayed because either Check entire text

or Check from cursor found an unknown word, click on Ignore to
resume searching. Searching continues from the next word in the
text.
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Learn

This adds the word to a User dictionary. If no User dictionaries
are present then a default one is created.

Possible errors are the same as for Ignore.

Forget

This deletes the word from all User dictionaries. You can delete
words only from User dictionaries - never from the Main word
list. 

Possible errors include:
Illegal character = a - (hyphen) , * (star) or # (hash) character is

present in the word.
String too short = word is 1 or 2 characters long.

Word not found = there are no matching words present in any
user dictionaries. 

Unable to delete word = the word is in the main word list or
does not exist in the dictionaries.

Replace

Insert

These buttons have an effect only if there is a highlighted word in
the Word list window.

When it says Replace, the highlighted word in the Word list
window replaces the selected word in the text. When replacing
the word, notice is taken of the case of the letters. If the new
word is longer, then the case of the new letters on the end reflects
the case of the last letter of the old word.

When the button says Insert, the highlighted word is inserted into
the text at the cursor position.

A short cut is double-click on the word in the scrolling list.
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Editable field

This provides the word for all dialogue operations. When the
dialogue box is brought up onto the screen, the cursor is placed
into this field and, when spell checking, the unknown word is
copied into this field. Amendments can be made to the word
using the normal editing keys. The characters which you can type
into the field are:

A-Z, a-z, * (star), # (hash), ' (apostrophe) and - (hyphen).

As you type into the editable field, the word list window displays
the nearest match in the word list. If the word includes * or #, the
scrolling list is not updated.

A space in the editable field acts as a terminator. For example,
typing �hello there� into the editable field and clicking on
Find performs a search on �hello�.

As with all editable fields, Ctrl-U is the easiest way to delete the
entire line of text.

Word list window

This contains a display of 

� the chosen dictionary (you cannot display the WordWorks
dictionary) or 

� words found from other options such as a Guess operation.

A single click on an item in the list transfers it into the editable
field and highlights that word in the list. 

A double click is the same as pressing the Insert/Replace button
or pressing Return.

Load Target

You can load any previously saved User, Exception or Abbre-
viation dictionary by dropping its file icon onto the load target.
(Exception and Abbreviation dictionaries are described later.) If
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the file is recognised then it is loaded in. Dictionary filenames can
only contain the characters A-Z or a-z. 

The error message No room in RMA means that there is no space
for the word list in memory.

Word list dialogue box menu

Click Menu on the Word list dialogue box to display this menu:

The dictionary shown
in the dialogue box

is ticked on this menu

If there is more than one User
dictionary, a tick indicates which
one will have words added to it
when you click on the Learn button

There may be up to eight user dictionaries loaded, and each of
them will have a menu option. (In the above example, there is
one user dictionary loaded called USERDICT.) If you click on the
name of a user dictionary in this menu, a tick appears against the
name. Then any words you add using Learn in the Word list
dialogue box are added into that dictionary. This is useful if you
have more than one User dictionary.

Main dictionary

If you choose this option the word list window shows entries the
Main word list and any User dictionaries.

Exception

If this option is chosen, the word list window shows the hyphen-
ation Exception dictionary (described later). If the hyphenation
program is not present, a warning box appears allowing you to
load it in.
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Save on the submenu lets you save the Exception dictionary.

Either:

� drag the icon to a directory window, or

� click on OK. This saves the dictionary to Impression�s Auto
directory and it will be reloaded every time you load Impres-
sion. You only need to save a dictionary to the Auto
directory once. Any future changes are automatically incor-
porated into dictionaries in the Auto directory whenever you
quit Impression.

Abbreviation

This refers to the Abbreviation dictionary (described later) and
operates in the same way as Exception.

Create

This lets you create up to eight User dictionaries by moving onto
the submenu and typing a name for the user dictionary. The name
can be up to 10 letters long and can only contain A-Z or a-z. You
cannot use numbers. 

Pressing Return or clicking Select creates a User dictionary with
the given name.
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User dictionaries

Save lets you save the User dictionary. Either:

� drag the icon to a directory window, or

� click on OK. This saves the dictionary to Impression�s Auto
directory and it will be reloaded every time you load Impres-
sion. You only need to save a dictionary to the Auto
directory once. Any future changes are automatically incor-
porated into dictionaries in the Auto directory whenever you
quit Impression.

Save as text lets you save the dictionary as plain text. You can
then edit the file using applications such as Edit. Give the
modified file a suitable name and drop its icon on the load target
on the Word list dialogue box. This creates a new User dictionary.
The name can be up to 10 letters long and can only contain A-Z
or a-z. You cannot use numbers.

Delete removes this User dictionary.
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Abbreviation expansion

When typing a long document, you often find that you are typing
many of the same words or phrases repeatedly. Impression offers
a method of speeding up your typing by letting you define
abbreviations for often used phrases, which are then automati-
cally expanded as you type. For example the phrase for example

could be abbreviated to eg. Then, every time the word eg is typed
on its own, it is expanded to for example.

Use Utilities ⇒ Abbreviations ⇒ Dictionary to display the
Abbreviations dictionary. Enter abbreviations in the format

eg for example

Important: the abbreviation must be a single word. Impression
substitutes everything after the first space (for example) for the
word before the first space (eg).

The Abbreviations dictionary can be automatically loaded when
Impression starts up. See Word list dialogue box menu for details.

To turn on abbreviation expansion, use Utilities ⇒ Abbreviations

⇒ Expand as you type. You can also customise Impression to
start-up with this option set. (Set Expand abbreviations in Prefer-

ences on the Icon Bar Menu. See 2.16 Customising Impression
for more details.)

One particular use for this option is expanding frequently used,
long telephone numbers. By entering, for example, tn1 as an
abbreviation for 010 1 415 684-7729, you not only save yourself
typing but also ensure that the number is correct each time it is
used. (When typing it is very easy to transpose two numbers such
as 7792.)

Abbreviations are only expanded if they are terminated by a
space, full stop, Tab or Return. If you move off the word using the
arrow keys, the abbreviation is not expanded. Abbreviations are
not expanded if preceded by a character such as a bracket. Also,
they are case-sensitive � in the examples above, only eg and tn1

would be expanded; Eg or TN1 would not.
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Adding an abbreviation

You can not only expand abbreviations but also substitute one
word for another during typing. For example you can substitute
don�t (with the correct apostrophe character) for don't.

1 Use Utilities ⇒ Abbreviations to display the Abbreviations
dictionary in the dialogue box. 

2 Type
don't don

To enter the ’ character hold down Alt and type 145 on the
numeric keyboard on the right of the keyboard.

Type the final t.

The editable field looks like this:

(The apostrophe is shown incorrectly if you have
RISC OS 2.)

3 Click on Learn to add the word to the dictionary:

4 If you want to save the dictionary, click Menu on the
dialogue box. (Usually you will want to save the dictionary
so that you can reuse it in the future.)
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Drag the file icon to a directory window if you want to save
the dictionary as an ordinary disc file. You will have to
reload the dictionary into Impression if you want to reuse it
in the future.
It is more convenient to save the dictionary to Impression�s
Auto directory. It will then be automatically loaded
whenever you start Impression. Click on OK to save to the
Auto directory.
(If, in the future, you make changes to dictionaries loaded
from the Auto directory you do not need to save them.
Impression automatically updates auto-loaded dictionaries
when you Quit Impression.)

5 You can now close the dialogue box. (Click on OK.)
6 Lastly, you need to enable abbreviation expansion. You can

either 
� choose Utilities ⇒ Abbreviation ⇒ Expand as you type. A

tick against Expand as you type shows when abbrevia-
tion expansion is enabled:

 
    This enables it temporarily � it is not enabled when you

next load Impression.
� choose Expand abbreviations in Preferences on the Icon

Bar Menu. If you then click on Save you enable this
option and also make it the default so it applies every
time you load Impression.

Now, whenever you type don't, Impression substitutes don�t.
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Hyphenation

A word that runs over the end of a line can be either moved to the
next line or split over the two lines and the two parts separated by
a hyphen. Hyphenation is the splitting of words over two lines.

If you do not wish to use the automatic hyphenation module, it
need not be loaded. This saves about 17KB of memory. Words
can also be hyphenated using soft hyphens; these are described
later.

Impression can automatically load the hyphenation module when
it starts up by setting Hyphenator in the Icon Bar Menu Prefer-

ences. See 2.16 Customising Impression for more details.

If the hyphenation module has not been automatically loaded,
you can do so from the Word list dialogue box menu (described
earlier). Choose Exception. You are asked if you wish to load the
hyphenation module and Exception dictionary.

Using hyphenation

Hyphenation is used when a word: 

� does not fit at the end of a line, and

� is in a style with the Hyphenation attribute set.

Impression first checks to see if the word is in the Exception
dictionary. If not it attempts to apply its own built-in hyphenation
rules to the word. The hyphenation system uses a combination of
word list look-up and a sophisticated hyphenation rule method.
In addition you may specify the exact position of hyphenation
points in any word by using the hyphenation exception
dictionary.

Of course, not every word that does not fit is hyphenated. It
depends on a variety of factors. The larger the gap left at the end
of the line by a word not fitting, the more likely it is to hyphenate.
Also if there are hyphens already at the end of previous lines then
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it is less likely to hyphenate as a run of hyphens is undesirable.

Only if the ideal conditions are met and suitable hyphenation
points in a word can be found will the word be hyphenated.

Generally, the narrower the columns of text, the more necessary
it is to hyphenate text. Also, fully justified text benefits more from
hyphenation as it helps reduce large gaps between words.

Special cases

� If a single word is too long to fit onto a line, it is always
hyphenated.

� Words shorter than 4 characters are never hyphenated.

� Words longer than 32 characters are forcibly hyphenated.

� Any non-alphabetic character or hyphen already in the word
means that the word will not be hyphenated. 

� The last word in a paragraph is never hyphenated.

� A word containing a soft-hyphen (Ctrl-hyphen) will be
hyphenated at the soft-hyphen.

Special Words

Some words are special cases where the point of hyphenation
depends on the context in which the word is used. For example:

I give you a pres-ent.
I pre-sent you with this. 

In such cases the word should not be automatically hyphenated.
Such words are entered into the Exception dictionary with no
hyphenation points present. If hyphenation is required then this
should be entered manually using a soft hyphen (described
below). 
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Adding words to the Exception dictionary

Words are added to the Exception dictionary in the same way as
they are added to other dictionaries. The word should be typed
into the editable field as normal, and any hyphenation points
indicated by a number (1, 3 or 5 with 1 being the worst point and
5 being the best). For example:

night3mare

would make sure the word nightmare is only hyphenated
between night and mare.

Click on Learn to add the word to the dictionary.

Deleting words from the exception dictionary

To delete a word, click on the word in the dictionary window to
put the word in the editable field, then click Forget.

Soft hyphens

A soft hyphen is inserted in the text by pressing Ctrl-hyphen (Ctrl
plus the - key). This special character allows you to override the
automatic hyphenation on any required word or to force hyphen-
ation when the hyphenation module is not present.

When a word is likely to be hyphenated because it appears at the
end of a line, insert the soft hyphen at the point where you want
the word to hyphenate. In the example word present you might
put a soft hyphen between e and s (if that is correct for the
context). If the word is hyphenated, the break will be between
pre and sent and the soft hyphen replaced by a normal hyphen. If
the word is not hyphenated (later edits may move the word to the
middle of the line), the soft hyphen is invisible and has no effect. 

If you step the cursor through a word containing a soft hyphen,
you will see it pause at the soft-hyphen. This is because the soft
hyphen is a character in the word even though it is invisible.

Often you want the whole document to be automatically hyphen-
ated. (Set Hyphenation in Normal style to do this.) Sometimes you
will find that a word has hyphenated when it would be better
unhyphenated. The easiest way to stop a word hyphenating is to

245 

2.13 Spell Checking



insert a soft-hyphen at the end of the word. Move the cursor after
the last character and type Ctrl-hyphen (Ctrl plus the - key).
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2.14 Mail merging

This section covers:

• using the Start mail merge menu command

• mail merging using Start mail merge

• inserting merge commands from CSV files

• using the Merge command menu option

• mail merging from a database
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Mail merging

Impression has a simple but very flexible method of mail-merg-
ing. You insert merge commands into a document at the required
places. Impression can then communicate with a database
program or use its own merge facility. The merge commands in
the document are replaced by data from the database or a suitable
data file and the document printed. This process continues until
either all the mail-merge records have been processed or you
stop the process.

Preparation

Before running mail-merge you must prepare a suitable data file
in CSV format. This is a common file format used by most
database programs. The filetype must be CSV (if you have
RISC OS 3, use the filer menu to change the type if necessary).
The format is:

data field 1,data field 2,etc.
with commas separating each field (hence, Comma Separated
Value � CSV). Enclose the field in sexless double quotes (") if it
includes a comma (for example, "One,two"). Use \N if you
want a Return character in the field.

At the head of the file should be a list of field names. These
names should match those in the Impression document merge
commands. For example, a simple file might have three fields:

Name,Telephone,Room Return

Note that there is no comma after Room. This tells Impression that
this is the end of the field names.
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The data for merging comes after the field names. A simple file
with just two sets of data might look like this:

Name,Telephone,Room Return
John,26,B12, Return
Kate,38,T3

You can prepare files using Impression. Save them using
File ⇒ Save text story and reset all save options:

After saving the data to disc you can use the filer to change the
filetype to CSV.

If you later reload the file into Impression for further editing,
ensure that Smart quotes in Preferences on the Icon Bar Menu is
off. If this option is on, the sexless quotes "" get changed to true
quotes ��. See 2.16 Customising Impression for details of
Preferences.
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Start mail merge menu option

Use Utilities ⇒ Start mail merge to display a small dialogue box:

Drop a CSV file onto the dialogue box. An extra button Start

merge then appears in the bottom corner of the dialogue box and
the Headings tab becomes active:

Select Ignore Headings if the first line of the file is not a list of
headings (field names). (See Mail-merging using Start mail
merge for more details of field names.)

Click on Start merge to begin the mail merge operation.

Impression replaces the Merge commands with the first entry in
the CSV file.

Click on Print to print this document. You can click on Print again
to print another copy of this entry.

Click on Print all records and then Print to print all the remaining
entries in the file.
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Click on Next to replace the Merge commands with the next entry
in the CSV file. Press Next again if you don�t want to print this
entry.

Click on Edit if you want to edit the currently displayed docu-
ment. This quits the mail merge operation but retains the
currently merged data. If you save this document to disc, remem-
ber to change the file name. If you keep the same filename, you
will overwrite the original document.

Mail-merging using Start mail merge

Impression includes a simple mail-merge facility accessed from
Utilities ⇒ Start mail merge. (The menu option is described
earlier.)

The mail merge operation is based on an Impression document
which contains merge commands, which appear as the field
name surrounded by angle brackets. These are created as
described below, not simply typed in as they appear.

In order to place merge commands inside your Impression
document, in the place where you want to insert data from the
CSV file, choose the field name from the Headings tab and the
command will be inserted at the current cursor position. For
example, a simple letter to John and Kate might look like this:

To <Name> room <Room>

From Mark

Your extension number will change on Thurs-

day to 3<Telephone>.

When you merge the first record, the data from the CSV file
replaces the merge commands and the letter reads:

To John room B12

From Mark

Your extension number will change on Thurs-

day to 326.
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An easy way to insert merge commands using

CSV files

1 Display the Start mail merge dialogue box.

2 Drop the CSV file onto the dialogue box. (The CSV file must
contain a headings line.) This ungreys the Headings option.

3 Position the cursor where you want to insert the Merge
command.

4 Click on the arrow to the right of Headings. This displays a
menu of available field names.

5 Choose the required field name from the menu. Impression
inserts the correct format Merge command for that field
name into the document at the cursor.
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Merge command menu option

Use Utilities ⇒ Merge command to display this dialogue box:

Use this dialogue box to enter mail-merge commands into the
document. Merge commands are inserted at the cursor, so
reposition the cursor if necessary. Type the required merge
command (up to 250 characters) into the editable field. (In the
illustration, this field contains data field.)

Click on Set to insert the command into the document. Merge
commands are shown in the document as <Field name>.

Click on Cancel to close the Merge dialogue box and ignore any
changes made to the editable field.

Click on Clear to delete the merge command to the right of the
cursor from the document. You can also delete merge commands
using any of the delete keys.

Mail merging using database applications

Merging is entirely under the control of the database application.
The database communicates with Impression whenever a <Field
name> command needs replacing with record data.

Impression sets no restrictions on the format of the merge
commands, which are entirely database dependent. For this
reason, you should refer to the documentation supplied with the
database for merge command syntax.

Other software developers wishing details of the Impulse inter-
application command language used by Impression should
contact RISC OS Developments.
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2.15 Contents & Index

Generation

This section covers:

• creating a list of contents 

• creating an index chapter

Related sections of this manual:

• 2.4 Effects, Styles & Rulers

• 2.11 Chapters

Many aspects of contents & index generation are easier to

describe by example. The sample document Index on the

Publisher discs shows you how to create appropriate styles

and select appropriate master pages.
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Compiling a list of contents

Before you can compile a list of contents you must mark those
words and phrases you want include in the contents. Use the
Contents label attribute in the Style Editor for this. (The Style
Editor is described in detail in 2.6 Styles.)

Any text in a style with this attribute set will be included in the
contents list. (The predefined styles Main Heading and Sub
heading already have this attribute set.)

Associated with Contents label is Level. This lets you use different
styles when creating the contents list to show the relative impor-
tance of different entries. For example, Main Heading has level 1
set; Sub-heading level 2. Impression has 16 levels of contents
style, 0 to 15.

To use levels you need to create one or more styles called
ContentsN where N is the level number. (Contents1 for level 1 for
example.) Note: the Contents styles affect how entries appear in
the contents list � they have no affect on text in the main part of
the document.

Using levels is optional. Impression substitutes Normal style for
any missing Contents styles.

Use Utilities ⇒ Compile contents to display the Compile dialogue
box (described later). This creates a new chapter at the beginning
of the document containing a list of contents. Entries can contain
any character including spaces but leading and trailing spaces are
removed before they are entered in the contents list. Each entry is
followed by a space, a Tab character and then the page number
on which it appears. The whole line has the style ContentsN (if
defined) applied over it.

Styles with the Label attribute set do not need to have any effect
on the format of the text to generate entries in the compiled
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chapters. For instance, you may have marked some text in Sub-
Heading style and subsequently applied another style over it so
that the effects of the Sub-Heading style are completely hidden.
Any text in Sub-Heading style will still appear in the contents
pages.

Compiling an index

This is similar to compiling a list of contents. You first mark text
for inclusion in the index by applying a style with the Index label

attribute set. 

Usually you would create a special style (Index is a sensible name
for it) with just the Index label attribute set. However, it can be
useful temporarily to set the text background colour for the index
styles. The coloured background shows you which text will be
included in the index. It is up to you to decide which words and
phrases you want in the index by applying the Index style to
those words.

Use the menu option (Utilities ⇒ Compile index) to display the
Compile dialogue box (described later). This creates a new
chapter at the end of the document containing the index.

Each piece of text marked for inclusion in the index is given an
entry in the index (the case of alphabetic characters is ignored).
Entries can contain any character including spaces but any
leading and trailing spaces are removed before they are entered
in the index. A list of the page numbers containing each entry is
constructed after the entry. If an entry appears on two or more
consecutive pages a range is shown (123-125).

Entries are arranged alphabetically under category headings of
the letters A to Z. If an entry does not start with an alphabetic
character it appears either before the A category or after the Z

category, depending on the character.
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The Compile dialogue box

Use either Utilities ⇒ Compile contents or Utilities ⇒ Compile

index to display this dialogue box.

À Á
Â
Ã
Ä Å
Æ Ç

À Chapter Style 

This is the style that will be applied to the whole chapter. It
should be appropriate for the layout of the chapter. If the Chapter

style is defined to have no tabs then the page list will be dis-
played directly after the entry text. If the Chapter style defines a
tab position it should be set so that it is beyond the end of the
longest entry text. Then all the page number lists will line up
vertically. The left margin and return margins can be used to
control the wrapping of long page number lists. It is also probably
a good idea to set the Space below paragraph attribute of the
Chapter style to 0 otherwise text may be spaced out too much.

Á Style lists icon

You can type style names into Chapter style, Title style and
Category style. An easier alternative is to:

� click on the Style lists icon, or

� click Menu on the editable field.

Either action displays a list of styles from which you can choose.
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Â Title style 

This is applied to the word Index or Contents that is always
placed at the start of the chapter.

Ã Category style 

This is only used in index compilation.

It is applied to each of the category headings A to Z. It is useful to
set the Space above paragraph attribute to at least 4pt so that
each category is separated from the preceding entries.

Ä Chapter numbers

If this is on, page numbers are shown in the form
chapter .page. 

This lets you number each section of a manual independently and
show the complete section number in the index and contents
pages. (See 2.3 text handling for details of inserting page and
chapter numbers into the text.) 

If the button is off, only the page number is shown.

Å Master page

This lets you choose a suitable master page to use for the index or
contents chapter. As index entries are usually fairly short, a two
column master page (as shown in the illustration) can make better
use of the space on the page.

Click on the menu icon to display a menu of master pages.

Æ Capitalise entries

If this is on, entries have an upper-case first letter. Otherwise the
entries are shown as they first occur in the document.
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Ç The OK button

Click on this to create the index or contents chapter. You can edit
these like normal chapters. If you ever need to re-compile them,
any edits that you have made do not appear in the new version.
For this reason, creating a new index/contents chapter does not
delete the old one. This gives you the opportunity to examine the
changes between the old and new chapters. The old chapter can
then be deleted using Edit ⇒ Delete chapter.

Common aspects of index & content compilation

Text stories that exist only on master pages, such as headers and
footers, are not included in the index/contents search. 

If the document is very large the index/contents compiler may
have to bring in text stories which have been shuffled out of
memory - so there may be some disc access while the new
chapter is being compiled.
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2.16 Customising Impression

This section covers:

• changing the master page

• Preferences in the Icon Bar Menu

• auto-loading files
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Introduction

Every owner of Impression has a different use for it. One user
might want it mostly for letters, another for producing newslet-
ters, and another for writing books. No matter what your
requirement for Impression, you will almost certainly find that
one aspect or another is not exactly as you would like it.

For this reason, many features of Impression are changeable.

Changing the default document 

(The default document is the blank document that appears when
you click on the Impression icon on the icon bar.)

The Utilities ⇒ Save as default menu option lets you overwrite
the default document with the current document.

To modify the default document:

1 Click on the Impression icon to open a new document.

2 Make any necessary changes. (These changes could be
adding, modifying or deleting styles from the style list;
modifying the layout of frames on the default page; adding,
modifying or deleting master pages. You can make any
change to the default document that you can to an ordinary
document.)

3 When you are happy with the changes, use Utilities ⇒ Save

as default to make this the new default document.

4 Quit and then reload Impression. This loads the new default
document.
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Icon bar menu Choices

This dialogue box controls the preferences while Impression is
running, letting you change the defaults after Impression has
started, but it also allows you to save the preferences in the
Impression application so that these become the defaults. 

Click OK to use, but not save, the new preferences. 

Click Cancel to ignore any changes made to the preferences. 

Click Save to use the new preferences and also save them within
Impression, so they also take effect each time Impression is
loaded. You also save the current setting of the Save text options
(these are on the File menu).

The Modules button is described later.

There are five areas controlled by the Preferences dialogue box.
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Auto load

The spelling checker, automatic hyphenation, and dither graphics
within Impression are controlled by separate program modules,
which are stored within the Impression application directory.
Normally, they are not automatically loaded, as they take up
valuable memory - the spelling checker takes up over 100KB - but
if they are always required, Spelling checker, Hyphenator, and
Dither graphics can be switched on. Then, if the preferences are
saved, the next time Impression is loaded it automatically loads in
the selected modules. 

You need to load the dither graphics module (which is about
20KB long) if you want rotated sprites in RISC OS 2 and grey-
scale dithering. Even with this option off, you can always rotate
Draw files. If you have RISC OS 3 you can always rotate Sprites.
Only RISC OS 2 needs this option to rotate Sprites.

Greyscale dithering is greyed out until Dither graphics is turned
on. Turning on Greyscale dithering does several things:

� Displays all the sprites using greyscale dithering, ensuring
monochrome sprites appear as well as they can on screen.
This applies to sprites containing colour as well, so all sprites
appear as monochrome images.

� Sets the desktop colour palette to give 16 grey levels. If you
use a colour monitor, it appears as though the screen is
monochrome. Using 16 grey levels vastly increases the on-
screen display of monochrome images.

� Loads in another module which extends the range of grey
levels available in Draw images. This uses dithering to give
the appearance of far more grey levels than are actually
available.
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To return the colours back to normal just use the palette
utility on the right of the icon bar. (Click Menu on the palette
icon and then select Default.) The palette icon was removed
after RISC OS 3.19.

Units

Several of the dialogue boxes in Impression display measure-
ments. Use this area to change the display default units. Any page
measurements, such as frame sizes or page sizes, use the Page

unit. Style or typeface measurements, such as font size or line
spacing, use the Style unit. Page rulers use Page rulers.

To change one of the default units, either;

� click on the arrow to the right of the box, or

� click Menu on the box itself.

This displays a menu of available units. The currently selected
entry is ticked. Click on the required name to change the default
units. 

When using Impression, you can type in new values using any of
the units that Impression recognises and Impression will do any
required conversion. For example, if the page unit is inches, you
can type in a value as 3cm. Impression then automatically
converts that value from centimetres to inches. All values would
be displayed in inches.
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Default window scale

Whenever a new window is created onto a document, it has a
default scale, normally 100%. It may be useful to change this, as
the best scaling depends on the screen mode. As an example,
100% in mode 12 means that Impression cannot display the full
width of the default frame - a scale of 90% would be more useful.
To change the scaling of the document view, edit the number in
the Document field. The scale is saved with the document and
applies when you next load the document.

Master page performs the same task for the master page window. 

Display

This box controls certain aspects of the way documents are
displayed in Impression. 

Show frame outlines

Turns frame outlines on or off, except for the selected frame
which always has an outline. Turning the frame outlines off gives
a better impression of how the page will look when printed.
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This option has a keyboard short cut of Ctrl-O. You can also use
the Frame outline tool on the toolbar.

Show print borders

This duplicates View ⇒ Print borders and has a keyboard short cut
of Ctrl-Shift-O.

This shows the limit of the current printer driver�s printable area
in grey. This limit only applies when printing single pages at
100%. 2.4 Printing describes using the print borders.

Show page rulers

This duplicates View ⇒ Page rulers and has a keyboard short cut
of Ctrl-P.

This turns the rulers along the top and left-hand edges of the
window on or off. Because the ruler has to be redrawn when the
document moves in the window, showing the page rulers can
slow down screen updating.

Show button bar

This displays the button bar along the top of the document. It
duplicates View ⇒ Tool bars ⇒ Show button bar. (See 2.2
Toolbars for details.)

Show text/ruler bar

This displays the text/ruler bar along the top of the document. It
duplicates View ⇒ Tool bars ⇒ Show text/ruler bar.

Show ruler bar

This displays the ruler bar along the top of the document. It
duplicates View ⇒ Tool bars ⇒ Show ruler bar.

Flashing cursor

It is often easier to see the cursor if it is flashing. This is especially
so on monochrome monitors.
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Show short cuts on menu

Showing short cuts on menus can be a useful reminder but
increases the width of menus.

Misc

Check as you type

This checks the spelling of words as you type them. You also
need to set Spell check on in Auto load and include any user
dictionaries in the Auto directory.

For more details of spell checking, refer to 2.13 Spell checking &
Dictionaries.

Expand abbreviations

If you have created an abbreviation directory, setting this option
on will automatically expand abbreviations as you type them. You
must create an abbreviation dictionary before you can use
abbreviation expansion.

For more details of abbreviation expansion, refer to 2.13 Spell
checking & Dictionaries.
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Snap to all frames

This facility is described in 2.8 Frame handling.

Smart quotes

This option affects the interpretation of �sexless� quotes in text
files read into Impression. (Sexless quotes are the ' and " charac-
ters on the keyboard, next to the Return key.) Impression can
convert these into proper open and close quotes (‘ ’ and “ ” ).
The smart part is that Impression decides when it should use
open quotes and when close quotes, according to the rules of
English punctuation. It occasionally confuses an apostrophe for a
close quote but usually gets it right. Smart quotes can greatly
improve the appearance of a document especially when printed
at high resolution.

A second feature is that two consecutive ordinary dashes (- -) are
converted to a long or em dash (�).

You would turn this option off to import program listings as
usually these require the sexless quotes and �- -� to remain
unchanged.

Save old DDF format

The version of DDF used in this Impression is incompatible with
older versions. This option lets you save text in the old format.
You can then load those text files into older versions of Impres-
sion. The on-line help contains more details on DDF commands

Remove document on close

As described in 2.1 The basics, clicking on the Close icon can
have two possible effects:

(a) Close the window and remove the document from memory.
(This is the convention with most Acorn applications.) If you
have multiple windows (up to four are allowed), the docu-
ment is only removed when you close all the windows.

(b) Close the window but retain the document in memory. This
can be useful if you want to have several documents in
memory (up to 15) but don�t want to clutter the screen with
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unwanted windows.

This option selects which option applies. (When selected, option
(a) applies.) The most suitable option is a matter of personal
preference.

Search whole document

This applies to the Find & Replace dialogue box. See 2.3 Text
handling for more details.

Colour table

Click on the menu icon for a menu of available tables. Colour
tables are described in 2.4 Printing.

To change the default colour table, select the required table and
then click Save.

Modules

This button opens a dialogue box that lets you load and remove
modules from the auto-load list and from memory. These
modules can perform a variety of functions such as loading files
in alien formats and permitting draft printing.

The loader modules can be found in the Extensions directory.

An Impression loader or printer module has this icon

To load a module

Select either Auto loaded or In memory. Modules in the auto
directory are loaded every time you load Impression. Modules in
memory are discarded when you Quit Impression.

Drop the module icon on the load target. This loads the module
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and adds it to the list in the dialogue box.

The types of module you can load are:
� Impression loader and printer modules,
� spelling checker user dictionaries,
� spelling checker ignore dictionaries, or
� RISC OS relocatable modules. 

Other types of module are ignored if you try to load them.

To remove a module

1 click on the module name to highlight it,

2 click on Delete.
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Chapter 3:

Keyboard shortcuts
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The usual notation is used:

� F1 to F12 denotes the function keys, 

� Shift-F1 - hold down the Shift key and then press F1, 

� Ctrl-F1 - hold down the Ctrl key and press F1,

� Ctrl-Shift-F1 - hold down both Ctrl and Shift and press F1.

Dialogue boxes 

F3 - save

F4 - find

Ctrl-F1 - document info

Ctrl-F5 - new style

Ctrl-F6 - edit style

Ctrl-F7 - new chapter or new master page

Ctrl-F8 - dictionary

Ctrl-F9 - scale view

Ctrl-F10 - alter frame

Ctrl-F11 - alter graphics

Ctrl-T - tracking/kerning

Ctrl-Shift-A - alter chapter

Ctrl-T - tracking/kerning dialogue box 

Print - print

Page movements

Ctrl-Shift-G - go to page

Ctrl-Shift-N - move to next page (if any)

Ctrl-Shift-P - move to previous page (if any) 

Ctrl-Shift-W - go to chapter

PageUp - scroll down one screen

PageDown - scroll up one screen

Ctrl-Shift-↑↓←→ - equivalent to clicking on the Scroll Arrows

277 

Chapter 3: Keyboard



Effects & Styles

Ctrl-B - embolden text

Ctrl-I - italicise text

Ctrl-N - clear all styles (revert to Normal style)

Ctrl-Shift-J - superscript effect

Ctrl-Shift-K - subscript effect

Ctrl-Shift-L - line spacing edit box

Ctrl-Shift-S - text size edit box

Ctrl-Shift-T - increase font size

Ctrl-Shift-U - underline effect

Ctrl-Shift-Y - decrease font size 

F5 - left align (justify) text

F6 - centre text

F7 - right align (justify) text

F8 - fully justify text

Kerning

Ctrl-E - extend space between characters (horizontal kerning) or
expand tracking of region of text

Ctrl-J - move baseline down (vertical kerning)

Ctrl-R - reduce space between characters (horizontal kerning) or
reduce tracking of region of text

Ctrl-T - tracking/kerning dialogue box 

Ctrl-U - move baseline up (vertical kerning)

Deleting & Copying

Ctrl-C - copy the selected item to the clipboard

Ctrl-D - cut the word at the cursor to the clipboard

Ctrl-H - delete the character before the cursor

Ctrl-K - delete the selected item
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Ctrl-X - cut the selected item to the clipboard

Ctrl-Copy - cut the entire line to the clipboard

Pasting & Inserting

Ctrl-V - paste clipboard contents

Insert - equivalent to Ctrl-V
Ctrl-Shift-D - insert current date

Ctrl-Shift-E - insert new repeating frame

Ctrl-Shift-F - embed frame

Ctrl-Shift-I - insert new blank frame

Ctrl-Shift-F9 - insert subsequent paragraph number

Ctrl-Shift-F10 - paragraph number selected region

Rulers

Ctrl-P - toggle page rulers on and off

Ctrl-Shift-R - toggle Toolbar on and off

Selecting text

Ctrl-A - select entire story containing cursor

Ctrl-L - select line containing cursor

Ctrl-Q - select word containing cursor

Ctrl-2 - select paragraph containing cursor

You can also select using the mouse:
double-click to select a word,
triple-click to select a line, 
quad-click to select the entire paragraph.
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Spelling

Ctrl-F - check spelling of the story from the cursor

Ctrl-W - check spelling of the word at the cursor

Miscellaneous

The remaining commands don�t fit into any particular category.

Ctrl-G - force to next frame

Ctrl-O - turn frame outlines on and off

Ctrl-S - swop case of character at cursor (from lower-case to
       UPPER-CASE or vice versa)

Ctrl-Y - find next occurrence of search word

Ctrl-Z - deselect the selected region

Ctrl-F2 - remove document

Ctrl-F3 - save text story/graphic

Ctrl-Shift-C - close window (this is the same as clicking on the
Close icon on the editing window)

Ctrl-Shift-H - insert a bullet point (�) at cursor

Ctrl-Shift-O - turn print borders display on or off

Ctrl-Shift-Q - transpose characters either side of cursor

Ctrl-Shift-F1 - open new window on current document 

Ctrl-Shift-F2 - open master page window

Ctrl-Shift-F3 - Toggle single file/directory save formats 

Ctrl-Shift-_ - insert an n-dash (−) at cursor

Shift-F1 - permit editing of irregular frames

Shift-F2 to F10 - scale view to 20% to 100% of full size

Shift-F11 - halve current viewing scale

Ctrl-Shift-F11 - double current viewing scale
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Mouse operations

Anywhere in document:

Select +Ctrl+Shift Click - double current scale
+Ctrl+Shift Drag - Zoom rectangle
+Shift Drag - Create frame selection rectangle

Menu - display Main Menu 
Adjust +Ctrl+Shift Click - halve current scale

Blank areas of a page:

Select Drag - scroll your view of document

Frame handles, normal action:

Select Drag - resize frame

...additional action in graphics frames

Adjust Drag - resize frame and scale contents 

On outline of irregular frames:

...on handles

Select Drag - move handle
  Drag over another handle - delete handle

+Shift Click - delete handle

... on frame edge

Select Click - add handle

Within frames:

...all types of frames

Select Click - select frame under pointer
Click and Hold - pick up and drag frame

Select +Shift Click - add frame to or remove frame from
current frame selection

Select +Ctrl Drag - if over selected frame, pickup and drag
selected frame, 

  else drag frame under pointer
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Select +Alt Click - perform Click operation on frame
below selected frame

Select +Shift+Alt Click - as Shift Click but acts on frame below
selected frame

...additional action in blank frames:

Adjust Click - link frame contents to selected frame
contents

...additional action in repeating frames:

Select Double-click - move to first occurrence of frame

...additional actions in text frames:

Clicking or dragging within a selected region...

Select Click & release - clear selection and position cursor
 Drag - move text using drag & drop

Select +Shift Drag - copy text using drag & drop

Otherwise...

Select Click - position cursor
Drag - select a region from click point to end

of drag 
Double-click - select word

Triple-click - select line
Quad-click - select paragraph

Adjust Click - select region from cursor/selected
region to click point

Drag - select region from cursor/selected
region to end of drag

...additional actions in graphics frames

(including frames with embedded data):
Select Double-click - alter graphic dialogue box 
        +Ctrl Double-click - OLE to parent application 
Adjust Double-click - scale graphic to fit the frame
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Graphics tool:

Rotate handle

Select Drag - rotate
Double-click - set angle to 0°

Select +Ctrl Drag - constrain rotate to 45° angles
Adjust Drag - rotate frame and graphic; make frame

irregular

Pan handle

Select Drag - move graphic in frame 
Double-click - centralise graphic

Select +Ctrl Drag - constrain pan to 45° angles

Scale handle

Select Drag - scale graphic about centre
Double-click - scale graphic to 100%

Select +Ctrl Drag - preserve current aspect ratio
Adjust Drag - scale frame and graphic
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Appendix 1: Updating ABI

The ABI module covers the user interface of Impression and other
applications. This section describes the action you should take if
you get the error message �... Please refer to the �Updating ABI�
section in the manual�.

This message means the application requires a more recent
version of ABI than that on your disc. Read the manual for the
application that you have updated � this section covers problems
after Impression upgrades.

Depending on your level of expertise you can use the non-
technical or the technical way to update ABI. If the message
persists, seek technical assistance.

The preferred way

1 Open the !Style application directory.

2 Open the Impression RMStore directory.

3 Open the !System.Modules directory.

4 Copy the ABIMod file from RMStore into !System.Modules.
5 Quit any applications currently loaded.

6 Reset the computer.

7 Reload Impression.
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The legacy method (running from floppy disc)

1 Re-run the Impression !Install program. This re-installs ABI
on your computer.

2 Quit any applications currently loaded.

3 Reset the computer.

4 Reload Impression.
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Appendix 2:                     Using

Dialogue Boxes  

Dialogue boxes are the most important way in which you
communicate with Impression. Nearly every important function,
apart from entering text, is carried out through the use of a
dialogue box. The dialogue boxes in Impression have all been
designed to look and act in the same way so that they never do
anything unexpected.

While we have tried to make our dialogue boxes look distinctive,
they closely follow the Acorn style guidelines. If you have never
used dialogue boxes before, the following descriptions should
help you to understand how they work. If you are familiar with
dialogue boxes you can probably skip the rest of this appendix,
as Impression dialogue boxes will hold no great surprises for you.

Every box that you click on or type into in a dialogue sets up a
new value or does something inside the program. You can tell
roughly what is going to be done by the shape and colour of the
box you are clicking or typing into. You can also tell what the
current setting of a value is by the shape, colour and text of the
boxes.

Switches

Switches are small squares with text immediately to the right or
left of them. Switches only have two positions - clicking on the

287 

Appendix 2



switch or the text beside it will flip the switch from on to off or
vice versa.

      

�  When a switch is on, it is drawn with a tick in the middle
and looks as if it is pushed into the dialogue box. In this state it
means that the value named by the text of the switch is on or
set or true.

�  When a switch is off, it is simply a light grey square which
looks as if it is raised up from the dialogue box. In this state the
value is off or unset or false.

Radio switches

Radio switches are small circles, once again with text immediately
to the right or left of them. Radio switches are always shown in
groups of two or more and only one switch in the group can ever
be on. They are used to set one value from a small range of
possible values. The radio switch which is on shows which of the
values is selected

�  When a radio switch is on it has a dark grey circle in the
middle and looks as if it is pushed into the dialogue box.

�  When a radio switch is off it is just a light grey circle which
looks as if it is raised up from the dialogue box.

Action buttons

Action buttons do not set values. They are drawn as if they are
raised up from the dialogue box and the text inside them
describes what will happen when they are clicked.
�  Most have a Cancel action button. When you click on this
button any changes that you have made by clicking or typing in
the dialogue box will be cancelled - all the values shown by the
dialogue box will revert to what they were before the dialogue
box appeared on screen.
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The Default action button

The default action button can be clicked like any other action
button. The difference between this and other action buttons is
that it also responds to Return. When the dialogue box has the
text cursor in one of its editable fields and the Return key is
pressed, the dialogue box acts as if the default action button had
been clicked.

There can only be one default action button in a dialogue box
and it is drawn much like other action buttons but with a yellow
�moat� around it.

�  Most dialogue boxes have a default action button and it is
usually named OK. Clicking the OK button (or pressing Return)
means that you want to use the changes that you have made in
the dialogue box.

Editable fields

Editable fields are white rectangles with black borders which look
as if they are indented into the dialogue box. A textual value is
shown inside the white rectangle and this can usually be altered
by typing in a new value. The text cursor must be in the editable
field that you wish to alter before any changes can be made.

The text cursor can be put into an editable field in one of two
ways. The simplest method is to click on it. Any subsequent
typing will appear in the editable field where the text cursor is
and the text cursor will move along with them.

It is usually necessary to delete the old value before typing in the
new one and this can be done by pressing the → key to move to
the right-hand end of the text and then pressing the Delete or
Backspace keys a few times until the text has been cleared. An
easier way to delete the text from an editable field is to press Ctrl-
U. (Ctrl-U means hold down the Ctrl key and press U or u.)

The other way of getting the text cursor into an editable field is to
use the keyboard. There are some keys on the keyboard which
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will move the text cursor around between the editable fields in a
dialogue box. They are:

↓ Move on to next field

↑ Move back to previous field
Tab Move on to next field

Shift-Tab Move back to previous field

Ctrl ↓ Move to first field

Ctrl ↑ Move to last field

The �next� field is usually below or to the right of the current field.

The �previous� field is usually above or to the left of the current
field.

The �first� field is usually the one nearest the top of the dialogue
box.

The �last� field is usually the one nearest the bottom of the
dialogue box.

If the text cursor is in the last field and you try to go to the next
one, it will go to the first field. Similarly, if the text cursor is in the
first field and you try to move to the previous one, the text cursor
will be placed in the last one.

Note that these keys only work if the text cursor is already in an
editable field in the dialogue box.

� Pressing Return when the text cursor is in an editable field
does not move it on to the next one as it does in older design
Acorn dialogue boxes. Instead, it always selects the default action
button.

Bump icons

These can point either up & down or left & right. Clicking on the
arrows increases or decreases the value in the adjacent editable
box. Usually each click changes the value by 1.
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Page units and Style units

These are also called Measurement units. Editable fields which
display measurements will display them in default units. Measure-
ments relating to the position on that page are usually given in
millimetres, and those relating to styles, such as font size, are
given in points. These default units can be changed using the
Preferences dialogue box but, regardless of the units displayed,
numbers can be entered in any unit recognised by Impression. If
you type the number followed by the abbreviation for the unit,
Impression will convert into its internal units. The units recogn-
ised by Impression are:

in inches

ft feet

yd yards

pt points (1/72 inch)

pi pica (1/6 inch)

mm millimetres

cm centimetres

m metres
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Colour fields

 

Colour fields let you enter colour values and look a lot like
editable fields - they are inset into the dialogue box and have
black text on a white background but they also have a coloured
spot to the right of the text. The colour of the spot is the closest
screen colour to the actual colour defined and the shape of the
spot describes which colour model was used to define it. For
more information on colours see 2.12 Colour handling.

� To alter the colour shown by a colour field just click in it and
the Colour Picker dialogue box will appear.

Sliders

Sliders are used as a quick way to enter numbers and they also
show the number graphically. Sliders are drawn as a thin
coloured bar on a white background which is raised up from the
dialogue box. At either end of a slider there is some text which
tells you the range of numbers which the slider represents. Quite
often there will also be an editable field close to the slider which
gives the actual number the slider is showing graphically.

�  To alter the value of a slider click on it and keep the mouse
button pressed. Then move the mouse pointer along the slider
and the coloured bar will follow the pointer. When you let go of
the mouse button the slider will set the value according to the
last position of the mouse pointer.
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Load targets

  

Load targets are visual reminders that something can be loaded
into Impression by dropping a file icon into a dialogue box. They
are drawn as large downward pointing arrows above the name
of the type of object which can be loaded.

� To use a load target you should drag the file icon of the file
you want to load from one of the directory windows onto the
load target. If you click on a load target a small dialogue box will
appear to remind you how to use that load target.

Alert boxes

Alert boxes are a special type of dialogue box. They are used to
tell you something important or to ask a question which must be
answered before the program can continue.

An Alert box is a small window with no title bar or close box and
appears in the centre of the screen. It has some text in a box on
the left and up to three action buttons on the right. The text
explains what the problem is and what you can do to deal with it.
The buttons allow you to choose one option to deal with the
problem.

When an Alert box is on the screen you will not be able to move
the mouse pointer beyond the box and you will not be able to
type characters into any other window or dialogue box on the
screen. This ensures that you respond to the Alert immediately.
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Report boxes

Report boxes are similar to Alert boxes but they usually report
much more serious problems. Report boxes look different
because they are not drawn by Impression but by RISC OS. They
are large windows with text in the centre, a warning �STOP� sign
and an Operating System icon.

� Report boxes often appear when there has been an error inside
Impression. It is strongly recommended that whenever you see a
report box you save your documents immediately afterwards!

 294 Impression Manual

Impression PublisherUsing Dialogue Boxes



Appendix 3: Recommended

equipment

Your choice of equipment and its specification will necessarily be
limited by your budget. It is possible to run Impression on a basic
computer, though your machine must have at least 2MB of
memory fitted. 

The question of what to get in order to enhance your system is
never an easy one to answer. However, here we offer a few
pointers. Please note that we cannot recommend particular makes
or models of monitors, printers or scanners.

Memory

Impression can operate in a 2MB computer but the more RAM the
better. A minimum of 4MB is recommended but most modern
computers now have at least 256MB.

Disc drives

You can use Impression on a floppy disc based machine - such
computers are, however, now obsolete. A hard disc gives much
greater storage capacity and faster loading and saving. This is
important if you use a lot of different fonts � with floppy discs
you will have to swop discs frequently.
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Monitors

Any modern monitor will offer a high resolution display capable
of showing the full range of colours.

Printers

There is a wide choice of printers available to work with Acorn
computers ranging from cheap dot-matrix printers to top-quality
laser printers and colour printers.

We do not recommend dot-matrix printers. They are slow and
give inferior results compared to other types of printer such as
ink-jet or laser.

Scanners

If you wish to include illustrations and photographs in your
documents, an image scanner could be the answer. Scanners are
fast becoming popular accessories.
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Appendix 4: Hints & Tips

This chapter contains general hints concerning many aspects of
Impression. It is provided because although most things are quite
possible in Impression, it is not always obvious how they might
be done. You should also refer to the document called !Hints on
the Publisher discs which contains the latest information.

A menu option is greyed

This usually happens when a menu option is not appropriate to
the current situation. For example, if the currently selected frame
is not a graphic frame, then menu options relating to graphics are
greyed.

If the document beneath the menu does not have the currently
selected frame in it (shown by a yellow title bar), then most of the
options will be greyed. Simply clicking in the document then
ungreys the menu options.

Memory problems

If you get �out of memory� or �heap full� errors, it is likely that the
memory is not ideally configured. The memory available to
Impression is reduced if the Module area or System Sprite area is
allocated unnecessarily large amounts of memory.
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The higher the screen resolution, the more memory is required.
Therefore, a simple way to recover more memory is to switch to a
lower resolution screen mode. Mode 12 requires 80KB whilst
mode 11 requires half that. Mode 0 is not really suitable for
editing text in Impression but can be used and requires only
24KB. (Mode 0 can be useful when maximising memory for
printing.)

Acorn recommend that no memory is allocated to the System
Sprite area and the minimum possible to the Module area (RMA).
Refer to the Installation supplement for details of how to change
the settings. Remember to reset the computer after making any
changes.

Many applications (such as !Draw and !Paint) load parts of their
programs into the module area. When these programs are
removed from memory, a residual area is still occupied in the
module area. This reduces the space available to Impression.

You cannot recover these residual areas except by pressing Reset.
To give Impression the maximum possible memory, press Reset
before starting Impression. This removes any unnecessary
programs from the module area.

Cursor going outside the frame

To allow text to go right up to the right edge of a frame, the last
space (or two) on a line of text can be positioned outside the
frame. As spaces don�t show when printing, this has no effect on
the printed result. However to show that the spaces are there (like
all characters they must be editable) it is possible to position the
cursor just outside the frame. This is a deliberate design feature
and so you should not be concerned when the cursor moves
outside the frame in this manner.

My screen isn’t wide enough!

When using a conventional monitor in, for example, mode 12, a
typical A4 Impression document is slightly wider than the
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maximum width of a window. This means that it is not possible to
see a full line-width of text within a window without scrolling it.
There are several solutions to this.

� Scale the view size down to 80% or 90%. This can be done
very easily with the key short cut Shift-F8 or Shift-F9 but has
the disadvantage that the text gets smaller and so less easy to
read.

� Use a multisync monitor. This is the best solution as it can
dramatically improve the appearance of the outline text
while at the same time allowing very much larger amounts of
the document to be seen on screen. It also has the benefit
that higher refresh rate screen modes (less flicker and less
eye-strain) can be used.

16 grey palette

Within the Impression application directory there is a 16 grey
level palette. If this is loaded (by double-clicking on it), it changes
the 16 colour modes to show 16 shades of grey. This gives
scanned images and grey half-tone artwork a more realistic
appearance. This method is no longer recommended.

Sprite files

RISC OS cannot display sprites created in a new screen mode
(that is, a non-Acorn mode) unless the screen extension module
has already been loaded. Use of screen modes that require an
extension module is deprecated.

The one exception is using !Paint to �grab� a part of the screen
area. If this is done while in any new mode, then the sprite is
created with the screen mode number in it. If this sprite is
subsequently put into an Impression document and then that
document is used on a machine that does not know about that
screen mode, the sprite is not correctly displayed.

The same display problem exists in the !Paint and !Draw pro-
grams, neither of which can display such sprites correctly.
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How do I alter my start page ?

Suppose, for example, that you want Impression to always start
up with a standard A4 page, but with a footer line that shows the
page number at the bottom of each page.

Altering the start page is described in 2.16 Customising Impres-
sion. However the actions needed to achieve the required result
are as follows:

1 Click on the Impression icon on the icon bar. This opens the
standard window showing a blank page.

2 Choose View master pages in the View menu to open the
view onto the master page. The window shows the current
master page. Click in the centre of this page to select the
frame. You will probably want to scale the view to 100% by
pressing Shift-F10.

3 Move the bottom edge of the selected frame up a bit to make
room for the footer line - probably no more than 0.7 cm. The
next requirement is to create a new frame along the bottom
of the page. Use New frame in the Frame menu to do this,
making it deep enough to contain one line of text - no more
than 1 cm.

4 Now enter the text to be used for the footer in this newly
created frame. For example, if it is to be centered in italic the
sequence would be something like:

a) Click in the footer frame to select it.

b) Press Ctrl-I followed by F6 and type �Page� followed by a
space.
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c) Choose Insert ⇒ Current page number

After having done this, the footing line should appear in
italics, centered with the <pn> symbol at the end. This <pn>

indicates where the page number will go.

5 Close the master page window by clicking on its Close icon
in the top left corner of the window. Now click in the
original document window - the frames should re-arrange
themselves so that the page number 1 appears at the bottom
of the page.

6 Save the document back as the new default document. Use
Save as default in the Utilities menu.

That�s it. In future whenever you start Impression it will now use
this document as its starting point. Of course you can use this
technique to customise any aspect of the start-up document.

Loading text files

If a text file is dropped over the selected frame with the cursor in
it, the text will be loaded and inserted into the document at the
cursor position. The loaded text therefore takes on the effects and

301 

Appendix 4



styles that are on at the cursor. This can be a very useful feature as
it allows text to be imported into a pre-set style. For example, if
the text is required in italics then simply selecting the italic effect
(press Ctrl-I ) then dropping the text file over the frame will load
this text in italics.

How do I delete a blank page

Edit ⇒ Delete page deletes the page that has the selected frame
on it. As a completely blank page has no frame to select, this
menu option cannot be used. To delete the blank page, first
create a new blank frame on it. You can then delete the page.

The round ‘a’

Sometimes a round �a� is required (especially in education where
children are taught to write the letter �a� in this manner). 

The AvantG font has such an �a� and is available from RISC OS
Developments. It is often included with your copy of Impression.
There are four fonts in the family:

Book    ABCDE abcde 12345

Book oblique   ABCDE abcde 12345

Demi    ABCDE abcde 12345

Demi oblique   ABCDE abcde 12345

These fonts have a rather strange capital �Q�, as you can see.
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RISC OS hints and tips

Select/Adjust clicking

Clicking the right (Adjust) mouse button generally has a different
action to clicking the left (Select) mouse button. This gives rise to
the following effects:

Windows

A Select drag on a title bar moves the window as well as moving
it to the top of the stacking order of windows while an Adjust

drag moves the window but keeps its position in the stacking
order.

Similarly an Adjust drag on the resize icon on a window retains
the order of the window in the stacking arrangement.

Scroll bar

A Select click on a scroll bar arrow scrolls in the direction of the
arrow while an Adjust click scrolls in the opposite direction. This
allows scrolling in both directions from one end of the scroll bar.

A Select click in the blank area of the scroll bar causes a �Page
down� operation while an Adjust click causes the opposite �Page
up�.

Menu options

A Select click on menu options chooses that menu option and
removes the menu while Adjust will keep the menu up if it is
appropriate. Useful when applying effects.

Impression

A Select click on Action buttons in Impression causes the action
to be carried out and the dialogue to be removed from screen
while an Adjust click causes the dialogue to remain up. The best
example of this is the Style Editor. This means that changes can be
made and seen on screen whilst still keeping the editor up to
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make any new adjustments.

A Select drag on graphics frame handles performs a clipping
operation while an Adjust drag performs a resize operation. 

Directory window

A Select click on the Close icon of a directory window closes the
window while an Adjust click also opens the parent directory if
one is present.

A Select click on a directory in a directory window opens the new
directory viewer while an Adjust click also closes the parent
window. This is useful in trying to avoid a Desktop cluttered with
many directory viewers.

Double-clicking on an application in a filer window with the
Select button runs the application while use of the Adjust button
also removes the directory window from the screen.

Looking inside an application directory

Pressing the Shift key whilst double-clicking on a RISC OS
application, such as the Impression !Publisher icon, opens a
directory viewer of what is in the application.

Clearing an editable field

Pressing Ctrl-U when in an editable field wipes the entire field.
This is useful when entering a new filename or document name
to be saved out.

RISC OS applications

Any applications which are seen by RISC OS for the first time
have their !Boot file run. Normally this sets up variables associated
with the application such as file types and run actions for when
the application�s files are clicked on but also it loads any
associated icons. In the worst case, if all RISC OS applications are
situated in one directory, then on first viewing of this, there is a
long pause whilst this setting up takes place but a large amount of
memory can be taken up for the sprite definitions. The worst
possible case is a hard disc with all of the applications in the root
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directory. This means that memory is permanently lost instead of
only being lost when the directory is viewed. The suggested
approach is to split any applications logically into a number of
sub-directories or over a number of discs on a floppy disc
machine. 

Printing

Most RISC OS printer drivers make use of the system sprite space
for a work area. When printing is initiated, the driver grabs as
much free memory as it needs, usually all on a 1MByte machine,
and allocates it to the system sprite area. It uses this area to build
up the image to be printed in strips. Once printing is complete it
then releases this memory back to the free area. 

One effect of this grabbing of free memory does mean that even if
the fontmax configuration has been set correctly, then on
machines which do not have enough memory for a full image as
well as some extra, no memory is available to increase this cache.
As printing uses the fonts at the resolution of the printer, which is
normally much greater than screen resolution, a larger font cache
is needed. Therefore, it is suggested that once the printer driver
has been loaded and before printing, the memory is optimised by:

� When using the normal printing mode, as opposed to the
character printing mode, the printer driver icon on the icon
bar is no longer needed and thus can be removed by
choosing the Quit option when the Menu button is pressed
on the icon. This leaves the printer driver module in memory
which is all that is needed.

� Changing to a lower resolution screen mode, e.g the four or
even two colour modes. The mode which gives most
memory is mode 0. For mode 20 use mode 19 or 18, whereas
for mode 12 use mode 11. As the screen resolution plays no
part in printing this means that more memory can be allo-
cated to such items as the font cache or strip size (via the free
memory).

� Once optimised, use the task manager to drag the font cache
to a more reasonable size for printing. A rule of thumb might
be to use double the allocation that you normally use for
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normal screen resolution cacheing. Allow a reasonable
amount of memory free for the strip size but the font cache is
more important. Another rule of thumb might be to allocate
the memory on a two thirds to the font cache, one third to
the strip size basis. An example of a suggested allocation
might be:

With 200KB of memory available to divide between the font
cache/strip size then it is suggested that about 150KB is used
for a font cache and the remainder left for the strip size.

Note that if you are using LaserDirect printer or TurboDriver
software, you do not need to alter the font cache size. The
printer�s software automatically makes any required adjustments.

The System folder

In-memory transfer is achieved via a file, Scrapfile, which
normally resides in the !System directory. A system variable,
Wimp$Scrap, controls where this file resides. Users of single
floppy machines may find it useful to either have the !System on
their work disc or set up the system variable to point to their work
disc to try and cut down on disc swopping.
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Appendix 5: Font samples &

Character Sets

Font samples

These are samples of the text fonts supplied with the Impression
package. The Character font is not shown (see 2.3 Text handling
for further information on this font).

Additional fonts are available from your supplier and other
companies in particular Electronic Font Foundry (EFF).

Corpus:
bold ABCDEF abcdef 123456

bold oblique ABCDEF abcdef 123456

medium ABCDEF abcdef 123456

medium oblique ABCDEF abcdef 123456

Homerton:
bold ABCDEF abcdef 123456
bold oblique ABCDEF abcdef 123456
medium ABCDEF abcdef 123456
medium oblique ABCDEF abcdef 123456

Pembroke:

Trinity:
bold ABCDEF abcdef 123456

bold italic ABCDEF abcdef 123456

medium ABCDEF abcdef 123456
medium italic ABCDEF abcdef 123456
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The character set

All of the characters displayed here are accessible from the keyboard. Those with
codes greater than 127 can be typed by holding down one of the Alt keys and
typing the character code on the keypad.

Codes 127-142 are undefined in RISC OS. Code 160 is a non-breakable space which
is useful when you have two words which you want to keep together. Impression
will not split at a non-breakable space.

32  60 < 88 X 116 t 144 ‘ 172 ¬ 200 È 228 ä
33 ! 61 = 89 Y 117 u 145 ’ 173 ­ 201 É 229 å
34 " 62 > 90 Z 118 v 146 ‹ 174 ® 202 Ê 230 æ
35 # 63 ? 91 [ 119 w 147 › 175 ¯ 203 Ë 231 ç
36 $ 64 @ 92 \ 120 x 148 “ 176 ° 204 Ì 232 è
37 % 65 A 93 ] 121 y 149 ” 177 ± 205 Í 233 é
38 & 66 B 94 ^ 122 z 150 „ 178 ² 206 Î 234 ê
39 ' 67 C 95 _ 123 { 151 – 179 ³ 207 Ï 235 ë
40 ( 68 D 96 ` 124 | 152 — 180 ´ 208 Ð 236 ì
41 ) 69 E 97 a 125 } 153 − 181 µ 209 Ñ 237 í
42 * 70 F 98 b 126 ~ 154 Œ 182 ¶ 210 Ò 238 î
43 + 71 G 99 c 127 155 œ 183 · 211 Ó 239 ï
44 , 72 H 100 d 128 € 156 † 184 ¸ 212 Ô 240 ð
45 - 73 I 101 e 129 Ŵ 157 ‡ 185 ¹ 213 Õ 241 ñ
46 . 74 J 102 f 130 ŵ 158 fi 186 º 214 Ö 242 ò
47 / 75 K 103 g 131 � 159 fl 187 » 215 × 243 ó
48 0 76 L 104 h 132 � 160  188 ¼ 216 Ø 244 ô
49 1 77 M 105 i 133 Ŷ 161 ¡ 189 ½ 217 Ù 245 õ
50 2 78 N 106 j 134 ŷ 162 ¢ 190 ¾ 218 Ú 246 ö
51 3 79 O 107 k 135 � 163 £ 191 ¿ 219 Û 247 ÷
52 4 80 P 108 l 136 � 164 ¤ 192 À 220 Ü 248 ø
53 5 81 Q 109 m 137 � 165 ¥ 193 Á 221 Ý 249 ù
54 6 82 R 110 n 138 � 166 ¦ 194 Â 222 Þ 250 ú
55 7 83 S 111 o 139 � 167 § 195 Ã 223 ß 251 û
56 8 84 T 112 p 140 … 168 ¨ 196 Ä 224 à 252 ü
57 9 85 U 113 q 141 ™ 169 © 197 Å 225 á 253 ý
58 : 86 V 114 r 142 ‰ 170 ª 198 Æ 226 â 254 þ
59 ; 87 W 115 s 143 • 171 « 199 Ç 227 ã 255 ÿ
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The Selwyn font (also known as Dingbats)

To select a character, select the Selwyn font, hold down Alt and type its decimal
number on the keypad.

32    60 , 88 X 116 t 144   � 172 ¬ 200 È 228    ä
33 ! 61 = 89 Y 117 u 145 � 173 ­ 201 É 229 å
34 " 62 > 90 Z 118 v 146 � 174 ® 202 Ê 230 æ
35 # 63 ? 91 [ 119 w 147 � 175 ¯ 203 Ë 231 ç
36 $ 64 @ 92 \ 120 x 148 � 176 ° 204 Ì 232 è
37 % 65 A 93 ] 121 y 149 � 177 ± 205 Í 233 é
38 & 66 B 94 ^ 122 z 150 � 178 ² 206 Î 234 ê
39 � 67 C 95 _ 123 { 151 � 179 ° 207 Ï 235 ë
40 ( 68 D 96 ` 124 | 152 � 180 ´ 208 Ð 236 ì
41 ) 69 E 97 a 125 } 153 � 181 µ 209 Ñ 237 í
42 * 70 F 98 b 126 ~ 154 � 182 ¶ 210 Ò 238 î
43 + 71 G 99 c 127 155 � 183 · 211 Ó 239 ï
44 , 72 H 100 d 128 � 156 � 184 ¸ 212 Ô 240 ð
45 - 73 I 101 e 129 � � 157 � 185 ¹ 213 Õ 241 ñ
46 . 74 J 102 f 130 � � 158 � 186 º 214 Ö 242 ò
47 / 75 K 103 g 131 � � 159 � 187 » 215 × 243 ó
48 0 76 L 104 h 132 � � 160   188 ¼ 216 Ø 244 ô
49 1 77 M 105 i 133 � � 161 ¡ 189 ½ 217 Ù 245 õ
50 2 78 N 106 j 134 � � 162 ¢ 190 ¾ 218 Ú 246 ö
51 3 79 O 107 k 135 � 163 £ 191 ¿ 219 Û 247   ÷
52 4 80 P 108 l 136 � � 164 ¤ 192 À 220 Ü 248 ø
53 5 81 Q 109 m 137 � 165 ¥ 193 Á 221 Ý 249 ù
54 6 82 R 110 n 138 � 166 ¦ 194 Â 222 Þ 250 ú
55 7 83 S 111 o 139 � 167 § 195 Ã 223 ß 251 û
56 8 84 T 112 p 140 � 168 ¨ 196 Ä 224 à 252 ü
57 9 85 U 113 q 141 � 169 © 197 Å 225 á 253 ý
58 : 86 V 114 r 142 � 170 ª 198 Æ 226 â 254 þ
59 ; 87 W 115 s 143 � 171 « 199 Ç 227 ã 255 ÿ
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The Greek font

Supplied with Impression is a specially designed Greek character set containing the
whole Greek alphabet.

Another, similar font is MathGreek supplied with EasiWriter offering very similar
characters.
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Appendix 6: Borders
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Appendix 7: Printers, PDFs &

Commercial Printing

General notes

There is a vast range of printers that can work with Acorn
computers. In many cases you get satisfactory results even if the
printer drivers are not set up exactly. Because Impression prints
an exact copy of what is on the screen, printer set-up can be more
important. This appendix details some of the common problems
encountered and their solution.

Details of Draft mode printing are included but this method is
obsolete.  This lets you use the in-built character set of the printer
to speed up the printing of text on older systems.

Setting-up your printer driver

Refer to the User Guide supplied with your computer for details of
setting up your printer.

Page size

Some users are confused about the page size when printing.

The page size in Impression is set quite independently of the
paper size used in the printer. The printer driver should be set up
to have the correct size of paper to match the paper which is
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being used in the printer. Usually this is the same as the page size
defined in Impression but in some cases they may be different.
The best example is an A5 document in Impression and printing
this out on A4 paper as two A5 pages side by side.

By default Impression starts with an A4 page. Many printers can
use this paper size.

Traditional fan-fold paper is 11 inches long, which is shorter than
A4. To use this size paper check that:

1 The dip-switches in the printer are set for 11 inch paper, with
no perforation skip.

2 The printer driver is set to the correct page size. Refer to the
User guide supplied with the computer for more details.

3 Impression is set to use 11 inch paper. To do this you will
need to create a new master page of the correct dimensions.
Use the Alter Chapter dialogue box to change to this new
master page.

Few printers can print right up to the paper edge, and so it is
sometimes useful to see the extent of the available print area.
View ⇒ Print borders displays this non-printable area. When
selected, Impression draws a light grey border around the edge of
the page on screen. If any objects on the page extend into this
grey area, they are unlikely to be printed.

Note the print borders can only be shown if the printer driver has
been loaded. The print borders are shown on screen for pages
printed upright at 100%. Therefore they do not indicate anything
useful if printing sideways or at a different scale.

Laser printers

Part of the laser printing process briefly exposes the paper to a
high temperature. This causes the paper to wrinkle slightly. Many
manufacturers of laser printers say you should not print on both
sides of the paper unless the printer is specifically sold as a
�duplex� model as this requires a second pass through the printer.
(Technically, this is called duplex or double-sided printing.)

We have used laser printers for double-sided printing, generally
without problems. However, the paper does tends to jam or
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misfeed occasionally. Our advice is that double-sided printing is
possible but don�t be surprised if you have the odd issue.

Dot Matrix printers

Using 24-pin printers (RISC OS 2)

You may find a problem if you have an Epson-compatible 24-Pin
printer. The default setting of the printer driver is to treat the
printer as 9-pin FX-compatible. When a 24-pin printer is driven in
this mode, the resultant document can produce pages that are
over-length.

The solution is to set the printer driver to Epson LQ compatible.
See Setting-up your printer driver for details of changing the
printer type.

Unexpected page throws

You may sometimes get page throws at the end of certain pages
when printing your document. Refer to Page size (earlier in this
appendix).

Hewlett Packard Deskjet printers

Please note that on the DeskJet the landscape printing option for
text printing cannot be used as no character mode landscape
fonts are available. These are available on the DeskJet Plus and
most LaserJet compatibles. This landscape option only applies if
text files are dropped onto the printer driver. 

Also, the DeskJet cannot print multiple copies of the same page.
This is because the printer driver assumes that a copy of the page
is kept in the printer�s internal memory. This is not the case with
the DeskJet. If you want to print several copies, set Collated in the
Print Setup dialogue box; this prints a document as pages
1,2,3..,1,2,3...
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Draft mode printing

Some printers, such as dot matrix, can take several minutes to
print a page using the standard Acorn printer drivers. Draft mode
printing uses the character sets built into the printer. You are
limited to the fonts supplied with the printer and you cannot print
graphics. However, draft mode is a quick way of printing simple
documents. 

This method of printing is now obsolete and is not described

further.

PostScript printers

It can take some time to print graphics and where a quick print-
out is required (for example, when checking a document), you
may find it useful to choose No illustrations. (This is in the Print
Set-up dialogue box.)

Creating PDFs

The rise of the internet and the �paperless office' has seen the
adoption of PDF files as the defacto standard for storing and
sending documents with complex, DTP-style layouts.  It is easy to
use Impression to create PDF files for sending by email etc.  This
is especially important for sending to users of other platforms.

To do this, you'll likely want to avail yourself of one of two
programs that allow you to make PDF files from all RISC OS
programs - either R-Comp's PDF Suite (aka !PDFmaker), or Steve
Fryatt's !PrintPDF.  Both programs are available on !Store which
you can find in your Apps folder on your main drive.

PDF Suite has a very simply setup automated setup procedure so
is probably the best choice for beginners (but you will have to
pay for it).  It is also very friendly in use/operation, but powerful
too. !PrintPDF is free, and contains some sophisticated additions,
so may be better for more technical users. 
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Each program comes with instructions for setup and use.

Once installed, both work in similar ways - you �print� your
documents to PDF.  Essentially, the programs integrate with the
normal RISC OS printer drivers (exactly as if you were printing to
paper in a printer, as discussed earlier) to allow you to �print to�
PDF output files which you can then save, preview, email etc.

Tips

When creating the PDF version of this manual, we used software
that provides level 3 Postscript output and then used a utility
provided with that software to convert the Postscript output file to
PDF. These tips apply equally to PDFMaker and PrintPDF.

We noticed a few things which may help you produce great
looking PDFs from your documents...

1)  Some fonts are handled differently to others.  The basic RISC
OS fonts (Homerton, Trinity, Corpus etc) are �known� typefaces
which the RISC OS printing system will map to typefaces on other
platforms (Helvetica, Times New Roman, Courier etc.).  This can
result in smaller files, and because these fonts are �known�, we
find they look better on screen, both in RISC OS and elsewhere.

Unknown fonts will be converted and embedded in the PDF
document as needed, which is fine for most uses, but the
�known� typefaces will often give the best results when viewed
under RISC OS.
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2)  You can use full colour sprites and JPEGs in Impression, and
whilst they should look OK when printed to paper, the flexibility
of PDF files (ability to scale arbitrarily, and use on other plat-
forms) can make some images look worse than you'd like.

If you happen to own Artworks, you can drop your sprites and
JPEGs into that, and drag-save the resulting Artwork illustration
into Impression (instead of the sprite or JPEG).  Impression will
use Artworks' more advanced colour/print capabilities when the
PDF is created, resulting in better looking images at variable sizes.

3)  There is another program which integrates with both
!PDFmaker and !PrintPDF called �PostScript 3 drivers� by MW
Software.  This is also included in the �Pro� edition of PDF Suite.

PDF files are essentially compressed PostScript, and this program
replaces the RISC OS printing system's PostScript driver with a
more advanced implementation.  All fonts are converted with
high quality routines, and it has better handling of fills, clipped
images and bitmaps (it is by the Artworks authors).  This can help
bypass both the issues mentioned above, but isn't essential.

4)  If you print a document which contains A5 pages with the
printer driver set up to expect A4 paper then the postscript and
PDF file produced will have the content centred on an A4 page.
The resulting PDF can be reprinted with a magnification of 142%
to produce A4 pages with the content filling the page. 

Alternatively it can be load into a PDF editor and cropped to
reduce the page size to the intended A5.

If the page size of the document is A3 and the paper size in the
printer driver is A4 then you will be asked whether to proceed
with the printer driver cropping the area outside the bounds of
the paper size given. This does not usually give predictable
results.

5)  If you want to produce a PDF document that contains a font
that is available on another computer platform but not on RISC
OS then it is possible to convert a True-Type font into an equiva-
lent RISC OS font using a convertor such as TTF2f.
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If an Impression file contains fonts that are not present on the
computer then they will be substituted on loading but full
information on the fonts as originally specified will be retained on
saving. Re-loading the document on a machine where the fonts
are present, will show them correctly.

Font usage

If you load documents or graphics that were created on another
computer, the fonts used may not be present on your computer.
Especially in the case of graphics, the missing fonts may not be
noticeable. Use the menu option (Utilities ⇒ Compile font usage)
to display the fonts specified in the document and its images. Any
font which has been substituted on this computer will be marked
with an asterisk (*).  

Commercial Printing

Whilst the technology of printing has advanced enormously,
commercial printing has become simpler in many ways. Large
print runs (more than a hundred) may use lithography (where a
printing plate is prepared) but print on demand is now available
for single copies. In both cases the printer will work directly from
PDF files that contain high resolution images.

The days of providing crop marks and colour separations and
using camera-ready artwork have gone. Checking your document
can be done by examining the pre-press PDF file.

Using MW-Software�s Level 3 Postscript printer driver to produce
PDF files from an Impression document is usually sufficient for
both black and white and colour reproduction.

PDFs with embedded RGB JPEG files are usually tolerated by
printers although the RGB colour space does not describe pinks
and pale blues adequately. Much finer control of pale tints is
available in the CMYK colour model.

Producing a vector graphic file by importing a Draw file into
ArtWorks and exporting as ArtWorks or as PDF will automatically
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convert any RGB vector graphics into an equivalent CMY process
colour using the slightly flawed formula below:

The correct formula (using a linear colour correction table) is as
given below:

This avoids ink saturation by removing the �blackness� achieved
by an equal mix of each process colour and using black instead.
Adding a small amount of each process colour can make blacks
richer. Reducing the amount of cyan can make the printed colour
look more like how it appeared on the screen but colour printing
is a rather specialist subject.

ArtWorks allows a colour table to be exported, edited in a simple
text editor and reimported back if you need to make fine colour
adjustments before importing the ArtWorks file into Impression.

Colour correction tables are provided for a few devices and these
may be used, see pages 69, 74, 75, 266 and 273. A utility to edit
such correction tables, SepEd2, was produced but is probably no
longer necessary.
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r = R
255 ;  g = G

255 ; b = B
255

K = 1 − max (r, g, b)

C = 1 − r − K
1 − K

M =
1 − g − K

1 − K

Y = 1 − b − K
1 − K

r = R
255 ;  g = G

255 ; b = B
255

K = 0
C = 1 − r

M = 1 − g

Y = 1 − b



Appendix 8: Loading alien file

formats

One of the perennial problems in computing is compatibility.
There are any number of software products on the market but the
chances of one product understanding files created by another
are slim.

Impression overcomes this problem by using loader modules -
small programs loaded into Impression which convert from �alien�
text formats into a format that Impression can understand.

Loading Loader Modules

A Loader module is loaded into Impression simply by double-
clicking on its icon in a filer window. You cannot load the same
module more than once.

Converting a file

After loading an appropriate module, you can load files by
dropping them onto an Impression window. The contents of the
file are converted into Impression format.
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Automatically loading modules

Loader modules can be automatically loaded by Impression when
it starts up (described in 2.16 Customising Impression). This is
useful if you frequently want to load files from another source. 

Note:

The CSV and PipeDream loaders require some working disc
space. This means you cannot use them if the requested disc is
almost full. To see the available space on a disc, click Menu on
the disc icon on the icon bar. This displays a small menu; click on
Free on that menu to display the free and used space on the disc.

Text files

You can always load text files and Impression format files. You
do not need a special loader.

LoadASCII – Dummy loader

This loader is useful only if you have several loaders in Impres-
sion�s Auto directory. Without this loader, if you drop a plain text
file onto Impression, each loader asks if you want it to convert the
file. LoadASCII is the first loader checked and, optionally, loads a
plain text file without modification. To use it, copy it into the Auto
directory.

Important:

LoadASCII is alphabetically the first loader and so is the first
loader checked when run. Do not rename it or rename any of the
other loaders so as to change the alphabetic order.

LoadBasic – Basic file loader

There are no known problems with these files.

LoadC – C source file loader

Both C language files and Impression�s internal format make use
of �curly brackets� ({ }). This loader reads in C files and correctly
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formats any such curly brackets.

LoadCSV – CSV loader 1

CSV files are often produced by spreadsheet programs and use
commas (,) to separate a line of variables. This loader converts
commas into Tab characters to restore the formatting into
columns by generating any necessary Rulers.

LoadCSV+ – CSV loader 2

Use this loader instead of LoadCSV for CSV files that include
tables or boxes. When the file is read, a horizontal line (rule-off)
is drawn above each line of text and a vertical line (or rule)
between each field. (In CSV files, a comma marks the end of each
field.)

The last line should terminate with a Return; this ensures that a
line is drawn under the text.

Two examples of its use

The basic CSV file (part of a PipeDream example file):
�Car Lovers Ltd�
�Company fleet�
,,�Value�,�Cpcity�,�Cyls�,�Reg�
�Porsche Carrera RS�,,30,2700,6,�RS 27�
�AC Cobra Mk II�,,90,4700,8,�289 COB�

which, when loaded into Impression using LoadCSV+, looks like
this:

Car Lovers Ltd

Company fleet

Value Cpcity Cyls Reg

Porsche Carrera RS 30 2700 6 RS 27

AC Cobra Mk II 90 4700 8 289 COB

A second example simply encloses text in boxes. The basic CSV
file looks like this:

a box
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and, when loaded into Impression using LoadCSV+:

a box

Remember the Return after box.

LoadDTP – Acorn DTP loader

This loader can only handle text from Acorn DTP files and not
graphics. There are no known problems with these files.

LoadFWP – FirstWord Plus text file loader

The loader can only handle text from FirstWord Plus and not
graphics.

Some very early versions of FirstWord Plus on the Archimedes did
not set the file types. If you have to set the file type use the
*SETTYPE command. Press F12 and type

*settype :0.fred AF8 

assuming your file is called fred and it is on drive 0.

LoadIWord – Inter-Word loader

Files from the BBC versions of InterWord do not set the file types.
If you have to set the file type use the *SETTYPE command. Press
F12 and type

*settype :0.fred D80

assuming your file is called fred and it is on drive 0.

If this is not done, the text will include many incorrect characters.

LoadPDream – PipeDream 3 loader

Because Impression and PipeDream use completely different
ways of storing text and the information about it, it is not possible
to get totally correct automatic translation between the two
formats. However, this loader module significantly reduces the
work required to transfer PipeDream files to Impression.

There are some things this loader cannot cope with; these are
listed below.

LoadPDream cannot cope with:
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� Graphic files incorporated into files.

� Printer driver constructs.

� Colour constructs.

� The following commands are not supported;

� Option Constructs (%OP%parameter value),

�  leading and trailing character format,

� Slot is a number slot,

� formulae - no calculations are done.

This loader maintains the appearance of multiple column text by
using Tabs to format the text across a single frame. This means
that later editing of the text in Impression will be difficult.

LoadPDream should accurately represent all the other commands
of Pipedream.

PipeDream files from the Z88 and the PC

The PipeDream manual describes how to transfer files into the
Archimedes. Archimedes files contain filetype information and
files imported in this way will have the wrong filetype set. To
correct this, use the *SETTYPE command. Press F12 and enter
the command

*settype :0.fred DDE

assuming your file is called fred and is on drive 0.

LoadReturn – Return stripper

The return stripper module takes Returns and LineFeeds out of
text from packages such as PipeDream so that the text is con-
tinuous when imported into Impression, and not �jagged� as
happens when the text is just loaded straight in.
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An example of a file without LoadReturn:

LoadReturn loader

-------------------------

The Impression �loadermodule� LoadReturn will

strip out unwanted Return and Line Feed codes

from documents.

Any filetype will be processed by this loader

module making it very general purpose.

And with:

LoadReturn loader
-------------------------
The Impression �loadermodule� LoadReturn will strip out unwanted
Return and Line Feed codes from documents.
Any filetype will be processed by this loader module making it very
general purpose.
The stripper follows these rules:
   1. any Returns or LineFeeds on their own will be stripped,
   2. if more than one LineFeed or Return follow each other, then n-1
are stripped where n is the total number of consecutive Returns or
LineFeeds,
   3. a Return followed by a LineFeed is treated as a single Return
character,

There are many ways in which text can be formatted just with
Returns (code 13) and LineFeeds (code 10). Therefore the stripper
follows these rules:

1. any Returns or LineFeeds on their own will be stripped,

2. a series of consecutive Returns is replaced by a single
Return,

3 a series of consecutive LineFeeds is replaced by a single
LineFeed,

4. Return-LineFeed is treated as a single Return character,

 326 Impression Manual

Impression PublisherLoading alien file formats



5. if there is no space before a Return or LineFeed, one is put
in.

Rule 4 implies that Return-LineFeed-Return-LineFeed becomes a
single Return (from rule 2).

The stripper translates files of any type. This could lead to
unexpected results if correctly formatted files are dropped onto a
frame after the module is loaded. Use the Modules dialogue box
in Preferences on the Icon Bar Menu to remove LoadReturn. (See
2.16 Customising Impression for details.)

LoadRTF – Rich Text Format (RTF) loader

RTF is a standard way of transferring files between systems. Most
programs on the Macintosh can load and save in RTF format, as
can a fair number on the PC.

What is converted

Only file types data, text, or pcdata are converted by the RTF
loader. Other file types are ignored.

Most features of RTF directly map to Impression format, but there
are a few differences. These are summarised below:

� Any ruler effects are turned into Impression styles and rulers.

� The following commands are not implemented:
�  document information,
�  colour information,
�  paper width, height, margins,
�  headers and footers,
�  page numbers,
�  top, left and right borders (see note),
  �  shadowed and double borders are the same as thick

borders (see note),
�  super/subscripts are of a fixed displacement,
�  pictures (bit-map and include pictures) are ignored.

Note:
These features can only be imported if they are RTF styles; if
they are RTF effects, then they cannot be imported.
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Transferring RTF files to the Archimedes

Unless both machines are connected by a network, transfer files
using PC format floppy discs. (If you have RISC OS 2 you require
a suitable program to read PC format discs).

Word for DOS

One of the Word discs contains a converter program to output
RTF. (Only recent versions of Word include this converter; if you
have an older version, contact Microsoft about upgrading.)

Word for Windows

You can select RTF format in the Save as: dialogue box. The name
you save it as can be up to six characters long, plus (optionally)
an extension of .RTF (for example, FILE.RTF). 

Word on the Macintosh

Again you can select RTF as a save format. Most current Macin-
toshs can write to DOS format discs. 

LoadView – View file loader

There are no known problems with these files.

LoadWP42 – WordPerfect loader

The WordPerfect loader converts version 4.2 or earlier. The
loader converts all WordPerfect text effects into Impression
effects. All commands ar implemented except:

� hyphenation �hotzone�,
� page numbers,
� headers and footers,
� pitch/font changes,
� printer specific commands,
� columns,
� date/time functions.
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LoadWStar – WordStar loader

The WordStar loader converts versions 2.2x to 4.0. (MicroPro �
the developers of WordStar � will not release the file format of
later versions.) If you have WordStar 5.0 or WordStar Professional,
you can use the WordPerfect option in Star exchange to output
the data in WordPerfect format. You can then use LoadWP42 to
load the file into Impression.

Only these options are implemented:

� type styles:
� italic,
� bold,
� underline,
� subscript,
� superscript,

� full justification.

Wordwise Plus files

To use Wordwise plus files in Impression you must first remove
any embedded commands and change the character denoting
Tab.

1 Load the file into Wordwise Plus.

2 If any tabs are used then do a search and replace specifying
|T for the search string and |I for the replace string. The |
symbol is the broken vertical bar found on the \ key in the
top right of the main keyboard. 

3 Press Esc to go into the editor. Find and delete all embedded
commands.

4 Save out the file under a new file name.

5 Load this file into Impression as plain text.
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Appendix 9: History of Impression

Impression was first released in December 1989. Version 1.05
became Impression Junior in October 1990 when Impression II
was released. This developed to version 2.18 as features such as
crop marks, vertical rules and compatibility with RISC OS 3 and
ArtWorks were added. During 1994 Impression was made
available in three forms:

� Impression Style version 3.01 (March 1994)

� Impression Publisher version 4.01 (July 1994)

� Impression Publisher Plus version 5.01  (December 1994).  

These were developed in parallel, made StrongARM compatible
and reached version x.13 by 10 December 1996.

All three offered named styles which could be applied to blocks
of text and could be nested and/or overlapped. Each chapter had
a master page giving default page size and frame and column
layout. An effects menu was provided for localised application of
a style. Graphics could be panned, cropped and rotated within
their frame using the mouse. An interactive toolbar made the
software easy and intuitive. Object linking was provided so that
graphics and tables could be edited externally, in the application
in which they had been created, and simply saved back into the
document. Large documents were now handled correctly on
machines with large amounts of RAM (i.e. with more than
20Mbytes of RAM).

Publisher offered some evolutionary advances: improved
typographical controls and graphics handling; frames could now
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be an irregular shape, not just rectangular.

Publisher Plus added the Open Pre- Press Interface (OPI) to allow
low resolution images in the document to be replaced by high
resolution images when commercially printed; support for named
colours; a word count utility and offset for the page origin.

These versions remained backwards compatible so that a
document saved in version 3.xx could be loaded in version 4.xx
or 5.xx but not vice versa. By December 1994 there were over
30,000 users of Impression. Version 5.13 was the last version
released by Computer Concepts.

In the period from 1996 to 2014, Acorn broke up (1998), RISC OS
was developed from 3.60 to 4.04, 4.39, Six and now 5.26 and runs
on many new platforms. Conversion to 32-bit safe started in 2003
by X-Ample Technology and the forthcoming product was named
Impression-X. Conversion proved difficult and it still remains
partially 26-bit and requires Aemulor to run on modern hardware.

Further development by  Richard Keefe led to version 5.75 being
released on 24 October 2014. This added dynamic areas and
artworks integration with all features of Publisher Plus included. It
took forward the source as it was prior to implementation of
about 800 of the bug fixes in version x.13. Although the nature of
the bug fixes had survived, the actual fix had not, so these are
being re-engineered in parallel.

By version 5.78 (28 October 2017), longer (14 character)
filenames, mapping of font names on import, direct JPEG import,
scaling of images down to 1%, allowing higher resolution images
to be used and configurable action of the DELETE key (PC style
or Acorn style) had been added as well as many of the outstand-
ing bug fixes.

In August 2019, RISC OS Developments was given overall
ownership of the Impression family, and intend to encourage
future development. One of their first steps was to commission
(and assist with) the updating of this manual.

The latest version is 5.799 (6 March 2020).
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Appendix 10: Document description

file (DDF)

Impression supports the loading and saving of multi-font text in a
simple ASCII format, called �DDF� or �Document Description
File� format. Changes in font, colour, underline, etc are stored as
command strings and this means that the tagged files can be
edited or even originated in simple text editors. Furthermore the
ASCII character set used in DDF files is the seven bit character set
(no ASCII codes greater than 127 are used) so that it is easy to
export tagged files to other systems via modems. The text story in
a single frame can be saved using the �With styles� option the save
window to save a file in DDF format, including style information.

All characters in the ASCII range 32-126 are recognised, except for
open curly bracket (character 123), which marks the start of a
special command. These commands are used to store style
changes, characters from 0-31 and 128-255 and other things.

Only basic details of DDF are given here as the full specification
is complicated and of little use to most users. For a complete
specification, contact your supplier quoting the software version
number of your copy of Impression. It would allow the contents
of a frame to be generated programmatically, for example. The
simplest way to work out what the DDF file would need to
contain, is to generate the desired formatting in the usual way and
then save the text story with styles included. This can then be
edited to locate tab stops etc. precisely. 
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Basic DDF commands

Style changes

A style change is stored in the form:

{"Style name" on}some text{"Style name" off}

A Style on code must be followed by a Style off code, otherwise
the style will be on for the duration of the document.

Effects

An effect change is stored in a similar way to the style change
except that turning on a new effect cancels any previous effect
that sets the same attribute. To turn an effect on, the effect
command takes a parameter and to turn it off, the command is
given with no parameter. For example:

{fontsize 15pt} This is 15pt{fontsize 6pt}This is
6pt{fontsize}This is back to default.

Tabs

A Tab is stored as: {tab}

ASCII character 9 is also recognised as a Tab.

Returns

A Return is stored as character 13. {cr} is also recognised as
return. Linefeeds (character 10) are converted to Returns.

Top bit set characters

Characters in the range 128-255 are stored as: {\n } where n is the
character code.

Star, Hash and At

When DDF is used in the search dialogue the star (*), hash (#)
and at (@) characters represent wildcards and so the DDF
commands {star}, {hash} and {at} are supplied to make it easier
to search for these characters.

Force to next frame

A force to next frame is stored as: {nextframe}
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Including curly brackets

If your document needs to include the open curly brackets
symbol, use {\123}.

Kern commands

Kern commands specify both the x and y movements to be
applied to the following text. The values given are measured in
1000ths of an em as in the kern dialogue box.

Example: {kern 120 -80}

Page and chapter numbers

Page number and chapter number commands both have optional
parameters describing the way in which the page number is
shown. If the parameter is not present then the number will be
displayed in numeric form. The possible parameters are decimal,
romanlower and romanupper for numeric, lower-case roman
numerals and upper-case roman numerals respectively.

Examples: {pagenumber romanlower}

{chapternumber decimal}

{pagenumber}

Soft hyphens

Soft, or discretionary, hyphens are stored as {softhyphen}

Style definitions

Styles can be defined from within DDF using the {define style ...}
command. This command is slightly different from the other
commands in that it doesn�t insert anything into the text. The style
definition can describe every attribute of a style from its name
right down to whether it appears on the style menu. The attrib-
utes are identified by DDF keywords which are usually followed
by parameters and are separated by semicolons. Style definition
commands can occur anywhere in the text except that you must
define a style before using it.

Measure

A measurement of some size which can be specified in points,
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picas, inches, centimetres, etc. exactly as they would be entered
into dialogue boxes.

Smart quotes

When text is loaded into Impression, it often contains quotation
marks. These are normally �sexless� quotes, being neither opening
nor closing marks. However, in most fonts there are different
symbols for opening and closing quotes, so when loading in an
ASCII file, Impression will attempt to convert normal quotes into
the correct type, according to the rules of English. The difference
smart quotes make, especially when printed at a high resolution,
is often surprising. There may be some extremely rare occasions
when the code will mistake an apostrophe for a closing quote,
but on the whole, it converts correctly.
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Appendix 11: Glossary

Ascii Stands for the American Standard Code for Information
Interchange. Usually refers to the range of alpha-numeric
characters which make up plain text files.

Adjust The right hand mouse button.

Anti-aliasing A graphical technique which uses shades of grey to �smudge� the
edges of images on screen, used to improve the readability of text.

Baseline The invisible line upon which the bases of most characters rest.
Character descenders usually drop below the baseline.

Bit-image A graphic image described in terms of the individual pixels which
make it up, in the same way as a television picture or a newspaper
photograph is made up of individual dots.

Bold text Text shown in a heavy, thick, form like this: bold text.

Bullet A bold dot (�), often used to mark or highlight words and phrases
in some text.

Caret A vertical cursor shaped like a capital �I�. Impression uses two
carets, which we refer to as the text cursor and the mouse pointer.
See Cursor.

Case The form of letters, be they upper case (capitals) or lower case
(small letters).

Centered text Lines of text arranged on a text frame so that the beginning and
end of each line are equidistant from the their respective margins.

Chapter A self-contained section of a document. All pages in a chapter are
based on the same master page, but different chapters can be
based on different master pages. Also, page numbering can either
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be continuous (following from the last page in the previous
chapter) or start from a defined page number. Chapters other than
the one currently being edited may be saved out to disc if Impres-
sion runs low on memory.

Character Any printable number, letter, or symbol.

Clipboard A temporary store for sections of text or graphics frames which
may have been deleted or cut. An item stored on the clipboard can
be �pasted� back to a selected area of a document.

Close icon One of the small icons in the title bar of certain windows. Clicking
in it closes the window.

Context sensitive Something is context sensitive if it changes depending on
the context of its use. Many context sensitive menu options
change their wording depending on, for example, the currently
selected item.

Copy Part of cut/copy/paste. Copies a selected region of text, or a frame,
to the clipboard, but unlike cut it does not delete the original.
Items copied to the clipboard can be recalled later by using Paste.

Cursor An indication of the current position in the text. It appears as a
vertical bar. Any characters that are typed appear at the cursor
position.

Cut Part of cut/copy/paste. Copies a selected region of text, or a frame,
to the clipboard and deletes the original. Items cut to the clipboard
can be recalled later by using Paste.

Decimal tab A tab stop which determines the position of a decimal point in a
piece of text. This is useful for aligning columns of figures.

Default The condition of a feature as set by the computer or Impression at
the beginning of a new session.

Dialogue box A window containing various buttons, switches and editable fields
which allows the user to control various facets of a program.

Double-click The action of clicking the mouse button twice in succession over a
particular icon or part of a window. Double-clicks are often used
to initiate some kind of action, such as starting an application.
Double-clicking in Impression text highlights the word at the
pointer.
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dpi Stands for Dots Per Inch. Usually used to describe the resolution
of a particular display device, such as a printer.

Drag The process of moving icons, windows, or the text cursor when
selecting text. Whilst dragging, a mouse button is held down as
the mouse is moved.

Draw objects Line art objects compatible with the display mechanism of Acorn
Draw. See �Line art�.

Effects See Style effect.

Em A measure of width, equivalent to the point size of an M character
in the font currently in use.

Extension loader module   See Loader module.

Extension saver module    See Saver module.

Facing pages When the pages on the current master page are arranged in pairs,
allowing a different layout on left and right hand pages.

Family A family of fonts all having similar characteristics to one another.
For example, Trinity.Medium, Trinity.Bold, Trinity.Medium.Italic

and Trinity.Bold.Italic are all part of the Trinity font family.

Filer The program that controls the filing systems on RISC OS, notably
the windows displaying disc files.

1st line margin The margin which determines the horizontal position of the first
line in a paragraph. This can be changed to produce a hanging
indent for example.

Font The term used for a particular design of character set. For
example, Trinity.Medium and Trinity.Bold are two different
fonts, although they belong to the same family. Homerton,
Trinity and Corpus are actually slight variations of the classic fonts
Helvetica, Times-Roman, and Courier respectively.

Font cache An area of memory used to store the screen representations of
fonts at different sizes. The size of the font cache can be adjusted
using the RISC OS Task manager. Using a small font cache may
cause Impression to run slowly as it continually has to look at the
disc when displaying text, rather than having the characters stored
in the cache.

339 

Appendix 11



Footer A line at the bottom of each page which usually contains chapter
references or page numbers.

Format The arrangement of a page according to its set parameters. These
could include margins, justification, dimensions, etc.

Frame A rectangle in which text can be entered, or graphics can be
displayed.

Frame handles See Handles.

Graphic A picture.

Graphic frame A frame containing a graphic. Graphic frames can be re-sized by
dragging their frame handles, which either leaves the graphic
image alone (if the handles are dragged using Select) or re-sizes
the graphic along with the frame (if they are dragged with Adjust).

Guide frame A type of frame which aids the positioning of normal frames.
When the Snap to guides option is selected, the edges of new
frames will be �attracted� to the edges of any guide frames. Guide
frames are often useful when creating a magazine-type layout.
(Not in !Style.)

Guttering The space added to the right margin on a left-hand page, and the
left margin on a right hand page to allow for binding with facing
pages.

Handles Small squares found on the corners and sides of a selected frame.
The handles are used for adjusting the size of that frame. 

Hanging indent Where the first line of a paragraph has a different left margin from
the rest of the paragraph, and so �hangs� outside the paragraph.

Hard disc A sealed unit containing a rigid disc spinning very fast, which can
store a large amount of information, and retrieve it at very high
speeds.

Hard space A space in a line of text which is not affected by formatting or
justification. The code for a hard space is code 160.

Header A line of text at the top of each page � similar to a footer.

Highlight Selected text, displayed by inverting its displayed colour. Normally
this is white text on a black background. Impression also inverts
highlighted coloured text.
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Hyphenation The process of splitting words with hyphens. Impression
hyphenates words which cannot fit into the space provided on a
line. Impression uses a sophisticated algorithm to determine
exactly where a word should be hyphenated, if necessary.

Hyphenation exception The hyphenation method used in Impression is
accurate for more than 90% of words; however, some commonly
used words are hyphenated unusually. These words and the
correct hyphenation points can be included in the exception
dictionary for future reference by the hyphenation mechanism.

Icon A small, usually rectangular, image which is representative of an
object or function � a file icon for example. The icon can usually
be manipulated by the mouse pointer.

Import The process of introducing previously saved text or graphics to a
document.

Indent Either

the gap between the left margin and the start of a line or

the gap between the end of a line and the right margin.

Ink Jet printer A printer that produces its image by firing tiny jets of ink onto the
paper. Slightly faster than dot-matrix printers, and usually almost
silent, they can produce results than are almost as good as those of
a laser printer, but are much slower.

Input focus When a window or a dialogue box has input focus, all keypresses
are passed to that window. The window with input focus normally
has a light yellow title bar.

Italic text Slanted text. By convention this is usually slanted to the right:
italic text.

Justified text A body of text which is lined flush with either the left, right, or
both margins. In Impression, text can also be justified about the
centre of a page.

Kerning The process of altering the gap between certain pairs of characters
to improve their appearance. This is generally only useful at larger
text sizes - at smaller sizes the effect is negligible.
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Key short cuts Some functions within Impression are selectable without having to
resort to the mouse. For example, Ctrl-N selects Normal text. See
5. Keyboard short cuts.

Leader A row of characters, usually dots or dashes, filling the space
between two words separated by tabs. Useful for contents pages.

Leading (pronounced ledding.) This is the distance between the base of
one line and the next. This can be measured in points, or conven-
tional imperial or metric scales, amongst others.

Left justified text Where the left hand edge of text lines up with the left-hand
margin.

Left margin The margin which controls the horizontal position of the left-hand
edge of text (with the exception of the first line, which is con-
trolled by the 1st line margin).

Line art A graphic made up of lines and curves, rather than pixels as in a
sprite image file. Line art benefits from the expanded resolution of
certain screen modes or printing devices such as laser printers.

Loader module A program that can be loaded into Impression and which allows
files from other programs to automatically be translated into
Impression format and loaded in a frame.

Local frame A frame which does not appear on the master page, only on the
normal page. Local frames can be re-sized and moved around on
the page at will.

Master page A page layout which is used as the basis or template for normal
pages.

Master page frame A frame on a master page which appears on all pages based
on that master page. Master page frames can contain text, enabling
them to be used for headers and footers, or they can be left blank,
in which case they become Master text frames. New pages are
automatically created as text flows out of a master text frame,
removing the need for the manual creation of pages.

Menu The centre mouse button. This usually displays a menu.

Monospacing Where characters are spaced evenly regardless of their actual size.
The opposite of proportional spacing. Each line of monospaced
text has the same number of character spaces, so characters fall
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into defined columns. An example of a monospaced font is
Corpus, a version of the Courier typeface commonly used in
typewriters.

Mouse pointer The small icon that moves when the mouse is moved. It changes
its shape depending on what is below it on screen. For example,
when it is over some Impression text, it changes to a vertical
cursor, but when over an area of the page without frames, it
changes to a �hand�, indicating that the page can be dragged.

Multi-scan monitor A monitor that can change its scan rate to display much higher
resolution images than is possible with ordinary monitors.

Normal The default text style in Impression. See Style. 

Null frame An empty frame. A null frame can become either

a text frame, by typing into it or dropping a text file onto it, or a
graphics frame, by dropping a graphics file onto it.

Outline font A font that is designed as a series of lines and curves, as opposed
to a bitmap font which is designed as a series of pixels. Outline
fonts can be scaled to any size, and still retain smooth edges, while
bitmap fonts look jagged.

Page layout The chosen arrangement of text and graphics on a given page.

Paste The re-introduction of text or a frame from the clipboard to a new
place in a document. The clipboard contents will have been cut or
copied from another part of the document.

Pathname The name of a file including all the directories it is under from the
root, or $ directory. For example:

adfs::HardDisc4.$.sprites.MyPic

Pending style change A style change applied at the cursor position. It does not
take effect until something is typed.

Pica A unit of measurement used for typesetting. One pica is one-sixth
of an inch.

Pixel A pixel, or picture element, is an individual point in a picture.
Everything displayed on the computer screen can be described as
a collection of pixels of differing colours, in the same way as a
television picture is made up of individual coloured dots. A picture
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file that describes the picture in terms of pixels is known as a
�Sprite� file (see �Sprite�).

Point A unit of measurement used in typesetting. A point is equivalent to
1/72 of an inch.

Point size The height of a given font measured in points.

PostScript PostScript is a page description language, often used in laser
printers to reduce the amount of information a program needs to
send to print a page. On most printers, in order to print a complex
page containing text in different fonts and sizes, and graphic
images, a program would need to describe the page in terms of
individual pixels, which could mean describing the position of
over a million tiny dots. With PostScript, however, the program
need only send commands to tell the printer to, for example,
display a line of text at a certain position in a certain font and size,
or draw a line from one point to another. The PostScript program
in the printer creates an image from the commands it is given, then
print the page.

Preferences Those aspects of Impression which can be changed to suit your
personal taste. These include the default window scale, whether
frame outlines are shown, what units measurements are displayed
in and whether the spelling checker is automatically loaded. 3.14
Customising Impression gives full details of this feature.

Proportional spacing Where character width depends on the character. For
example, �i� is narrower than �m�. It is usually easy to tell if text is
proportionately spaced since, unlike monospaced text, characters
do not form regular columns down the page. 

Ragged text Where one side of a region of text is not flush with a given margin.
The opposite of justified text.

Repel text An option which forces text to flow around a frame rather than
over or under it. The distance between the frame boundary and
the start of bordering text is variable.

Return margin An alternative name for the 1st line margin.

Resolution A measure of how accurately a device can display an image.
Usually measured in Dots Per Inch (dpi).
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Right justified text  Where the right hand edge of text lines up with the right hand
margin.

Right margin The margin which controls the horizontal position of the right-
hand edge of the text.

Rule off A horizontal line drawn beneath a line or paragraph. A rule-off can
be set in the Style Editor.

Sans serif A font which does not feature serifs.

Saver module An additional program which can be loaded into Impression and
which allows text in Impression to be saved in varying formats.

Select The left hand mouse button.

Serif The embellishment of character designs made up of a small
projection finishing off the stroke of a displayed or printed letter.
Compare the capital �T� of Trinity font with the Homerton �T�. The
serifs at the ends of the horizontal T-bar, as well as the base of its
trunk, can be clearly seen in the Trinity version. The Homerton T
is finished without such embellishment and is referred to as sans
serif.

Sidebars These are thick vertical lines used in documents such as reports
and minutes to highlight important information or action points.

Snap An option to help you accurately align frames. If you drag a frame
around a page, it snaps to other frames it passes close to.

Sprite A picture described in terms of individual pixels - an icon for
example. Large bit-images, such as scanned images or pictures
created using art programs, are also saved as sprites. Sprites can be
re-sized, though they have a maximum displayable resolution.
Since sprites are made up of pixels, the larger you display the
sprite, the chunkier it looks.

Sprites should not be confused with line art images or draw files.
The latter are not defined as pixels. They are a collection of
geometric constructs which are re-drawn every time they are re-
displayed.

Story A specific part of an overall document. A story is a piece of text. A
text story will fill one or more frames in a document, flowing from
one frame to the next. A sequence of frames for a given story can
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be built.

String Any given series of characters, spaces included, of any length.

Style A named collection of text effects. There are default and user
defined styles in Impression. Styles can affect one or many aspects
of the way in which a given section of text is displayed. Among
the effects in a style are font, font size, line spacing, colours,
justification, margin settings and underlining. All text in an
Impression document is governed by at least one style - Normal.

Style attribute An individual feature of a style, which can be set in the Style
Editor. For example, font height, font colour or justification.

Subscript A miniature version of the displayed font which appears under the
baseline of the full-sized text.

Superscript As for subscript, except displayed along the top of the line of full-
sized text.

Tab stop Defines the starting position of the text on any line if the tab key is
pressed. Tab stops are defined on the rulers.

Task manager A feature of RISC OS which allows you to adjust the amount of
memory taken up by various functions, such as the fonts or the
relocatable modules. See the computer�s User guide for more
details.

Text frame A frame containing text. A text frame may contain text which has
flowed from another frame, and in turn it may flow text into
another frame. Frames connected in this way are said to contain
the same text story.

Text story A self-contained piece of text that is displayed in one or more text
frames.

Title bar The area at the top of a window which contains the window title.
The title bar of an Impression document window gives the
document name and the scale factor of the window. Holding
down the mouse button on the title bar allows the window to be
dragged around the screen, and even off screen.

Toggle Like an on-off switch - press the key once and the function is on,
then press it again and it is off.
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Truncated text Occurs when a frame contains more text than it can display and
there isn�t another frame into which the text can flow.

Window A rectangular area of the screen that displays all or part of a larger
area. A window can be seen as a �hole� in the screen through
which you can view a portion of a larger area. The area under-
neath can be moved around (scrolled) using scroll bars at the
edges of the window, allowing different parts to be seen. Win-
dows can be moved around the screen by dragging their title bars,
and they can overlap one another.

All documents in Impression are viewed in windows.
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Boot file 304
!Draw see Draw files
!Paint 177, 298-299

see also Sprites
!System 306
# wildcard (Search & Replace) 56

searching for 59
in Word list 233

* wildcard (Search & Replace) 56
on Title bar 12
searching for  59
in Word list 233

@ wildcard (Search & Replace) 56
searching for 59

+ on Toolbar 34
{Code 42} search string 59
{\42} search string 59
"/from cursor " in Style name 126
10% clip of graphic contrast 192
1st line margin 135, 139
2nd half (printing) 72

↑ 290
↓ 290
% 119
<cn> 51
<pn> 51

A
Abbreviation dictionary 238, 271
Abbreviation expansion 240-242, 271
About this manual i
Above paragraph space

see Space above paragraph
Above text switch (Style Editor) 124
Acorn advance 22

Acorn DTP loader 324
Acorn printer drivers 74
Action button in dialogue box 288, 303
Action buttons in Style Editor 108
Add 

an abbreviation 241
Footer 157
Header 157
to Exception dictionary 245

Adjust mouse button ii
Advance (from Acorn) 22
Advanced searching 59
Alert boxes 293
Aligning frames 160

see also Snap to frames
Alignment 35, 91, 119
Alt key 154
Alt-space 49
Alter chapter dialogue box

48, 203, 216-218
Alter frame dialogue box 

40, 169-174, 186
Alter frame tool 34, 169, 186
Alter graphics dialogue box 

169, 186-196
Alter graphics tool 34, 186
Alter master page dialogue box 208
Anagram (spell checking) 234
Angle of rotated graphics 180, 187
Angle in PostScript output 189
Application directory, look inside 304
Applied styles 98
Apply button on Style Editor 108-109

Index

 



Applying
Effects 83-85
Styles 99-101, 108

Arrow keys 41
ArtWorks 177, 183
Aspect ratio 

of text 112
of graphics 180, 187-188

Auto directory 242
Auto-indenting ruler 119, 132
Auto-loaded dictionaries 26, 267
Auto-saving 21
Automatic kerning tables 22
Automatic page creation & deletion 47
Automatic paragraph apply 99
Automatic Style naming 126
AvantG font 302

B
Background colour of text 104, 113
Backspace key 41
Backup a document 18
Basic file loader 322
Basics 7-28
Below text switch (Style Editor) 124
Bit-images see Sprites
Blank frame 33, 146, 148
Blank page, deleting 302
Bleed around page 207
Blinking cursor see Flashing cursor
Blue frame outline 147, 157
Bold text 35, 93-94, 111
Bold.Italic text 93
Borders 166-168, 173-174

colour 174
illustrated 311
list of 166
drop shadow borders 173

Bring to front (frames) 153
Bullet point 53-54, 280
Bump icons 290
Business cards 166
Button bar 31, 270

C

C source file loader 323
Camera-ready artwork 319
Cancelling see Removing
Canon BJ printers 67
Caption 161
Carriage -return, searching for 59
Centre decimal point 116
Centre page when printing 74
Centre tab 138
Centre-aligned 91
Changing 

a style ruler 132
frame stacking order 33, 153
master page frames 201
tab types 140
text margins 131
the default document 265
to a different master page 200
which Effects are applied 84

Chapters 209-218
Alter Chapter dialogue box 216-218
current number 31, 259
deleting 212
New Chapter dialogue box 213-215
number of 24
numbering 211
what are they? 211

Characters on the keypad 308
Character font 50, 87
Character Sets 307-310
Characters see text
Check spelling as you type 231, 271
Check spelling of word at cursor 232
Checking your document 319
Clear format files 177
Clear all effects 83-84, 86
Clear all styles 98
Clearing an editable field 304
Clipboard, description of use of 44
Close icon 11, 272
cm (centimetres) 291
CMYK colour model 193. 221

conversion to/from RGB 319-320
<cn> 51
Colour 219-224

correction 74, 273
of borders 174



of characters 88, 113
of frame background 174
fIelds in dialogue boxes 292
picker 221

Colour map dialogue box 190
Colour table (colour correction) 74, 273
ColourCard 296
Commercial Printing 319-320
Compile

dialogue box 259
index 258
list of contents 257

Composite output 77
Condensed font 87
Contents Generation 255-262

label (Style Editor) 116
pages 116

ContentsN style 257
Control characters, searching for 59
Copy 

key 41
master page 47-48, 215
previous page 47-48, 215
text 45
tool 33, 46, 149
to the clipboard 45

Corpus font 307
“Couldn’t find search string in text” 58
Courier font 316
Creating

PostScript and PDF files 317, 319
an auto-indenting ruler 132
duplicate frames 164
local ruler 131
new borders 167
new frames 148
new Style 102
new style ruler 131
pages 47
tables, grids, etc. 103
User dictionaries 238-239

Crop marks 77, 317
CSV files 249-250, 322

loader 323
Ctrl+Shift keys 16
Ctrl ↑ 290
Ctrl ↓ 290
Ctrl-2 43
Ctrl-A 43

Ctrl-B 92
Ctrl-C 45, 150
Ctrl-Copy 46
Ctrl-D 46
Ctrl-E 90
Ctrl-F 231
Ctrl-F1 23, 66
Ctrl-F2 14
Ctrl-F3 19, 32
Ctrl-F5 98
Ctrl-F6 98
Ctrl-F7 204, 213
Ctrl-F8 232
Ctrl-F9 15, 32
Ctrl-F10 169
Ctrl-F11 186
Ctrl-H 41
Ctrl-I 93
Ctrl-J 90
Ctrl-K 46
Ctrl-L 43
Ctrl-N 98
Ctrl-O 32, 270
Ctrl-P 129, 270
Ctrl-Print 64
Ctrl-Q 42
Ctrl-R 90
Ctrl-S 280
Ctrl-T 89
Ctrl-U (kerning) 90
Ctrl-U (clear editable field) 304
Ctrl-V 47, 150
Ctrl-W 230-231
Ctrl-X 46, 149
Ctrl-Z 43
Ctrl-Shift-A 208, 216
Ctrl-Shift-arrows 13
Ctrl-Shift-C 280
Ctrl-Shift-D 52
Ctrl-Shift-E 148
Ctrl-Shift-F 159
Ctrl-Shift-F1 14
Ctrl-Shift-F2 201
Ctrl-Shift-F3 17
Ctrl-Shift-F4 158
Ctrl-Shift-F9 53-54
Ctrl-Shift-F10 53-54
Ctrl-Shift-F11 16
Ctrl-Shift-H 280



Ctrl-Shift-I 148
Ctrl-Shift-J 94
Ctrl-Shift-K 94
Ctrl-Shift-L 88
Ctrl-Shift-N 277
Ctrl-Shift-O 71, 270
Ctrl-Shift-P 277
Ctrl-Shift-Q 280
Ctrl-Shift-R 31
Ctrl-Shift-S 88
Ctrl-Shift-T 87
Ctrl-Shift-U 93
Ctrl-Shift-W 277
Ctrl-Shift-Y 87
Ctrl-Shift-_ 280
Current 

chapter 212
chapter number 51
date 52
document 10
page number 24, 51, 301
story 56-57
time 52

Cursor 13
flashing 13, 270
going outside the frame 298

Custom page 204
Customising Impression 263-274
Cut tool 33, 46, 149
Cut & Paste 45
Cutting

frames 149
line 46
marks 166
text 46
word 46

Cutting to the clipboard 46

D
DDF

description 333-336
saving in old format 272

Decimal tab 138
Decimal tab character 116
Default 

action button in dialogue box 289
document 10, 200
    changing 265
master pages listed 200
window scale 269

Define button on Toolbar 34, 101
Define style by example 102
Delete button in Style Editor 109
Deleting

blank page 49
borders 167
chapters 212
characters 41
master pages 202
pages 49
text 46
unwanted Style 102
word from exception dictionary 245

Demi font variant 93
Deselecting a region of text 43
Deskjet see Hewlett Packard
Diagonally crossed lines in frame 182
Dictionaries see Spell Checking
Dimensions of frame 170
Dingbats font 120, 309
Directory, saving documents as 17
Directory window 304
Disc drives 295
Discard document (Icon Bar Menu) 14

(File Menu) 14
Dither graphics 181, 267
Document 

back-ups 18
current document 10
default document 10
discarding 14
loading 10, 22
opening a second window 14
removing 11, 14, 269
re-opening 11
saving 17-19
scrolling 13
sliding 13
starting new document 10

Dot Matrix printers 63, 69, 315
Double-click, defined 42
Double-sided printing 314
Draft printing 50, 316

the current story 319
Drag & Drop 45
Dragging frames 148
Draw files 20, 167, 177, 181,

 183-184, 298-299
Drawing lines 165
Drop shadow borders 174



E
Econet networks 9
Edit, saving to 20
Edit menu

Add Footer 157
Add Header 157
Alter chapter 201, 216
Alter master page 208
Copy frame 150
Copy text. 46
Cut frame 149
Delete chapter 212, 261
Delete master page 202
Delete page 49, 302
Delete text 46
Insert new page 48-49
New chapter 213
New master page 204
Paste frame 150
Paste text 47
Select text story 43

Editable fields 289
Editing an existing Style 109
Editing master pages 201
Effects 81-94

applying and removing 83-85
what are they? 83

Effects & Styles 104, 278
Effects menu 86

Alignment 35
Bold 35
Clear all effects 86
Italic 35
Line spacing 88
Keep together 92
Kern 89
Ruler 133
Subscript 94
Superscript 94
Text font 35, 88
Text size 35
Tracking 90
Underline 35, 93

Electronic mail system, saving to 20
em, defined 89
em (—) dash 272
Embed a graphic 159, 178
Embedded frames 147, 159
End of a paragraph 39

Entering text 39
Epson printers 67, 319
Equasor 177
Exception dictionary 237-238
Expand abbreviations 240, 242, 271
Expanded text 87
Exporting graphics 183

F
F3 18-19, 32, 184
F4 55
F5 91
F6 91
F7 91
F8 91
Facing pages 49, 205, 214

deleting 49
Fan-fold paper 314
File menu

Discard document 14
Info 23, 66
Preferences 17, 21-22
Print 64
Save document 18
Save graphic 183, 196
Save text/graphics/selected 19, 250

Film, printing to 80
Find (search & Replace) 55
Find dialogue box 55
Find next when spell checking 233-234
First line margin see 1st line margin
FirstWord Plus text file loader 324
Fit lots when printing 67, 71, 73, 77
Fit same pages when printing 73
Fit to frame (graphics) 188
Flashing cursor 13, 270
Flowing text stories 48, 154, 172
Font see also Text font

aspect ratio 112
dialogue box (Style editor) 111
family 86
matching 317
samples 307
size 112

see also Text size
Footers see Headers and Footers
Force to next frame 49
Forget (spell checking) 235, 245
Frames 143-174

background colour 174



boundaries 92
containing crossed lines 182
co-ordinates 189
handles 151
outlines 32
snap 32
tool 32, 148
types of 146

Frame menu
 Alter frame 149, 169
Alter graphic 186
Border import 167
Bring to front 153
Duplicate frames 164
Embed frame 159
Force to next 49
Group frames 162
Make irregular 157
Make regular 158
New frame  submenu 148
Put to back 153
Show irregular 158
Snap 157, 160-161
Ungroup frames 162

‘From cursor’ Style name 126
ft (foot) 291
Full colour printing 76-77
Fully justified text 49, 91
Fuzzy matching (spell checking) 233

G
Gaps, difference to margins 206
Glossary 337-347
Go to page/chapter 41
Graphic 19, 177

frame. 146
has been scaled 187
handling 175-196
tool 179, 283

Greek font 310, 318
Green frame outline 39, 147
Greyscale dithering 267
Grid 32, 120
Grid offset & spacing 207
Group frames 162-163
Guess 233, 236
Guess again  when spell checking 233
Guide frames 

48, 146, 153, 157, 160, 206
Guttering 205

H
Handles of frames 161
Hard space (character 160) 49
Headers and footers 155-157
‘Heap full’ error message 297
Help system 25
Hewlett Packard printers 68, 315-319
Hidden graphics 182, 188

 are not printed 183
Highlighted text 41
Hints & Tips 297-306

RISC OS 303-306
Home key 41
Homerton font 307
Horizontal crossed line in frame 182
Horizontal kerning 89
How Impression uses frames 145
HQS (high quality screening) 79
HSV colour model 193, 223
Hue (HSV colour model ) 223
Hyphenation 115, 243-245
Hyphenator 243, 267

I
Icon Bar Menu 12

Discard document 14
Info 23
Minimise memory 25
New view 11, 14
Preferences / Choices 266
Show flow 32
Quit 26

Ignore when spell checking 234-235
Ignore page border (printing) 66-67
‘Illegal character message’ 234-235
Importing borders 167
Importing text 44
Impression 

documents, structure of 211
Help system 25
quitting 26
versions 9, 331-332
window 10

Impression II 18, 22, 130
Impression Junior 22, 48, 130, 215
Impulse 254
in (inch) 291
In-memory transfer 21
Indents and hanging indents 140



Index compilation 259-261
Index label 101, 116, 258
Info boxes 23
Information dialogue box 195
Information field on Toolbar 32
Initial number 53
Ink-jet printers 63
Insert 

chapter number 51, 214
current date 33, 52
current page number 51, 214, 301
in spell checker 235-236
key 47
menu option 51
new page 48
tool 33, 51-52

Inserting an item 47
Inset from edge of frame 171
Inter-Word loader 324
Interactive help 25
Introduction 1-4
Irregular frames

 146, 152, 157, 168, 171,174
Italic text 35, 93-94, 112

J
JPEG file format, loading 177

K
Keep together 92, 121-122
Kerning 89-90, 278
Key (K), CMYK colour model 222
Key shortcut (in Style Editor) 107
Keyboard shortcuts 275
Knocks-out on separations 224

L

Landscape orientation 66, 205
Laser printers 63,72, 314
LaserDirect printers 63, 306
Laser Jet printers see Hewlett Packard
Leadering string 116
Leading, explained 119
Learn (spell check) 235, 237, 241, 245
Left aligned text 91
Left justified text 91
Left margin ruler icon 134, 139
Left tab 138
Left/right pairs see facing pages

Level (contents generation) 117, 257
Light-grey outline to frame 157
Line spacing 88, 103, 119

of 0 120
Linking frames 154
Linking graphics 181
Load a module 273
Load Target (spell checker) 236
Load targets in dialogue boxes 293
LoadASCII loader module 322
LoadBasic loader module 322
LoadC loader module 323
LoadCSV loader module 323
LoadDTP loader module 324
Loader module, importing text 44, 321
LoadFWP loader module 324
Loading 

alien file formats 321
Advance documents 22
an existing document 10
from Impression II &
         Impression Junior 22
graphics 178
Impression 9
Loader Modules 321
text files 301
the main word list 228

LoadIWord loader module 324
LoadPDream loader module 324
LoadReturn loader module 325
LoadRTF loader module 327
LoadView loader module 328
LoadWP42 loader module 328
LoadWStar loader module 329
Local frames 48, 147, 171
Local ruler 92, 129, 131
Lock aspect (Alter graphic) 180, 188
Lock in place (Alter frame) 148, 170
Lock to page grid 120, 207
Lock values (Alter graphic) 178, 188
Looking in application directory 304

M
m (metres) 291
Magazine-type page layouts 146
Mail merging 247-254

using database applications 254
using Start mail merge 252

Main dictionary menu option 237
Main Menu 12



see also individual submenus
Main word list 228
Make local (frames) 171, 201
Margins, difference to gaps 206
Master 191-192
Master pages 197-208

frames 147, 150, 171
name 204
summary 203
window 203

Measurement units in Impression 291
Medium font variant 87
Memory 295

management 25
problems 297

Menu mouse button ii
Menu options, Select/Adjust clicks 303
Menu option is greyed 297
Merge in Style Editor 109, 126
Merge command menu option 254
Merge from cursor 126
Merging Styles 126
Minimise memory (Icon Bar Menu)

25, 182
Misspellings 227
Mistyping 227
mm (millimetre) 291
Modifying Styles 101
Module area 297
Modules 266, 273, 327
Moiré patterns 79
Monitors 296, 299

Multisync 296, 299
Mouse buttons ii
Mouse operations 281
Mouse pointer 13
Move backward tool 153
Move forward tool 153
Move 

around the text 41
blocks of text 45
cursor 41
graphics 180
items on the ruler 136, 139
to a specific page or chapter 41
to start or end of line 41
to start or end of story 41

Multiple selection of frames 161-163
Multisync monitor 296, 299
My screen isn’t wide enough! 298

N
New chapter dialogue box 213-215
New frame 33, 300
New master page 208
New master page dialogue box 204
New rule offs 22
New style 98, 109
New view (Icon Bar Menu) 11, 14

on View menu 14
No illustrations 70, 316
‘No room in RMA’ 228, 234, 237
Non-standard page size 204
Normal pages 199
Number 206

of chapters 24
of pictures 24
of text stories 24
of words 24, 212, 332
region 54

O
Object Linking & Embedding see OLE
Oblique text 93
Offset 112-114, 124, 164, 207
OLE 177, 184-185
On-line documentation 25
Opening a second window 14
Orange frame outline 147
Order in which Styles were applied 100
Orphans 121
‘Out of memory’ message 297
Outdent 141
Overlapping frame 153
Overlaying Styles 100
Overprint 78, 224
Overwrite mode 44

P
Page 

border 70
control 207
creation 215
current number 24
grid 161
movements 277
number 31
rulers 129, 268, 270
size 204, 313
unit 268



units and Style units 291
PageDown key 14
Pages, when printing 63
PageUp key 14
Pamphlet printing 71
Pan handle (graphics tool) 180
Paper, when printing 63
Paragraph 

apply switch 101, 108, 118
dialogue box 118
numbering 54
space above/below 108, 118, 260

Paste 33, 46-47
& Inserting 279
tool 47

Pause button (printing) 65
Pembroke font 307
PhotoCD files, loading 177
pi (picas) 291
PipeDream 322-324
Place extra tabs on the ruler 136
Placing items on the ruler 139
Plain text, saving 20, 44
<pn> 51
Pointers 13
Points (pt) 112
Portrait orientation 66, 205
PostScript 316

printers 63, 65, 70, 316
screen 78

Preferences (Icon Bar Menu) 266-273
Previous zoom 16
Print 33, 64-65, 251, 317

a pamphlet 71
all records 251
border 70
dialogue box 64-80
information box 65
setup dialogue box 69
margins 67
tool 64

Printers & Draft printing 313-320
Printer resolution 79
Printers 296
Printers marks 76
Printing 61-80, 305
Process colours 319
PSprolog 316
pt (points) 291

Put to back (frames) 153

Q
Quality menu option 34, 183
Quit (Icon Bar Menu) 27, 242, 305
Quitting Impression 27

R
Radio switches 288
Ragged-left text 91
Ragged-right text 91
Recommended equipment 295-296
Rectangle, when scaling 16
Red arrow in frame 40
Redefine style 102
Reflect page 80
Registration black 224
Registration marks 76-77
Remove 

a local ruler 133
a module 274
a ruler from a style 133
a Style 101
a style ruler from the text 133
an Effect 85
document from memory 14
document on close 11, 14, 272
items from the ruler 140
sequence numbers 55

Rename a document 26
Repeating frames 155
Repel 152, 171
Repel distance 171
Repel text outside 152, 171
Replacing text (overwrite mode) 44
Report boxes 294
Resizing frames 151
Resizing graphics 179
Restart page at 214, 217
Return key ii, 39, 289
Return margin see 1st line margin
Return stripper 325
Reverse 73
RGB colour model 192, 221
Rich Text Format (RTF) loader 327
Right align text 91
Right justified text 91
Right margin 134, 139
Right pages 214
Right tab 138



RISC OS hints and tips 303
RISC OS 2 267
RMA 298
Rotate a graphic frame 158
Rotate handle, graphics tool 180
Rotate the graphic 180, 187
Rule-offs 22, 104, 123

above 124
below 124
colour 125
margins 135

Ruler 92, 119,127-142, 279
icons 134
in Impression 129
measurement units 137
shown on Toolbar 130

Rules dialogue box 123
Rules-offs 103

S
Saturation (HSV colour module) 222
Save 

Abbreviation dictionary 242
as default 265, 301
as text 239
documents 17-21, 32
file 184
graphics 19
old DDF format 272
plain text 20
Preferences dialogue box 266
selected text 19
text 19, 21, 266
text or graphics 32
stories 19
tool 18-19
text story 19, 319
User dictionaries 238-239

Scale 187-188
handle 179
the frame and the graphic 158
tool 15, 16

Scale view dialogue box 15
Scaling 15, 16,32, 67, 71-72

see also Zoom tool
Scaling your view 14
Scanned photographs 192
Scanners 177, 296
Scrapfile 306
Screen angle 79-80

Screen density 78
Screen isn’t wide enough! 298
Screen modes 15, 31
Screen type 79
Scroll bars 13, 303
Scrolling the document 13
Search & Replace 55
Search whole document 56, 273
Second window, opening 14
Select mouse button ii, 168
Select 

a line 43
a paragraph 43
a region of text 41
a word 42
overlapping frames 153
story 43
text 279
text story 43

Selected 
frame 39
region ends 41

Separation names 76
Separations, producing 77
Sequence numbering 52
Set Palette 223
Set values 65
Sexless quotes 250, 272
Shape of the mouse pointer 13
Shift-F2 to Shift-F11 16
Shift-Tab 290
Show 

all graphics 182
button bar 270
flow 40, 120, 155
flow tool 32, 40, 155
frame outlines 32, 269
irregular 158
on style menu 99, 108
page rulers 129, 270
print borders 270
ruler bar 270
short cuts on menu 271
text/ruler bar 270

Shutdown 26
Sidebars 103
Sideways printing 71
Single file format for saving 16-17
Size of document 24
Size of the frame 170



Slide the document 13
Sliders 292
Smart quotes 250, 272
Snap to all frames 272
Snap to frames 160
Snap to grid 160, 207
Snap to guides 206
Snap tool 160
Soft-hyphen 244-246
Space bar ii
Space above paragraph 108, 118, 260
Space below paragraph 

39, 118-119, 259
Spacing 120, 207
Spell checking  33, 225-246, , 267, 271
Spell checking your document 230
Spelling 280
Spot pattern 189
Spot-colour work 78
Sprite files 299
Sprites 177, 181, 183, 187, 267
Star LC10 printer 318
Start mail merge menu option 251-252
Starting a new document 10
Stop printing 65, 72
Strikeout 115
‘String too short’ message 234-235
Style Editor 106-126
Style menu 97
Styles , 95-126

buttons 59
list 98, 101
name 108, 126
ruler 129, 131
summary 105
unit 268

Styles in Search & Replace 59
‘Style1/Style2’ in Style name 126
Subscript 94, 112-113
Subsequent number 54
Superscript 94, 112-113
Superscript 1, 2, 3 94
Switches 287
Swop case 60, 280
Swop two characters 280
!System 306
System folder 306
System font 50
System Sprite area 297

T
Tab character, searching for 59
Tab key 290
TableMate 104, 177
Tabs 138-139
Take styles 102
Telephone numbers 49
Telephone symbol 120
Template document 104, 107
Text 

cursor 13
bar 34
colour 88
dialogue box 114
files 322
font 86, 111
found dialogue box 57
frame 146
from other documents 44
handling 37-60
rulers 129
size 87, 112

Thesaurus 227
Thickness of rule-off 123
Tick against a Style name 84
TIFF files 177, 183
Title bar decribed 12
‘Too many files open’ message 9
Toolbar 29-36, 65
Tracking 89-90, 115
Transparent frame 151-152, 174
Transpose characters 280
Trinity font 307
Truncated text 40, 59
TurboDriver software 68, 75, 306
Twin, saving to 20
Types of frame 146
Typeset separations 224
Typesetting dialogue box 76, 189
Typo matching (spell checking) 233
Typographic conventions 2

U
‘Unable to delete word’ message 235
Under/Strike colour 115
Underline 35, 93, 114
Ungroup frames 162
Units recognised by Impression 291
Units used on the ruler 36



Unknown fonts 318
Unsaved changes 12, 14, 24
‘Untitled Style’ name 126
Updating ABI 285-286
Use recommended angles 79
User dictionaries 229, 239
USERDICT 237
Using 

Dialogue Boxes 287
Impression 5
master pages 200
Styles 99

Utilities menu
Abbreviations 241
 Expand as you type 240
  Dictionary 240
  Expand as you type 242
Compile contents 257, 259
Compile index 258-259
Compile font usage 319
Find text 55
  Go to chapter 41
  Go to page 41
Insert 33, 51
  Current chapter number 211, 214
  Initial number 53
  Number region 53
  Subsequent number 53
Merge command 254
Save as default 265
Spelling 33, 231-232
  Check as you type 231
  Check word 230
  Dictionary 228, 232
Start mail merge 251
Thesaurus 227

V
Version number 23
Vertical inset in frames 171
Vertical kerning 89
Vertical rule 103, 123, 138-139, 206

width 103, 125, 139
View 169, 172-173, 188, 300
View dialogue box 173
View file loader 328
View menu 

Hide all graphics 182
Master pages 150, 201, 203, 300
New view 14

Page rulers 129
Print borders 71, 270, 314
Quality 34, 183
Scale view 14, 15
Show all graphics 183
Tool bars 31
  Show button bar 270
  Show ruler bar 130, 270
  Show text/ruler bar 131, 270

W
What are 

chapters? 211
Effects? 83
graphics? 177
master pages? 199
Styles? 97

Whole document search 56-58
Width of columns 206
Wildcard in Search & Replace 56

in Word list 233
Wimp$Scrap 306
Windows 303
Wire-frames 183
Word count 24, 212, 332
Word for DOS 328
Word for Windows 328
Word list 232

dialogue box menu 237
‘Word not found’ message 235
Word on the Macintosh 328
Word pairs 49
WordPerfect loader 328
WordStar loader 329
Wordwise Plus 329
WYSIWYG, explained 4

X, Y, Z
X offset 164

page grid  207
X-Y coordinates of frames 170

of graphics 185

Y offset, page grid 207
Y offset (duplicate frames) 164
yd (yard) 291
Yellow Title Bar 10
Yellow ‘moat’ in dialogue boxes 289

Zoom tool 15, 16 (see also Scale tool)


